LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Postfix Mail Connection to SMTP Server (http://www.linuxquestions.org/questions/linux-networking-3/postfix-mail-connection-to-smtp-server-418980/)

zeraia77 02-24-2006 12:38 AM

Postfix Mail Connection to SMTP Server
 
In my Intranet LAN I install Linux SuSE Version 10.0.
Sofar I Install and configure all the Network Services mostly I use the defaults.
It has been two weeks since I install and configure Postfix. Every time I want to test the Postfix using the KMail 1.8-2 (using KDE 3.4.2 Level 'b' SuSE 10.0), I receive error message "Sending of message failed. The message could not be sent because connecting to SMTP server vita.mama.com failed. The server may be unavailable or is refusing SMTP connections." or "Sending failed. Could not connect to host vita.mama.com".
Looking some suggetions I try to telnet to the host, i.e.
telnet localhost 25
telnet localhost smtp
telnet localhost 10025
and I receive response "Trying 127.0.0.1 ... Connected to localhost Escape character is '^]'
220 vita.mama.com ESMTP ^] telnet > quit
Which it sound good, but when I try to
telnet vita.mama.com 25
telnet vita.mama.com smtp
telnet vita.mama.com 10025
or
telnet 192.168.113.6 25
telnet 192.168.113.6 smtp
telnet 192.168.113.6 10025
the response I receive is:
Trying 192.168.113.6 ...
telnet: connect to address 192.168.113.6: Connection refused

So please who can help.

Thanks

ctkroeker 02-24-2006 12:57 PM

Please post your question in it's apropriate forum.
This post has been reported and will be moved by a moderator.

XavierP 02-25-2006 11:32 AM

Moved: This thread is more suitable in Linux-Networking and has been moved accordingly to help your thread/question get the exposure it deserves.

trainpic 02-25-2006 11:52 AM

Can you post your postfix configuration file?
Is vita.mama.com the same machine that you are running kmail on? (it would seem so)

Try configuring kmail with localhost instead of vita.mama.com. Postfix may be configured to only accept connections on the lo device and not eth0.

zeraia77 03-05-2006 01:50 AM

Quote:

Originally Posted by trainpic
Can you post your postfix configuration file?
Is vita.mama.com the same machine that you are running kmail on? (it would seem so)

Try configuring kmail with localhost instead of vita.mama.com. Postfix may be configured to only accept connections on the lo device and not eth0.

I resolve the problem, it was master.cf configuration parameter of SuSE.


All times are GMT -5. The time now is 07:28 AM.