LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-31-2005, 10:36 PM   #1
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Rep: Reputation: 30
Postfix LDAP lookups with Active Directory


hi there,

i'm trying to get postfix to run with Active Directory so i can logon to my e-mail useing my ADS account and get the aliase from the 'mail'
section of my container.

now when i try and run what is ment to be a test for this i get this error, now i know it's a microsoft LDAP error as shown with the link below.

http://archives.neohapsis.com/archiv...3-06/3121.html

so i'm wondering if someone knows how to get arount this?

[root@rhel /]# postmap -q pma ldap:/etc/postfix/ldap-aliases.cf
postmap: warning: dict_ldap_lookup: Search error 9: Partial results and referral received
 
Old 11-02-2005, 08:44 PM   #2
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
i have found a website that seams promising, although i don't
read any languages other than english.

http://www.myunix.idv.tw/mx/forum/printview.php?
t=476&start=0&sid=f67b4d66a3643eb7f38fda3b97983145

but towards the bottom is does mention my error messsage.

發現升級至 Windows 2003的Active Directory後,在/var/log/maillog
中會出現類似以下訊息

代碼:
Sep 21 10:02:54 mail postfix/smtpd[21129]: warning:
dict_ldap_lookup: Search error 9: Partial results and referral
received
Sep 21 10:02:54 mail postfix/smtpd[21129]: 5B7A4137642:
reject: RCPT from x.x.x.x[x.x.x.x]:
451 <vincent@myunix.idv.tw>: Temporary lookup failure;
from=<zoob@ms13.url.com.tw> to=<vincent@myunix.idv.tw
> proto=SMTP helo=<myunix.idv.tw>


【訽因】

因為Windows 2003已經使用LDAP v3的協定,所以如果在main.cf裡面沒
有指定ldapsource_verion = 3 的話,預設會使用LDAP v2與Win 2003
AD來連結

【解決】

(1)請在main.cf裡面加入以下敘述

代碼:
ldapsource_verion = 3

(2)重新啟動 postfix service

from what i can make out of that i need to
add, 'ldapsource_verion = 3' to my main.cf file and restart
postfix. i did that but still nothing.

i'm still looking for the answer, so if anyone out there finds the answer in here, can they tell me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Active Directory vs LDAP alex r Linux - Software 26 04-07-2010 04:47 AM
LDAP and Active Directory Ecalvam Linux - Networking 5 11-10-2005 08:53 AM
Active Directory, Kerberos, LDAP, PAM, and nsswitch PenguinPwrdBox Linux - Security 1 06-04-2005 09:56 PM
samba ldap winbindd kerberos with active directory errors xtrusion Linux - Software 0 03-21-2005 04:24 PM
migration from windows active directory to linux ldap spyghost Linux - Networking 1 08-01-2004 12:26 PM


All times are GMT -5. The time now is 09:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration