LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-22-2007, 11:34 PM   #1
CSandman
Member
 
Registered: Mar 2007
Distribution: Xubuntu
Posts: 33

Rep: Reputation: 16
possible DNS problems in ubuntu Feisty


Hey guys,
I just upgraded to Ubuntu's newest release, I know I know its still in alpha till this weekend but i couldn't wait! Just about everything went fine! In Edgy everything worked great except for my wireless card and the drivers for my graphics card which was a big incentive to try feisty. In feisty now my wireless card is recognized and i can connect and everything works fine on my university's wireless networks but on my home network it is really really slow! Using the network tools I can ping every website I've tried but the traceroute gets about half way there and times out. I've disabled ipv6 system wide and in firefox, and I've tried through the network manager to set the DNS addresses. For some reason Network manager tends to change the DNS back to my router IP. I've also attempted to change the DNS addresses in /etc/resolv.conf but same thing, the file comments that the file is generated by network manager so I believe it is replaced everytime network manager starts up. I'm not sure what to do about this.

I'm running a new Toshiba Satellite Pro A100-ED5 with the following specs...
network card: Atheros AR5006EG chipset
Graphics Card: ATI Xpress 200m graphics card
Audio Card: ATI HDA SB450 Audio card
Its an Intel Celeron with a gig of ram
//Just as a comment everything works fine (including my wireless network) in windows XP

Thanks in advance for the help!
 
Old 03-24-2007, 08:06 AM   #2
saavik
Member
 
Registered: Nov 2001
Location: NRW, Germany
Distribution: SLES11 / FC20/ OES / CentOS
Posts: 606

Rep: Reputation: 32
Correct!

AFAIK the network manager can change the resolve.conf.

You should be able to switch this of (as you do not like what he does). But I can not remember where that was....
 
Old 03-24-2007, 08:28 AM   #3
digen
Member
 
Registered: Dec 2005
Location: India
Distribution: Ubuntu Feisty Fawn
Posts: 107

Rep: Reputation: 15
A wild idea.. you could edit the file /etc/resolv.conf with the name server entries you want to use. You could then make the file immutable,

Quote:
digen@emily:~$ chattr +ia /etc/resolv.conf
Quote:
digen@emily:~$ lsattr /etc/resolv.conf
----ia----------- /etc/resolv.conf
This way the file /etc/resolv.conf wouldn't get overwritten when getting an IP address via DHCP. Do correct me if I'm wrong.
 
Old 03-24-2007, 09:41 AM   #4
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
I would do it by editing /etc/dhclient.conf. What is written above seems like it should work, but you'll have to undo that every time you go to a different network. You'll have to do that with my method as well, but it is just adding/removing a comment in one line of a file, not messing with its permissions.

In /etc/dhclient.conf, you have a line that is commented out that says:
Code:
#  option domain-name-servers 127.0.0.1;
I would remove the comment at the beginning of the line, and change the IP address from 127.0.0.1 to whatever the correct address(es) are for the name server that you want. It should look like:
Code:
option domain-name-servers A.B.C.D;
Then if you take your laptop somewhere else, the DNS you specify normally isn't likely to work. In this case, put the comment back in the line discussed, and restart the networking. You'll get a DNS server from DHCP in that way, and you can again uncomment it when going back to school.

Peace,
JimBass
 
Old 03-26-2007, 09:08 AM   #5
CSandman
Member
 
Registered: Mar 2007
Distribution: Xubuntu
Posts: 33

Original Poster
Rep: Reputation: 16
What if by a strange coincidence there is absolutely nothing in the file /etc/dhclient.conf ? I tried adding the line that you suggested I uncomment, so it was the only line in the file and it didn't do anything.

I have a sneaking suspicion that it might be the way my router is talking to my feisty install because although wireless doesn't work in edgy a wired connection works just fine.

Any other suggestions?
 
Old 03-26-2007, 09:31 AM   #6
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Two things. First, it is possible the Ubuntu guys put the file in a subdirectory, maybe something like /etc/dhcp? I would search for the file with this command -

Code:
find /etc -name dhclient.conf -print
If it is in a different location, just edit it where it stands.

If you actually don't have one, that makes things more complicated. I can give you the full text of my file, but if your system don't have it, simply adding it won't get it read, it needs to be called by some other process.

Did you upgrade your old install to Feisty, or did you reinstall? It is possible you have bad firmware that allows unencrypted wireles traffic, but not encrypted. Please check to see if you have firmware installed for your wireless card.

Peace,
JimBass
 
Old 03-28-2007, 12:19 AM   #7
CSandman
Member
 
Registered: Mar 2007
Distribution: Xubuntu
Posts: 33

Original Poster
Rep: Reputation: 16
It is a fresh install from the Beta iso recently released and the restricted drivers manager is using the most recent drivers for my card, so I don't think its that. I will try and find the file you mentioned though, I've noticed that although ubuntu is a great distro they have a couple of things in different places so its sometimes a problem on a site that deals with so many distros! I'll get back to you when I have a chance to see what I can see.
 
Old 04-03-2007, 01:14 PM   #8
tominglis
LQ Newbie
 
Registered: Apr 2007
Location: Edinburgh, Scotland
Distribution: Kubuntu / CentOS
Posts: 1

Rep: Reputation: 0
Feisty networkmanager slow DNS problems.

Hi guys,

I am having a similar problem in Feisty.

Whether I connect via ethernet or wireless, networkmanager assigns the router's IP as the top DNS server, and this seems to cause substantial delays when looking up DNS addresses. When I manually remove this IP from the list, lookup speeds are back to normal.

Have you found a solution to this yet?

Tom
 
  


Reply

Tags
dns, feisty fawn, ubuntu, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compiling vmware module in ubuntu feisty fakie_flip Linux - Software 5 05-04-2007 07:12 PM
LXer: Ubuntu Feisty beta delayed LXer Syndicated Linux News 0 03-22-2007 07:16 PM
Ubuntu Feisty CDMA modem +TV tuner installation problem farhadali05 Linux - Software 0 03-11-2007 06:58 AM
LXer: Ubuntu says no to non-free video drivers for Feisty LXer Syndicated Linux News 0 02-14-2007 02:16 AM
LXer: Ubuntu Feisty Fawn Herd 3 Released LXer Syndicated Linux News 0 02-03-2007 01:54 AM


All times are GMT -5. The time now is 11:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration