LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-04-2003, 02:05 PM   #1
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Rep: Reputation: 15
poptop: pptp - err Port Not Connected.


Trying to use POPTOP / PPTP for VPN access to my home network from work.

Redhat 9.0 Server running latest POPTOP / PPTP

when I try to connect, it gives me:

619: the specified port is not connected.

the server log shows:

Nov 4 14:00:06 trekkserver pptpd[17427]: CTRL: Client 66.156.205.235 control connection started
Nov 4 14:00:06 trekkserver pptpd[17427]: CTRL: Starting call (launching pppd, opening GRE)
Nov 4 14:00:06 trekkserver pppd[17428]: invalid address parameter '<ip-of-your-winsserver>' for ms-wins option
Nov 4 14:00:06 trekkserver pptpd[17427]: GRE: read(fd=5,buffer=804d920,len=8196) from PTY failed: status = -1 error = Input/output error
Nov 4 14:00:06 trekkserver pptpd[17427]: CTRL: PTY read or GRE write failed (pty,gre)=(5,10)
Nov 4 14:00:06 trekkserver pptpd[17427]: CTRL: Client 66.156.205.235 control connection finished

Ideas?
 
Old 11-04-2003, 02:13 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
invalid address parameter '<ip-of-your-winsserver>' for ms-wins option

means it doesn't like this entry in your /etc/pptpd.conf file

And have you recompiled the kernel for GRE?
 
Old 11-04-2003, 02:18 PM   #3
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
don't know how to recompile... didn't know I needed too....

Will check the conf file in just a sec.
 
Old 11-04-2003, 02:19 PM   #4
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
pptpd.conf

option /etc/ppp/options.pptpd
localip 192.168.0.10
remoteip 192.168.0.200-254

?
 
Old 11-04-2003, 02:43 PM   #5
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Whoops, going too fast for myself there...

Check /etc/ppp/options.pptpd and correct the ms-wins entry or comment it out.
Check the ms-dns entry as well.

The kernel needs to have support for gre protocol.
This is a recompile of the kernel to make the gre and pptp modules for your specific kernel.
 
Old 11-04-2003, 02:48 PM   #6
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
Yea... figured that out after the last post and already # it out.... now get:

Nov 4 14:31:06 trekkserver pptpd[18056]: CTRL: Client 66.156.205.235 control connection started
Nov 4 14:31:06 trekkserver pptpd[18056]: CTRL: Starting call (launching pppd, opening GRE)
Nov 4 14:31:06 trekkserver kernel: application bug: pppd(18057) has SIGCHLD set to SIG_IGN but calls wait().
Nov 4 14:31:06 trekkserver kernel: (see the NOTES section of 'man 2 wait'). Workaround activated.
Nov 4 14:31:06 trekkserver kernel: CSLIP: code copyright 1989 Regents of the University of California
Nov 4 14:31:06 trekkserver kernel: PPP generic driver version 2.4.2
Nov 4 14:31:06 trekkserver pppd[18057]: pppd 2.4.2b3 started by root, uid 0
Nov 4 14:31:07 trekkserver pppd[18057]: Using interface ppp0
Nov 4 14:31:07 trekkserver pppd[18057]: Connect: ppp0 <--> /dev/pts/1
Nov 4 14:31:07 trekkserver /etc/hotplug/net.agent: assuming ppp0 is already up
Nov 4 14:31:37 trekkserver pppd[18057]: LCP: timeout sending Config-Requests
Nov 4 14:31:37 trekkserver pppd[18057]: Connection terminated.
Nov 4 14:31:37 trekkserver pppd[18057]: Exit.
Nov 4 14:31:37 trekkserver pptpd[18056]: GRE: read(fd=5,buffer=804d920,len=8196) from PTY failed: status = -1 error = Input/output error
Nov 4 14:31:37 trekkserver pptpd[18056]: CTRL: PTY read or GRE write failed (pty,gre)=(5,10)
Nov 4 14:31:37 trekkserver pptpd[18056]: CTRL: Client 66.156.205.235 control connection finished
Nov 4 14:31:37 trekkserver /etc/hotplug/net.agent: NET unregister event not supported
 
Old 11-04-2003, 03:02 PM   #7
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
When I lsmod, I get

ppp_mppe
bsd_comp
ppp_async
ppp_generic
slhc
8139too
mii
ip_nat_pptp
ip_nat_proto_gre
ip_conntrack_pptp
ip_conntrack_proto_gre
ipt_REJECT

(The last 4 are from the patch-o-matic kernel updates to allow more than one pptp connection at a time.)

Do you get the first 4 showing?
Try insmod ip_gre. This is the new module after compiling the new kernel and modules.

If not, you will need to add GRE and PPTP support in your kernel.
 
Old 11-04-2003, 03:05 PM   #8
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
I get...

#insmod ip_gre

Using /lib/modules/2.4.20-20.9/kernel/net/ipv4/ip_gre.o
 
Old 11-04-2003, 03:22 PM   #9
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
When I lsmod I get:

Module Size Used by Tainted: P
ip_gre 11072 0 (unused)
ppp_async 9440 0 (autoclean)
ppp_generic 24572 0 (autoclean) [ppp_async]
slhc 6756 0 (autoclean) [ppp_generic]
lvm-mod 64000 0 (unused)
nvidia 1764992 11 (autoclean)
binfmt_misc 7432 1
parport_pc 19076 1 (autoclean)
lp 8996 0 (autoclean)
parport 37056 1 (autoclean) [parport_pc lp]
autofs 13268 0 (autoclean) (unused)
ipt_ttl 1144 1 (autoclean)
ipt_unclean 8024 2 (autoclean)
ipt_limit 1560 34 (autoclean)
ipt_state 1080 7 (autoclean)
iptable_mangle 2776 0 (unused)
ipt_LOG 4184 1
ipt_MASQUERADE 2200 0 (unused)
ipt_TOS 1656 0 (unused)
ipt_REDIRECT 1368 0 (unused)
iptable_nat 21752 0 [ipt_MASQUERADE ipt_REDIRECT]
ipt_REJECT 3992 0 (unused)
ip_conntrack_irc 4112 0 (unused)
ip_conntrack_ftp 5296 0 (unused)
ip_conntrack 27272 4 [ipt_state ipt_MASQUERADE ipt_REDIRECT iptable_nat ip_conntrack_irc ip_conntrack_ftp]
iptable_filter 2412 1 (autoclean)
ip_tables 15096 14 [ipt_ttl ipt_unclean ipt_limit ipt_state iptable_mangle ipt_LOG ipt_MASQUERADE ipt_TOS ipt_REDIRECT iptable_nat ipt_REJECT iptable_filter]
8139too 18120 1
mii 3976 0 [8139too]
sg 36524 0 (autoclean)
sr_mod 18136 0 (autoclean)
microcode 4668 0 (autoclean)
ide-scsi 12208 0
scsi_mod 107544 3 [sg sr_mod ide-scsi]
ide-cd 35712 0
cdrom 33728 0 [sr_mod ide-cd]
raid1 14956 1 (autoclean)
keybdev 2976 0 (unused)
mousedev 5556 1
hid 22244 0 (unused)
input 5856 0 [keybdev mousedev hid]
usb-uhci 26412 0 (unused)
usbcore 79040 1 [hid usb-uhci]
ext3 70784 2
jbd 51924 2 [ext3]
 
Old 11-04-2003, 04:11 PM   #10
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
We need to be sure that your kernel does/doesn't have GRE support ...

Please do grep GRE /boot/config-2.4.20-20.9
(Put your kernel version in there).
 
Old 11-04-2003, 04:14 PM   #11
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
CONFIG_NET_SCH_GRED=m
CONFIG_NET_SCH_INGRESS=m
CONFIG_NET_IPGRE=m
CONFIG_NET_IPGRE_BROADCAST=y
 
Old 11-04-2003, 04:20 PM   #12
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Excellent, it is in there..

So, now to make some changes to your /etc/ppp/options.pptpd
Mine has...

lock
noauth
mtu 1450
mru 1450
ipcp-accept-local
ipcp-accept-remote
lcp-echo-failure 3
lcp-echo-interval 5
nodeflate


## turn pppd syslog debugging on
debug

## change 'pptpd' to whatever you specify as your server name in chap-secrets
name pptpd

proxyarp
#nobsdcomp

# This option applies if you use ppp with chapms-strip-domain patch
#chapms-strip-domain

# These options apply if you use ppp with mppe patch
# NB! You should also apply the ChapMS-V2 patch
-chap
#+chap
-chapms
#require-chapms-v2
+chapms-v2
#refuse-pap
#refuse-chap
#refuse-mschap
#-eap
#mppe-40
mppe-128
#require-mppe
mppe-stateless

Similar to yours?
 
Old 11-04-2003, 04:33 PM   #13
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
## CHANGE TO SUIT YOUR SYSTEM
lock

## turn pppd syslog debugging on
debug

## change 'pptpd' to whatever you specify as your server name in chap-secrets

# Don't need this
nobsdcomp

# Tell pptpd to find local interface and put it in proxyarp mode
proxyarp

# This option applies if you use ppp with chapms-strip-domain patch
#chapms-strip-domain

# These options are for use with the OpenSSL-licensed patch
# This flavor will be obsoleted ASAP.

# These options are for use with the OpenSSL-licensed patch
# This flavor will be obsoleted ASAP.
# NB! You should also apply the ChapMS-V2 patch
-chap
-chapms
+chapms-v2
#mppe-40 # both 40-bits and 128-bits encryption bite eachother
mppe-128
mppe-stateless

# These options are for use with the BSD-licensed patch (ppp => 2.4.2)
# This is the default implementation
#refuse-pap
#refuse-chap
#refuse-mschap
#require-mschap-v2
#require-mppe

# These options will tell ppp to pass on these to your clients


# These options will tell ppp to pass on these to your clients
# To use ms-dns or ms-dns in options.pptpd it must exist in /etc/resolv.conf
#ms-wins <ip-of-your-winsserver>
#ms-dns <ip-of-your-dnsserver>


noauth
 
Old 11-04-2003, 04:37 PM   #14
trekk
Member
 
Registered: Oct 2003
Location: Charlotte, NC
Distribution: Fedora Core 6
Posts: 66

Original Poster
Rep: Reputation: 15
Changed the chap sections to what I just posted - and restarted pptpd: same error but different in the log...

Nov 4 16:35:11 trekkserver pptpd[18483]: CTRL: Client 66.156.205.235 control connection started
Nov 4 16:35:11 trekkserver pptpd[18483]: CTRL: Starting call (launching pppd, opening GRE)
Nov 4 16:35:11 trekkserver pppd[18484]: In file /etc/ppp/options.pptpd: unrecognized option '-chapms'
Nov 4 16:35:11 trekkserver pptpd[18483]: GRE: read(fd=5,buffer=804d920,len=8196) from PTY failed: status = -1 error = Input/output error
Nov 4 16:35:11 trekkserver pptpd[18483]: CTRL: PTY read or GRE write failed (pty,gre)=(5,10)
Nov 4 16:35:11 trekkserver pptpd[18483]: CTRL: Client 66.156.205.235 control connection finished
 
Old 11-04-2003, 04:42 PM   #15
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Ok, add the lines that refer to LCP, MTU, MRU & ipcp, then restart pptpd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Port forward GRE and PPTP using IPtables twistedpair Linux - Networking 18 05-07-2011 08:23 AM
Strange client IP change on a VPN connection(pptp - poptop).txt 4mix Linux - Networking 1 09-16-2005 11:45 AM
pptp poptop VPN +port omid1979 Linux - Networking 0 06-11-2005 09:29 AM
PoPToP VPN with Shorewall: can only reach PoPToP server pgwillemsen Linux - Networking 0 12-27-2004 08:11 AM
POPTOP vpn on userdefined port pudhiyavan Linux - Networking 1 06-29-2004 04:53 PM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration