LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Playing Windows files on Linux box? (http://www.linuxquestions.org/questions/linux-networking-3/playing-windows-files-on-linux-box-368599/)

watha 09-30-2005 08:08 PM

Playing Windows files on Linux box?
 
I'm running XP on one machine, Linux on another, using Samba to network them. Windows lets me run multimedia files stored on the Linux machine. I just go to the folder, click the file, and it streams into whatever player I'm using. I can create a playlist of files on the Linux machine, and play them in any order.

When I switch to the Linux computer and try to play files stored on Windows, Linux doesn't cooperate so easily. I have to copy the file into the /tmp directory before it will play, and I can't create a list of files on the Windows machine and play them one after the other.

I get the impression that I'd have to mount the Windows files on a partition of the Linux machine to run them seamlessly. I don't know how to do this. Or is there some other solution? Thanks.

ag2uki 09-30-2005 08:49 PM

I usually use LinNeighborhood to mount shared directories.

watha 09-30-2005 10:10 PM

And what is LinNeighborhood? I never heard of it. I'm running SUSE 9.3, in case that matters...

ag2uki 09-30-2005 11:19 PM

LinNeighborhood is a GUI tool to solve your problem. :D
Basically, you can mount it from command prompt, like this:
Code:

# mount -t smbfs -o username=wedhus,password=wedhus //winsystem/Shared /mnt/Shared/
LinNeighborhood do the same way, but it's much better. :)

regards
ag2uki

watha 10-01-2005 01:20 PM

And how does one get LinNeighborhood?

watha 10-01-2005 07:56 PM

OK, I found LinNeighborhood and installed it. Now I can't get it to work. It identifies the folder I want to mount on my Linux box, but when I click "mount," it says "cannot resolve address."


Can anyone help? Thanks.

ag2uki 10-03-2005 08:34 PM

perhaps you installed a firewall on either your Suse or your Windows machines.
I have found a similar question, and i hope it will work for you.

http://www.linuxquestions.org/questi...04/07/2/197829

Good Luck!


regards
ag2uki

watha 10-03-2005 11:30 PM

The firewall on my SUSE box is off. I have a firewall on my Windows machine. I disabled it and tried again. It still won't resolve the address. So if both firewalls are shut down entirely, why else might it not work? Thanks.

FliesLikeABrick 10-04-2005 12:41 PM

If you wanna try doing it by hand instead of using LinNeighborhood (can't say i'm familiar with it at all) then try to make some sense of this:


to mount the windows shares under linux, install smbclient and smbfs (both are in apt repositories if you happen to be using debian or ubuntu) and I'm sure there's an RPM for them as well.


After that is all happy, it is just a matter of using smbmount (basically "mount" with special stuff to tell it that it is a windows network share) or you can add a line into your /etc/fstab file telling it to mount //computername/sharename into a mount path as filesystem type smbfs


you can also mount it using mount with filesystem type smbfs too. see man smbmount and man mount for more info, it is really straightforward

watha 10-04-2005 08:19 PM

Sounds like a plan, dude. I'll try it. Thanks.

watha 10-04-2005 08:57 PM

Yep, I puzzled out the right text command for mounting. Part of the problem was the Windows filename. I needed to put it in quotes. Still, it now works. Just wish I could automate the process. Oh, well, at least I made a copy of the command, so I can reissue it whenever I log on. Thanks much.

Randall Slack 10-06-2005 07:43 PM

hi
i'm using slackware so don't know how to do it with suse, but with slack i can edit a file called /etc/fstab (think you have the same file in suse)
this file tells the system what to mount at startup, my cdrom and floppy are listed there as well,
i can simply add a new line with the smbmount command in there and it will mount the windows share automatically at boot instead of typing it in.

watha 10-06-2005 08:10 PM

Yeah, I mean to try that one of these days. For now, I'd just as soon type the command as needed. Long as I can mount the share, I'll die happy.

Thanks.


All times are GMT -5. The time now is 09:33 PM.