LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-06-2009, 02:04 PM   #1
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Rep: Reputation: 38
Pinging by Name?


I've been able to get my machines to ping by netbios name by adding 'wins' to the end of the hosts line in /etc/nsswitch.

In Fedora 10, I added that value and was unsuccessful in pinging by name. I made sure smbd and nmbd are started.

What else do I need to do?
 
Old 05-06-2009, 02:18 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Is there a WINS server running on the network? If not, you need to make the Fedora machine run as one before it can resolve any names.
 
Old 05-06-2009, 02:45 PM   #3
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by MS3FGX View Post
Is there a WINS server running on the network? If not, you need to make the Fedora machine run as one before it can resolve any names.
Not a specific WINS server. However, standard NetBIOS master browser services are working fine. Under Fedora 7 (and maybe 8) I had Linux pinging by NetBIOS, no problem.

Also, nbtscan successfully returns IP/NetBIOS names.

Last edited by SlowCoder; 05-06-2009 at 02:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pinging delos Linux - Networking 6 07-02-2004 09:14 AM
Pinging?? Sherpa Linux - General 3 05-13-2004 07:23 AM
Network not pinging any more. duffboygrim Linux - Networking 2 03-30-2004 05:05 PM
Pinging Error?? Ikik Linux - General 2 10-01-2003 04:06 AM
Pinging Problem warlord07 Linux - Networking 1 09-19-2003 01:02 AM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration