-   Linux - Networking (
-   -   Ping resolves DNS but other apps don't? (

jago25_98 02-25-2007 12:26 PM

Ping resolves DNS but other apps don't?

"Connecting to ( port 6667"
"[admin@(none) root]$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=51 time=178.3 ms"

Separate ADSL Modem
- doesn't have much in the way of diagnostics. It's a linksys ADSL2 modem

^ connects through

- /etc/resolv.conf is set to

^ connects through

Client PC
- Firefox doesn't resolve DNS queries. Konqueror kind of works but
slow DNS requests.
- yet, ping works fine resolving DNS perfectly
- /etc/resolve.conf is set to (router), and ping only works if it is set to
this and not (modem)
- gateway is set to router ( by DHCP
- same symptoms on Windows and Linux, conected by ethernet cable
- can't ping the modem (
- apt-get fails to update as well

Other Windows only client PC:
- works fine connected by cable or wireless

What on earth is going on?

acid_kewpie 02-25-2007 12:32 PM

if i'm right, this sounds a lot like similar issues (well.. they wouldn't be similar otherwise would they??) which came down to very bizzare ipv6 issues with the adsl router and the certain patterns of dns lookups being done by clients. try disabling ipv6 on your box and see where that gets you. i still don't understand the "why", but the "how" seems to do the job.

fur 02-25-2007 01:18 PM

The linksys ADSL2 looks to be a combination modem, and router.

Then you have another router on top of that, and both are on the same subnet from what you posted

"Separate ADSL Modem"


If NAT is enabled on two devices, and they share the same subnet there will most likely be problems. If you want to use both routers you will need to do some config changes on the 2nd device.

acid_kewpie 02-25-2007 01:24 PM

no, i don't think so. actually it was the dns resolutions too that fitted in with it. regardless of network topology, if DNS works on one app on a client, it *should* work on all of them.

jago25_98 02-25-2007 01:31 PM

Thanks. For some strange reason I am able to get to but not ...

I am look for IPv6 in my WL500g settings and can't see a way to disable.

The modem only has one ethernet port on the back, and client PCs can't ping the modem.

What would be a better setup? -because the defaults of the modem and router being on didn't seem to work.

acid_kewpie 02-25-2007 01:43 PM

it's not a function of the laptop, it's the operating system which dos the support. normally it's just a case of removing, or not loading the "ipv6" module on boot.

fur 02-25-2007 02:11 PM


The modem only has one ethernet port on the back, and client PCs can't ping the modem.
Thats because they share they same subnet, and are being NATed by seperate devices.



Any clients that are plugged into the router are not going to send their packets to to reach, or any other IPs that share that subnet.

They will do a arp lookup asking who has, and wont get a answer because is not a configured IP that is in their collision domain.

Now if the modem had a IP on another subnet then the clients would look in their routing table, and see that the IP is not on the same subnet they are, send packets to their default route of

IPv6 may have something to do with this, but I have little experience with it. Either way, you will still want to get your network straightened out.

jago25_98 02-25-2007 02:22 PM

Thanks for the help guys! I changed the router to access point mode for the moment.

When I can would a choice of for the modem and for the router be ok? I'm not an expert in calculating subnets

fur 02-25-2007 03:01 PM

Do you have a link to documentation for you modem?

jago25_98 02-25-2007 03:06 PM

No, because it's 2nd hand off ebay and google search results are dogged by adverts

fur 02-25-2007 03:23 PM

Well I found the documentation, and that modem does do routing/NAT

This is what I would do.

To disable this.

In your modem go select "Bridged Mode Only"

Then click the "Save Settings" button.

This disables, routing, and NAT on the modem, so that it will act as a "normal" modem, and just pass traffic.

Then you would need to configure your router to connect to your ISP.

You want your router to perform NAT.

So it will connect to the ISP, and get a public IP on its external interface then hand out the 192.168.x.x IPs to your clients.

I would also get the documentation for your router as well as well as the connection settings for your ISP if you don't already have it.

acid_kewpie 02-25-2007 03:24 PM

/me sits back and waits for this to be deemed irrelevant. or be proved very very wrong. ;-)

fur 02-25-2007 03:39 PM


Originally Posted by acid_kewpie
/me sits back and waits for this to be deemed irrelevant. or be proved very very wrong. ;-)

Well if you look here there was a similar issue with domains resolving to with lynx, but ping would resolved the domain.

Either way his network is not setup properly with the 2 NATs like that, and needs fixed.

All times are GMT -5. The time now is 09:19 AM.