LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-10-2008, 12:16 AM   #1
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Rep: Reputation: 0
Pesky networking problem with Ubuntu / Debian


I'm running Ubuntu Server (Hardy) in our office. The building we are in provisions internet for us so we have fixed IP and DNS server. The problem is: I can't reach the internet from this server. It will resolve IP addresses but for example I can't apt-get or wget anything. Posted this problem on two other forums but no resolution yet. Would be open to any suggestions at this stage since everything I've tried doesn't work so far.

Code:
ifconfig -a:

eth0      Link encap:Ethernet  HWaddr 00:30:1b:46:b8:d8
          inet addr:193.168.1.200  Bcast:193.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::230:1bff:fe46:b8d8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:93 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7360 (7.1 KB)  TX bytes:10754 (10.5 KB)
          Interrupt:17

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:348 (348.0 B)  TX bytes:348 (348.0 B)
Code:
arp -a:

? (193.168.1.94) at 00:16:41:E7:A1:73 [ether] on eth0
SME100.SME (193.168.1.1) at 00:17:16:00:24:58 [ether] on eth0
Code:
interfaces:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 193.168.1.200
        netmask 255.255.255.0
        network 193.168.1.1
        broadcast 193.168.1.255
        gateway 193.168.1.1
        dns-nameservers 193.168.1.1 210.22.70.3 193.168.1.200
        dns-search com

Code:
resolv.conf:

search com
nameserver 193.168.1.1
nameserver 193.168.1.200
nameserver 210.22.70.3
Code:
I can resolve hosts:

XXX@XXX:/etc$ host google
google.com has address 64.233.187.99
google.com has address 72.14.207.99
google.com has address 64.233.167.99
google.com mail is handled by 10 smtp1.google.com.
google.com mail is handled by 10 smtp2.google.com.
google.com mail is handled by 10 smtp3.google.com.
google.com mail is handled by 10 smtp4.google.com.
Code:
But can't access internet:

PING google.com (64.233.187.99) 56(84) bytes of data.

[1]+  Stopped                 ping google.com
Nothing happens, even after waiting 10 minutes
I cannot ping the DNS server

Code:
I can ping the gateway:
PING 193.168.1.1 (193.168.1.1) 56(84) bytes of data.
64 bytes from 193.168.1.1: icmp_seq=1 ttl=64 time=0.569 ms
64 bytes from 193.168.1.1: icmp_seq=2 ttl=64 time=0.412 ms
64 bytes from 193.168.1.1: icmp_seq=3 ttl=64 time=0.391 ms
64 bytes from 193.168.1.1: icmp_seq=4 ttl=64 time=0.376 ms
64 bytes from 193.168.1.1: icmp_seq=5 ttl=64 time=0.375 ms
64 bytes from 193.168.1.1: icmp_seq=6 ttl=64 time=0.370 ms
64 bytes from 193.168.1.1: icmp_seq=7 ttl=64 time=0.388 ms

Thanks in advance to anyone who has suggestions for how to fix this!

Last edited by Deidgar; 07-10-2008 at 12:26 AM. Reason: Additional information
 
Old 07-10-2008, 12:26 AM   #2
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Show your router IP-related settings for the LAN.

Also, if your router is a cheap commodity router, don't use its internal DNS cache. They are very poor. Use your ISPs instead. (remove the 192.168.1.1 name server entry in resolv.conf, or wherever you configure your network settings).

Also describe the WAN side of your router - you can mask the IP if its public.
 
Old 07-10-2008, 12:29 AM   #3
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Wait a minute. I think you have a problem with your IP address and network

193.168.1.200

I think you want 192.168.1.200, which is a private network. 193 is public. Please confirm.
 
Old 07-10-2008, 12:42 AM   #4
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Unfortunately the router is managed by the building's IT department and I haven't been able to get much information from them yet, but I will try again today. I tried to determine the router's IP address from dyndns, but it couldn't resolve it, ping router also fails of course.

Before I only had the ISP's DNS server listed, but it wouldn't resolve hosts because I am not able to reach the DNS server, when I added 193.168.1.1 it can at least resolve hosts, though I am sure their router is cheap.

Seems like I am blocked at the gateway because I can ping it but not the DNS server or the router.
 
Old 07-10-2008, 12:46 AM   #5
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Unless you are in Europe and are part of the IP address range 193.0.0.0/8 :

Code:
$ whois 193.168.1.200

OrgName:    RIPE Network Coordination Centre
OrgID:      RIPE
Address:    P.O. Box 10096

...

NetRange:   193.0.0.0 - 193.255.255.255
CIDR:       193.0.0.0/8
NetName:    RIPE-CBLK
NetHandle:  NET-193-0-0-0-1
Parent:
...
% Information related to '193.168.1.0 - 193.168.1.255'

inetnum:      193.168.1.0 - 193.168.1.255
netname:      CU-CB-NET
descr:        Centre Universitaire
descr:        CU central building local network
descr:        Luxemburg
country:      LU
admin-c:      NS725-RIPE
i don't think you have the correct info.

Change your IP to 192 instead of 193. Watch what happens.

Last edited by Mr. C.; 07-10-2008 at 12:47 AM.
 
Old 07-10-2008, 12:47 AM   #6
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Mr. C. View Post
Wait a minute. I think you have a problem with your IP address and network

193.168.1.200

I think you want 192.168.1.200, which is a private network. 193 is public. Please confirm.
Yeah I wondered about that too, but it is in fact 193! Odd thing is that with exactly the same settings (I tested the IP address), my win lappy is able to connect fine.
 
Old 07-10-2008, 12:50 AM   #7
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Mr. C. View Post
Unless you are in Europe and are part of the IP address range 193.0.0.0/8 :

Code:
$ whois 193.168.1.200

OrgName:    RIPE Network Coordination Centre
OrgID:      RIPE
Address:    P.O. Box 10096

...

NetRange:   193.0.0.0 - 193.255.255.255
CIDR:       193.0.0.0/8
NetName:    RIPE-CBLK
NetHandle:  NET-193-0-0-0-1
Parent:
...
% Information related to '193.168.1.0 - 193.168.1.255'

inetnum:      193.168.1.0 - 193.168.1.255
netname:      CU-CB-NET
descr:        Centre Universitaire
descr:        CU central building local network
descr:        Luxemburg
country:      LU
admin-c:      NS725-RIPE
i don't think you have the correct info.

Change your IP to 192 instead of 193. Watch what happens.
I'm in Shanghai actually. The settings are correct, I verified that many times and as mentioned in the other post, they work on my windows machine (which I am using right now).
 
Old 07-10-2008, 01:04 AM   #8
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Luxemborg != China.

And this route isn't going to China:

Code:
8  DANTE.TenGigabitEthernet7-3.ar1.FRA4.gblx.net (207.138.144.46)  185.935 ms  176.342 ms  178.885 ms
9  so-1-3-0.rt1.lux.lu.geant2.net (62.40.112.54)  180.427 ms  176.461 ms  176.347 ms
10  restena-gw.rt1.lux.lu.geant2.net (62.40.124.150)  175.949 ms  181.449 ms  176.010 ms
11  gate-1.rest.restena.lu (158.64.16.62)  179.477 ms  180.510 ms  182.446 ms
12  gate-1-v25.limp.restena.lu (158.64.16.213)  182.662 ms  182.479 ms  181.936 ms
13  gate-1-v24.ucl.restena.lu (158.64.16.209)  180.886 ms  180.902 ms  182.408 ms
It might just be a remarkable coincidence.
 
Old 07-10-2008, 01:23 AM   #9
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Mr. C. View Post
Show your router IP-related settings for the LAN.

Also, if your router is a cheap commodity router, don't use its internal DNS cache. They are very poor. Use your ISPs instead. (remove the 192.168.1.1 name server entry in resolv.conf, or wherever you configure your network settings).

Also describe the WAN side of your router - you can mask the IP if its public.
What information specifically should I ask them for re the router IP settings for lan and wan? If I'm not really specific they won't reply.
 
Old 07-10-2008, 01:43 AM   #10
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Well, the router is not cheap, so that's not a worry. According to your arp, it appears to be a fairly pricey SME-100 NatPass in the price range of about $1800-$2500 US :

SME100.SME (193.168.1.1) at 00:17:16:00:24:58 [ether] on eth0

MAC Address
Prefix Vendor
001716 Qno Technology Inc.

It can be difficult to work with IT folks I realize. If they gave you a static IP, you need to know :
  • IP
  • Netmask
  • Gateway (which will be their router)
  • Broadcast (you can infer this, but ask anyway)
  • DNS server IP(s) in order of priority
 
Old 07-10-2008, 01:49 AM   #11
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Further interest, your DNS servers:

193.168.1.1
210.22.70.3
193.168.1.200

The first one is your gateway (whose IP addr seems questionable)
The second one is... what do you know... in Shanghai
The third is your own linux box. Are you running a DNS server on this box? If so, use it as the primary DNS server. If not, remove it from the list of name servers.
 
Old 07-10-2008, 02:13 AM   #12
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Mr. C. View Post
Well, the router is not cheap, so that's not a worry. According to your arp, it appears to be a fairly pricey SME-100 NatPass in the price range of about $1800-$2500 US :

SME100.SME (193.168.1.1) at 00:17:16:00:24:58 [ether] on eth0

MAC Address
Prefix Vendor
001716 Qno Technology Inc.

It can be difficult to work with IT folks I realize. If they gave you a static IP, you need to know :
  • IP
  • Netmask
  • Gateway (which will be their router)
  • Broadcast (you can infer this, but ask anyway)
  • DNS server IP(s) in order of priority
When I started I asked them for the following information, their replies are in italics:
IP address: 193.168.1.200
Netmask: 255.255.255.0
Network ID: [no response]
Broadcast IP: [no response]
Gateway/Router IP: 193.168.1.1
DNS Server: 210.22.70.3 210.22.70.227
 
Old 07-10-2008, 02:18 AM   #13
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Unless they have a VPN connection to somewhere in Luxemburg, and your network is part of that VPN, they are hijacking public IP space that belongs to somebody else. Perhaps they have answers...
 
Old 07-10-2008, 02:27 AM   #14
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Deidgar,
Why not you yourself try this:
whois 193.168.x.x

You will yourself understand there is some problems with ip address. Or that you really do not have complete information about it.
If the ip range you are using are illegitimate, then you might just not get help here.
As Mr.C said, you need to find out if there is some VPN connection that you are connected to.
 
Old 07-10-2008, 05:17 AM   #15
Deidgar
LQ Newbie
 
Registered: Jul 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Noted, and I told the IT people here (they don't work for us, we're in a serviced office) that they should use the designated 192.168.x.x for private networks. Their response was "pffft".

Good news is the problem is now solved. Those lazy jokers hadn't updated their routing tables for the ip address they assigned. Waste of time! working fine now!
 
  


Reply

Tags
debian, dns, networking, server, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 7.10 Networking Problem RexCoeus Linux - Newbie 11 11-15-2007 12:50 PM
Debian Etch+Networking restart problem kirby76 Linux - Networking 2 05-08-2007 02:06 AM
Strange Problem With Networking - Ubuntu 6.06 edwin11 Linux - Software 9 06-06-2006 09:26 AM
Ubuntu to Fedora Networking Problem BobNutfield Linux - Networking 4 03-20-2006 11:31 AM
Problem with Wireless networking after installing Ubuntu hoary skyhigh007 Linux - Wireless Networking 1 12-21-2005 08:54 PM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration