LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Packet Forwarding from eth0 to eth1 isn't working (http://www.linuxquestions.org/questions/linux-networking-3/packet-forwarding-from-eth0-to-eth1-isnt-working-551892/)

rajat 05-07-2007 05:01 AM

Packet Forwarding from eth0 to eth1 isn't working
 
Hi Folks,

I have a FC6 machine, kernel 2.6.18. I'm trying to forward packets from my eth0 interface to eth1 interface. It is not working. I have disabled the firewall as well.

Eth0 is on the network : 192.168.11.0 , netmask - 255.255.255.0
Eth1 is on the network : 172.16.0.0, netmask - 255.255.255.0

I have done the following settings in my machine:

1. Turned ON the packet forwarding by setting net.ipv4.ip_forward to 1 in the /etc/sysctl.conf file.

2. Added static routes to the file static-routes in /etc/sysconfig. The contents of this file are as under:
any: host 172.16.0.202 dev eth0
any: host 172.16.0.203 dev eth0
any: host 172.16.0.204 dev eth0
any: host 172.16.0.205 dev eth0
any: host 172.16.0.206 dev eth0
any: host 172.16.0.207 dev eth0
any: host 172.16.0.208 dev eth0
any: host 172.16.0.209 dev eth0
any: host 172.16.0.210 dev eth0
any: host 172.16.0.211 dev eth0
any: host 172.16.0.212 dev eth0
any: host 172.16.0.213 dev eth0
any: host 172.16.0.214 dev eth0
any: host 172.16.0.215 dev eth0
any: host 172.16.0.216 dev eth0
any: host 172.16.0.217 dev eth0

The same configuration works on my other FC2 machine, kernel 2.6.5

Please suggest what's wrong with the FC6 machine. Is there any more setting to be done in the FC6 box?

Thanks and regards,
Rajat

jschiwal 05-07-2007 05:24 AM

When I routed my desktop through my laptop in order to have access to my wireless router, I didn't add host routes like you are doing. However, I found out that I needed to modprobe ip_conntrack before it would work.


All times are GMT -5. The time now is 10:25 AM.