LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-03-2008, 11:20 PM   #1
arsham
Member
 
Registered: Mar 2004
Location: London
Distribution: Arch Linux, Debian
Posts: 184

Rep: Reputation: 30
Question openvpn over pppoe


Hi there,
I have an ADSL that connects to the internet through pppoe.
Now I want to setup a VPN connection with openvpn.

The connection is made , I checked both the server/client logs of openvpn.
But I have no route through the tunnel.

In client , this is the ifconfig output :

Code:
eth0      Link encap:Ethernet  HWaddr 00:11:95:8c:07:92
          inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0

ppp0      Link encap:Point-to-Point Protocol
          inet addr:192.168.80.237  P-t-P:192.168.210.2  Mask:255.255.255.255

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:192.168.1.6  P-t-P:192.168.1.5  Mask:255.255.255.255
And the route output is :

Code:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
arsham-laptop.l *               255.255.255.255 UH    0      0        0 tun0
192.168.210.2   *               255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     arsham-laptop.l 255.255.255.0   UG    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
default         *               0.0.0.0         U     0      0        0 ppp0
How can I manage to get the tunnel work?
 
Old 05-04-2008, 06:11 PM   #2
uncle_philip
Member
 
Registered: Apr 2008
Location: sydney
Distribution: centos5.2
Posts: 50

Rep: Reputation: 15
your local-ip address must not be the same subnet as tun0.
if your local-ip is 192.168.1.1
then assign your tun0 ip to 192.168.2.1
 
  


Reply

Tags
openvpn, pppoe, vpn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN client has not default gateway when connect to OpenVPN server sailershen Linux - Security 3 03-04-2010 02:20 AM
OpenVPN Question : connecting 5-6 comps with OpenVPN duryodhan Linux - Networking 7 02-15-2007 10:28 PM
PPPOE/xDSL any alternatives for rp-pppoe package.. deepclutch Linux - Software 2 02-04-2006 09:59 PM
pppoe & pppoe-server warning (solved) ggalvan Slackware 0 02-04-2006 05:58 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration