View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 07-06-2006, 04:40 PM   #1
LQ Newbie
Registered: Jul 2005
Posts: 6

Rep: Reputation: 0
Question openvpn client couldn't reach other servers behind vpn server

The network layout is like this (see detail in the diagram)

i have a linksys router connect to the internet and get the internet feed.
The OpenVPN server's eth1 port is connected to the router's LAN port, Both of them are in subnet.
The OpenVPN server's eth0 port is connected to the Project Server directly, both of the ports are in
The VPN subnet is

When the client use openvpn client tool connect to the OpenVPN server, the configuration is like that:

Client computer
IP address:
has route to and, so the client could ping openvpn server by using IP or
route print:
Active Routes:
Destination Netmask Gateway Interface Metric 20 1 30 30 30 1 20 1 20 20 1 30 20 1 2 1 1
Default Gateway:

OpenVPN server:
tun0(openvpn virtual port):
#ip route dev tun0 proto kernel scope link src via dev tun0 dev eth1 scope link dev eth0 scope link dev lo scope link
default via dev eth1

Project Server:
IP address:
default gateway:

Now i could ping from client, but failed to ping
On the OpenVPN server i could ping server), vice versa.

Problem is when i tried to ping from client side, it failed.

Last edited by jeffhan; 07-06-2006 at 04:56 PM.
Old 07-07-2006, 04:46 PM   #2
LQ Newbie
Registered: Jul 2005
Posts: 6

Original Poster
Rep: Reputation: 0
please help me, thank you
Old 08-27-2006, 11:20 PM   #3
Registered: Jun 2003
Location: Kalkar, Germany
Distribution: Slackware
Posts: 81

Rep: Reputation: 15
I have the same problem. What is in your route table?

ine says (on the server):
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 tun0 * U 0 0 0 tun0 UG 0 0 0 tun0 * U 0 0 0 eth0
default UG 0 0 0 eth0

The 122.100 network is in this case internal (I will change this later). I do not yet see how tun0 is to be connected to eth0, and I suspect that is the problem.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN client has not default gateway when connect to OpenVPN server sailershen Linux - Security 3 03-04-2010 02:20 AM
Configure Linux VPN Server for a Windows VPN Client xbaez Linux - Networking 4 04-28-2006 03:29 PM
VPN client and server zillah Solaris / OpenSolaris 5 05-14-2005 02:11 AM
PoPToP VPN with Shorewall: can only reach PoPToP server pgwillemsen Linux - Networking 0 12-27-2004 07:11 AM
How do i connect Ciscos VPN client to Checkpoint VPN server Klas Linux - Networking 1 11-29-2003 08:00 AM

All times are GMT -5. The time now is 03:27 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration