LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-01-2009, 10:22 AM   #1
quantamm
LQ Newbie
 
Registered: May 2005
Posts: 6

Rep: Reputation: 0
OpenVPN - Can't access other machines on the server's subnet


Hi, I'm setting up my first OpenVPN connection and using the "Examples" section of the man page as a guide.

The problem is that while I'm able to ping the server from the client, I can't ping any other machine on the server's subnet. I know that this has something to do with ip forwarding and routing, but I don't know what commands to execute.

I have done a 'echo 1 > /proc/sys/net/ipv4/ip_forward' on both machines. The OpenVPN FAQ says that I "need to add an internal LAN route to the LAN gateway so that the private OpenVPN subnet (declared in the server, ifconfig, or ifconfig-pool directives) is routed to the OpenVPN server machine (i.e. its internal address)", but I'm not sure what the proper route command is to make that happen.

My server is:
on subnet 192.168.1.0/24
with IP 192.168.1.100
and tun1 is 10.4.0.1

My client is:
on subnet 192.168.0.0/24
with IP 192.168.0.106
and tun1 is 10.4.0.2

From the client, I can ping 10.4.0.1 and 192.168.1.100. I can't ping 192.168.1.102 (another machine on the server's subnet).
 
Old 07-01-2009, 11:07 AM   #2
nowonmai
Member
 
Registered: Jun 2003
Posts: 481

Rep: Reputation: 47
Can you post the output of route on the server?
 
  


Reply

Tags
openvpn, ping, subnet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Ping Linux KVM from Other Machines on Host Subnet newmanium2001 Linux - Networking 5 05-19-2009 08:01 AM
OpenVPN-client connects,cant see servers subnet andbn Linux - Networking 0 10-29-2007 12:24 PM
openvpn w/o second subnet mrkofee Linux - Networking 2 04-23-2007 02:33 PM
OpenVPN Subnet Issues richinsc Linux - Security 5 04-06-2007 06:41 PM
Windows machines not seeing linux server from a new subnet nkeever Linux - Networking 3 04-29-2005 01:51 PM


All times are GMT -5. The time now is 11:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration