LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-22-2011, 12:19 PM   #1
vachon
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Rep: Reputation: Disabled
openSUSE VM networking problems


I'm virtualizing openSUSE 11 for class and the only interface up at startup is lo. I have to enter /sbin/ifconfig eth1 up (from root of course) and then use dhclient -4 eth1 to get it an IP address from my host adapter. At that point I can ping my virtual gateway address and host OS from linux as well as SSH into the machine and ping it from the host. However, I still have no internet access. I configured the host adapter to have DNS entries hoping the VM would take them. How do I display the DNS servers that my interface is using, if any? How can I configure my system such that I don't have to manually go through these steps every login? Thanks in advance for any advice the community can provide.
 
Old 10-23-2011, 11:38 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Have you tried configuring networking via yast2 ? .. it should do pretty much everything for you
 
Old 10-24-2011, 12:39 PM   #3
vachon
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
The problem was my VM not using proper DNS settings. I changed my /etc/resolve.conf and viola, solved.
 
  


Reply

Tags
networking, opensuse, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bridged networking on openSuSE 11.4 with Xen ... sankeny Suse/Novell 0 08-20-2011 07:22 PM
[SOLVED] networking problem in openSUSE 11.4 aarsh Suse/Novell 1 03-26-2011 03:57 AM
Networking Disabled in openSUSE aarsh Linux - Networking 5 02-20-2011 06:29 AM
Networking WINXP SP2 through OpenSUSE 10.3 garrettent44614 Linux - Networking 1 03-18-2008 10:24 AM
OpenSUSE Networking Troubles Saketh Linux - Newbie 9 03-17-2006 02:41 PM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration