LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 12-08-2007, 12:20 AM   #1
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Rep: Reputation: 0
opensuse, cannot and don't know how to connect to the internet


i have opensuse and i never connect it to the internet, it is a fresh install.
Now, i want to connect it,i dont know how to find the ip address, the dns, dhcp even everyhing and where should i put it.I'm very new to this opensuse.
I try to connect this computer from a cyber cafe via lan cable.
Can anyone lead me to 1by1 step?I'm only good with windows xp.
 
Old 12-08-2007, 01:17 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Look at this article and see if it helps. Post back if you have any questions.
 
Old 12-08-2007, 04:46 AM   #3
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Original Poster
Rep: Reputation: 0
I don't even understand it,i don't know how and where to start.
It doesn't showed command to get the ip.
I'm really stuck and frustrated!
 
Old 12-08-2007, 05:17 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
In a cybercafe, you probably need to use DHCP. You can set that in "YaST2 -> Network Devices -> Network Card"

Select your nic device and click on the "Configure" button.
In the device configuration page, Click on the General Tab. I think that for using in a cybercafe, the "Device Activation" on the top should be "On Cable Connection".

Click on the "Address" tab at the top. Make sure that Dynamic Address is selected. Using DHCP should be fine but you might try "DHCP + Zeroconf" as well if you still don't get an IP address and gateway assigned.

You can look at what these are with the command "/sbin/ifconfig" in the console. The cybercafe's dhcp server should also give you a default gateway address. You can enter "/sbin/route" and see if it is listed. Look at the line with the flags "UG".
 
Old 12-08-2007, 09:50 PM   #5
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Original Poster
Rep: Reputation: 0
if got this when i do the /sbin/ifconfig

lxuser@streamyx :~ /sbin/ifconfig
1o Link Encap : local loopback
inet addr : 127.0.0.1 Mask : 255.0.0.0
inet addr: ::1/128 Scope : Host
Up Loopback Running MTU : 16436 Metric :1
RX Packets : 24 error:0 Dropped:0 Overruns:0 Frame:0
TX Packets : 24 error:0 Dropped:0 Overruns:0 Carrier:0
Collision:0 txquelen:0
RX Bytes :1352 (1.3kb)
TX Bytes :1352 (1.3kb)

and for the /sbin/route

lxuser@streamyx:~>/sbin/route

Kernel IP Routing Table
Destination Gateway Genmask Flags Metric Ref Use Ifaec
Loopback * 255.0.0.0 u 0 0 0 1o



Only that, i write down it on paper, sorry for any misspell.

I post this because before this i already do some search and how to get the ip address.
Before this i got something like in the link below (see the 2 ip address & route diagram)
http://en.opensuse.org/SDB:Using_an_..._in_SUSE_LINUX

Now it's different??
 
Old 12-08-2007, 11:13 PM   #6
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Original Poster
Rep: Reputation: 0
forget my last post, by the way i already have it.

the /sbin/route RESULT:

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 u 0 0 0 eth1
link-local * 255.255.0.0 u 0 0 0 eth1
loopback * 255.0.0.0 u 0 0 0 eth1
default mygateway.ar7 0.0.0.0 UG 0 0 0 eth1

and for the /sbin/ifconfig
(note that i only write down this coz it too much to write)

eth1 : inet addr: 192.168.1.11 Bcast :192.168.1.255 Mask :255.255.255.0

Quote:
Look at the line with the flags "UG".
there's only "default", "mygateway.ar7", "0.0.0.0"


so?the question now which one of these number are the default gateway???

Last edited by kuszmania9999; 12-08-2007 at 11:16 PM.
 
Old 12-09-2007, 08:27 PM   #7
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Original Poster
Rep: Reputation: 0
isn't there anyone???still sleeping?
 
Old 12-10-2007, 02:21 AM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
The default gateway is listed in the route output line with the flag "UG". The G is for the gateway. So it is "mygateway.ar7". The actual IP address may be given in /etc/hosts.

You can also look at the contents of /etc/resolv.conf. It should list the ISPs nameserver addresses. This should also be supplied by DHCP.
 
Old 12-10-2007, 08:25 AM   #9
kuszmania9999
LQ Newbie
 
Registered: Dec 2007
Posts: 6

Original Poster
Rep: Reputation: 0
tq..now i already browsing internet, tq so much jschiwal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 09:28 PM
openSuSE won't connect to the internet lady_chance Linux - Networking 19 07-23-2007 09:29 PM
Can't connect to internet with Opensuse 10.2 bastjan Linux - Laptop and Netbook 2 05-24-2007 01:36 PM
opensuse 10.2 recognises wireless card, but won't connect nmsuaussie Linux - Newbie 3 05-24-2007 04:21 AM
I can't connect to the Internet using Firefox on OpenSUSE POCOFIREFOX Linux - General 4 04-23-2007 06:59 PM


All times are GMT -5. The time now is 07:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration