LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-28-2004, 01:18 PM   #1
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
Only root can use and connect to the internet


Uhh... so.. when I try to connect to the internet (with adsl-start),
I get a message that says that only root can run the script.

So, I run the command as root, and it connects successfully.
I can then start chatting at IRC (err, actually not >_< ),
browsing websites, ping computers etc.

But when I change back to my normal user, I cannot use the internet.

Any suggestions?


Distro: Slackware


(I found something here about using sudo, but I get an
syntax error when I try to run it...)
 
Old 04-28-2004, 07:21 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
try setting that command to be run as root. I had a similar problem with dcgui.

The command to use is:

chmod +s adsl-start

Then the command will be run as root no matter who runs it. I don't know if this is a good solution. That is up to gurus to tell you. But it worked for me.
 
Old 04-28-2004, 10:00 PM   #3
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Strange. If you switch to a tty (alt+F1), log in as root, run adsl-start, stay logged in as root, switch to another tty or xwindow, log in as a user and try to use the internet, does it work?
 
Old 04-29-2004, 01:27 PM   #4
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally posted by marghorp
try setting that command to be run as root. I had a similar problem with dcgui.

The command to use is:

chmod +s adsl-start

Then the command will be run as root no matter who runs it. I don't know if this is a good solution. That is up to gurus to tell you. But it worked for me.
root@bubble:~# chmod -s /usr/sbin/adsl-start
root@bubble:~# login vertical
Password:
vertical@bubble:~$ /usr/sbin/adsl-start
adsl-start: you must be root to run this script

Did'nt work... I also tryed to remove the root-check,
but with no positive results. =/


Quote:
Originally posted by zaphodiv
Strange. If you switch to a tty (alt+F1), log in as root, run adsl-start, stay logged in as root, switch to another tty or xwindow, log in as a user and try to use the internet, does it work?
Still no access to the internet =/

-----------------

But thanks anyway
 
Old 04-29-2004, 01:32 PM   #5
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
chmod +s adsl-start

NOT

chmod -s adsl-start

+ gives the command an attribute
- takes away that attribute
 
Old 04-29-2004, 01:35 PM   #6
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Uhh, doh, I'm stupid...
 
Old 04-29-2004, 01:38 PM   #7
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Still no luck...

vertical@bubble:~$ /usr/sbin/adsl-start
adsl-start: you must be root to run this script
 
Old 04-29-2004, 01:47 PM   #8
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
I don't know then. It works to me even as user. check attributes of /sbin/adsl-start and /usr/sbin/adsl-start

These are two files linked together. Check if any of these has some strange permission settings. Like not being rwxr-xr-x or something.

The adsl-start in /usr/sbin/ is just a link to the file adsl-start in /sbin/

So check that out and tell us what it says.
 
Old 04-29-2004, 02:02 PM   #9
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
-rwsr-sr-x

That's it's permissions...


/sbin/adsl-start ... no such file
 
Old 04-29-2004, 02:24 PM   #10
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
try locate adsl-start and tell me what that returns
 
Old 04-29-2004, 02:29 PM   #11
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory
 
Old 04-29-2004, 02:34 PM   #12
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
su
<your root password here>
updatedb
locate adsl-start
 
Old 04-29-2004, 02:35 PM   #13
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Uhh...
warning: updatedb: could not open database: /var/lib/slocate/slocate.db: No such file or directory
 
Old 04-29-2004, 02:43 PM   #14
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
I am lost now

You have some biger problems probably.

Time for the gurus to jump in and save the day.
 
Old 04-29-2004, 02:51 PM   #15
VerTiCal
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
ok, thanks anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you connect to internet as normal user without run pppd as root ? nasty_daemon Linux - Networking 2 09-13-2005 02:43 AM
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Is there anyway to connect to the internet without root privilages? captainfreedom Linux - Newbie 2 02-28-2005 11:59 AM
Only root can connect to the internet astronaut3000 Linux - Networking 2 07-25-2004 04:06 PM
Only root can use and connect to the internet VerTiCal Linux - General 2 04-28-2004 07:25 PM


All times are GMT -5. The time now is 07:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration