LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Closed Thread
 
Search this Thread
Old 04-17-2004, 10:39 PM   #1
hellfireboy
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Onboard nForce network card not recognized in RedHat 9


My mainboard is BioStar M7NCD (nFORCE2)
Network: (Onboard) MCP NVIDIA MAC + Realtek RTL8201BL PHY
Linux kernel: 2.4.20-8
Drivers download from NVIDIA is compiled for kernel 2.4.20.6 and 2.4.20.9 ,which cannot be actived in current kernel.
I recompiled the .src.rpm file , and got the error below

************************************************************
[root@localhost nforce]# make
make -C nvnet
make[1]: Entering directory `/mnt/backup/system/drivers/lan/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.20-8/build/include nvnet.c
In file included from /lib/modules/2.4.2
 
Old 04-17-2004, 11:31 PM   #2
[PX]Kal Bob
LQ Newbie
 
Registered: Jul 2003
Distribution: Debian
Posts: 8

Rep: Reputation: 0
I am not seeing an error here.
I think that your next step would be to run make install

That should give you the module file, then insmod it into the system.
 
Old 04-18-2004, 07:16 AM   #3
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php

The original is here:
http://www.linuxquestions.org/questi...285#post884285
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
onboard Intel LAN Card is not being recognized by RedHat 9.0 TempleOwl1999 Linux - Hardware 11 10-15-2005 04:46 PM
Onboard nForce network card not recognized in RedHat 9 hellfireboy Linux - Hardware 2 04-18-2004 09:40 PM
Trouble on nForce onboard Lan Card Ninja_212 Mandriva 8 04-14-2004 02:55 AM
onboard nforce card matt_w_lambert Mandriva 0 12-25-2003 01:34 AM
Network card not recognized niac Linux - Networking 7 10-24-2002 08:16 AM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration