LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 02-09-2004, 09:24 PM   #1
boardinglaxplr
LQ Newbie
 
Registered: Feb 2004
Location: New York
Posts: 6

Rep: Reputation: 0
Nvidia nForce Ethernet Drivers


I am running Mandrake 9.2 and trying to install the ethernet drivers for linux. I am dual booting with the computer with Windows and Linux and I am stuck with installing the drivers on Mandrake. I first of all downloaded the file "NVIDIA_nforce-1.0-0261.tar.gz" from the website that came in the manual with the ASUS NFORCE2 Motherboard. Then i put this file onto a floppy, switched to the linux OS and moved the file from the floppy to my home folder. Then i did the command "tar -xvzf NVIDIA_nforce-1.0-0261.tar.gz", which worked successfully. After that i followed the instructions and changed directories to nforce. Next, i tried to use the command "make" which error'ed like crazy. I managed to copy and paste the commands to a text file and load it to my other server. You can view it at 24.190.193.7:81/tarball if it would help in resolving the problem. It includes all commands starting at the "tar -xvzf NVIDIA_nforce-1.0-0261.tar.gz". Also, what i didn't include there was that i tried to do the "make" command as root. It looked to me to be the same errors though.
 
Old 02-09-2004, 09:34 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
Code:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error "   /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error "   the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error "   /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error "   compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error "   -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error "   instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error "   -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error "   Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
did you try to follow any of what it is saying here ?

also do you even have your kernel source on your box ?
 
Old 02-10-2004, 07:01 AM   #3
GraemeK
Member
 
Registered: Aug 2003
Location: Essex, UK
Distribution: Windoze 2000, Fedora Core 3
Posts: 325

Rep: Reputation: 30
i had this problem and gave up! why cant i just install an rpm or something and it works! this madness has to stop, on windows i install an .exe and done! on linux i pull my hair out... not good.

G
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia nforce ethernet card, enabling it? Schrambo Slackware 3 02-20-2008 02:41 AM
nForce 4 Audio/Ethernet drivers nhusted Fedora 4 05-29-2005 02:08 PM
Problem: NVIDIA nForce nvnet ethernet driver Peff Fedora 6 01-22-2004 03:13 AM
nVIDIA nForce ethernet in Redhad 9 tommytom02 Linux - Networking 2 12-20-2003 05:01 PM
nVidia nForce drivers baldurkn Linux - Newbie 24 07-24-2003 11:13 AM


All times are GMT -5. The time now is 05:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration