LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-25-2008, 06:17 PM   #1
crazywizzard
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Rep: Reputation: 0
Not connected to internet unless a user is logged in


I would like to be able to access my home machine remotely, however if I turn it on but don't log in, it is not connected to the internet. If any user logs in on the local machine the internet connection comes up and I can reach the machine over the network. I do not want someone to need to be logged in to access the machine, How can I change this behavior.

I am running Fedora 8, and have already added certain networking services to lower runlevels that I thought would bring up the connection sooner (I can't remember which ones), but I still can't reach it unless someone is logged in.

I am having trouble finding any resources through a google search, I don't know if this is just a rare problem or if I am using the wrong keywords. Thank you for any help you can provide.

EDIT: My apologies, this probably should have gone in the software section. I guess it's not really a network configuration or hardware problem.

Last edited by crazywizzard; 03-25-2008 at 06:27 PM.
 
Old 03-25-2008, 06:44 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
fedora is in a slightly messy place at the moment, as there are two different mechanisms for network connectivity at play, which contradict each other.

the method that is working for you would be networkmanager, but you probably don't actually need it at all, and it's just confusing things. if you don't need to change the networking, no wireless key management etc... probably just disable to boot service for it. what you should be looking at is the system-config-network tool which is what you'd probably want to use to configure the conventional networking, including DHCP if need be. that tool will configure the file /etc/sysconfig/network-scripts/ifcfg-eth0 (among others) and if you want you can directly just edit it.
 
Old 03-25-2008, 06:51 PM   #3
crazywizzard
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I don't need network manager at all, I'll just get rid of it and try manual configuration. Thanks.

EDIT: Fixed, awesome. You're my favorite person for the rest of the day.

Last edited by crazywizzard; 03-25-2008 at 06:59 PM.
 
  


Reply

Tags
connection, logged, network, ssh, user


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome: Auto mounting external devices as first user logged in, not current user yitzle Linux - Software 4 04-01-2008 10:43 AM
Unplug Internet Cable and plugin aging, but could not connected to the internet DevlinX Linux - General 2 07-02-2006 11:36 AM
Multi-user and 3D sharing, 3D only works for the first logged in user foxy123 Suse/Novell 0 02-20-2005 05:31 AM
When a user last logged in turbo_acura Linux - General 1 09-21-2004 01:02 PM
mozilla works fine when logged in as a user but crashes when logged in as root jimi Linux - General 6 04-02-2003 09:34 PM


All times are GMT -5. The time now is 04:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration