LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Not able to bring Linux on network. (http://www.linuxquestions.org/questions/linux-networking-3/not-able-to-bring-linux-on-network-349424/)

rgouda 08-02-2005 10:35 PM

Not able to bring Linux on network.
 
Seems like mine is a unique problem as I could not find any helpful threads. My problem goes as below -
I am newbie to Linux world. Installed Debian(Sarge) 3.1.r0a successfully on a Compaq desktop which has built-in Intel(R) PRO 100 Ethernet card into the motherboard configured as 'eth0'. I am trying to setup linux with Linksys wired router (series something like BEFS...) which is confifured to login to DSL to access Internet. My problem is I am not able to access / ping my local network.

Output of route command gives me nothing.
Output of 'lspci' gives the list of all PCI devices including Ethernet controller.
Output of 'ifconfig' command gives output of 'local loopback'
Get reply when I ping localhost or 127.0.0.1
But I cannot ping external host that is windows XP box or ping linksys router whose IP address is 192.168.0.1
Does anybody has solution to my problem?

Thank you in advance.
Raj

fenderman11111 08-02-2005 11:03 PM

if you use dhcp, just run the comand 'dhclient'.

otherwise, do this:

Code:

su
ifconfig eth0 192.168.0.2 up
route add default gw 192.168.0.1
echo nameserver 192.168.0.1 > /etc/resolv.conf

see if one of those gets it working.

rgouda 08-03-2005 09:34 PM

Thank you for responding to my post. However, it still did not help. Below is the logs on running command dhcpclient -

/home/rgouda# dhclient

Listening on LPF/lo/<null>
Sending on LPF/lo/<null>
Listening on LPF/eth0/00:02:a5:aa:8e:9c
Sending on LPF/eth0/00:02:a5:aa:8e:9c
Sending on Socket/fallback/fallback-net
DHCPDISCOVER on lo to 255.255.222.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 4
DHCPDISCOVER on lo to 255.255.222.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 14
DHCPDISCOVER on lo to 255.255.222.255 port 67 interval 17
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.222.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database.

Sleeping.

Can somebody give me more insights please.

Thank you in advance.

rgouda 08-03-2005 10:08 PM

May this give someone clue.

# ifconfig
eth0 Link encap: Ethernet HWaddr 00:02:A5:AA:8E:9C
UP BROADCAST MULTICAST MTU:1500 Metric: 1
RX Packets: 0 errors;0 dropped:0 overruns:0 frame:0
TX Packets: 6 errors;0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes: 0 (0.0 b) TX bytes: 2052 (2.0 KiB)

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mast: 255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric: 1
RX Packets:13717 errors:0 dropped:0 overruns:0 frame:0
TX packets: 13717 errors:0 dropped:0 overrunds:0 carrier:0
collisions: 0
RX bytes: 1146567 (1.0 MiB) TX bytes: 1146567 (1.0 MiB)

Another command dmesg output is:
# dmesg | grep eth0
e100: eth0: Intel(R) PRO/100 Network Connection.

Please let me know if anybody has suggestions, willing to try any other alternatives.

Thanks,

fenderman11111 08-03-2005 11:04 PM

well, do you have a dhcp server running on your router? iow, does your router automatically give out ip addresses to you? if not then dhclient will not work.

in any case, did you try the other commands i put in my last post? if dhclient doesn't work, the next step is to attempt to configure your ethernet card manually.

(each line is a different command)

Code:

su
ifconfig eth0 192.168.0.2 up
route add default gw 192.168.0.1
echo nameserver 192.168.0.1 > /etc/resolv.conf

if it still doesn't work then you have a problem; in that case i would check the cable and make sure that it works.

rgouda 08-04-2005 05:57 AM

Yes I did tried to run other list of commands. Command route add default gw failed.

# ifconfig eth0 192.168.0.2 up
# route add default gw 192.168.1.1
SIOCADDRT: Network is unreachable

I forgot to mention this in my reply. Do you know what exactly is going on? I do have network cable connected to router.

Looking forward to any help.

RHrulz 08-04-2005 01:55 PM

You still haven't answered if you are running DHCP on your router. Also,

Code:

# ifconfig eth0 192.168.0.2 up
# route add default gw 192.168.1.1

will not work correctly because you are typing 2 different subnets. Not sure if it was a typo.

make sure the 'route add default gw' is the IP address of your router and the 'ifconfig eth0' address is an unused address on the same network.

HTH

rgouda 08-04-2005 09:16 PM

Output of someother commands if this gives anyone clue to lead me any direction -
# netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
...... (empty)


# ethtool eth0
Settings for eth0:
Supported ports: [TP MII]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation; Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: Unknown! (65535)
Duplex: Unknow! (255)
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports wake-on: puag
Wake-on: g
Link detected: no

# dmesg | grep eth
e100: eth0: Intel(R) PRO/100 Network connection


Thanks,
Gouda

rgouda 08-04-2005 09:36 PM

Hi HTH,
Thanks for pointing me to my incorrect subnet address. I corrected that but still it was not working, recycled my linksys router now I can ping and hooked on to my network and internet. Thank you for your help, you are very helpful.


All times are GMT -5. The time now is 01:07 PM.