LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-11-2012, 09:25 AM   #1
EPS
LQ Newbie
 
Registered: Feb 2008
Posts: 22

Rep: Reputation: 0
No Nameserver found - Nameserver (DNS) failure


I have confugured my usb wireless stick using modeswitch.
It appears to be working OK, but I have a problem connecting to the internet.
When I run wvdial, ( my ISP is Bob.at in Austria )
The modem responds, it starts ppp and it waits for a carrier, It connects at 3600000, but then when it get to "Script /etc/ppp/ip-up run successful", then I get the Nameserver error.

I have looked at other threads on the forum, but none really answer my question. ie what do I do now ?

Any ideas, anybody ?
 
Old 01-11-2012, 09:28 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
try to add the DNS in
Code:
/etc/resolv.conf
Code:
nameserver x.x.x.x
Kind regards
 
1 members found this post helpful.
Old 01-11-2012, 09:54 AM   #3
mmrtnt
LQ Newbie
 
Registered: Nov 2006
Location: las vegas, nevada
Distribution: fedora core x
Posts: 25

Rep: Reputation: 7
wvdial.conf

Quote:
Auto DNS
Try to get the Domain Nameserver (DNS) from the provider. This option is "on" by default. (Option added by SuSE.)
Hope this helps...
 
1 members found this post helpful.
Old 01-11-2012, 10:21 AM   #4
EPS
LQ Newbie
 
Registered: Feb 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Thanks, both of you.
I should have mentioned I use Suse 11.4 and have tried unsuccessfully to use Yast to configure.
As far as I know the provider DNS is 194.48.124.185, there is also a secondary number there,.200

In wvdail I have a line saying " Auto DNS = 1 " , is this the same as "ON" ?

resolv.conf file as far as I can see is just a comment file telling me to go and screw around with /etc/sysconfig/network/config file, so I have been doing just that.

I have tried putting in the DNS No. that I have into this under NETCONGIG_DNS_STATIC_SEARCHLIST and NETCONFIG_DNS_STATIC_SERVERS and also NETCONFIG_DNS_FORWARDER.
.. again, I am not really too sure what I am doing here
 
Old 01-12-2012, 07:02 AM   #5
mmrtnt
LQ Newbie
 
Registered: Nov 2006
Location: las vegas, nevada
Distribution: fedora core x
Posts: 25

Rep: Reputation: 7
Heck.

I haven't fought with wvdial in a while.

What I believe is supposed to happen is once you've made a connection (dialed, connected, authorized) then the PPP server should be giving you an IP address and the nameservers via DHCP. It sounds like something in that chain is failing. You should be using DHCP (Instead of static config) via PPP.

I wish I could be of more help, but I would Google the heck out of "wvdial", "dhcp", "ppp", "nameserver" and "dns" in various combinations.

Good luck...
 
1 members found this post helpful.
Old 01-12-2012, 07:38 AM   #6
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,910

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
Quote:
Originally Posted by EPS View Post
As far as I know the provider DNS is 194.48.124.185, there is also a secondary number there,.200
So you are saying that you know that the ISP has DNS servers at 194.48.124.185 and 194.48.124.200?

Do you get the chance to ping either of those addresses, or are saying that the connection auto-closes once the DNS error has happened?

And, while the connection is up, can you cat /etc/resolv.conf as....

Quote:
Originally Posted by EPS View Post
resolv.conf file as far as I can see is just a comment file telling me to go and screw around with /etc/sysconfig/network/config file, so I have been doing just that.

That should not be the case: in the particular case of SUSE, Yast has had a reputation of making things a little more confusing when things go wrong, by putting settings back to what it thinks they should be, if you go around changing settings behind its back.

What I think is happening here is that Yast is using the setting in /etc/sysconfig/network/config to configure networking, but (in this particular respect) resolv.conf is what really causes changes to system operation. Where this really gets important is that other things change resolv.conf, too. So you may start up with some default settings in resolv.conf, Yast (and associated scripts) may then change those settings, and then DHCP or PPP may change them again, as networking actually starts up. This can be confusing, particularly if it is not what you were expecting.

Usually, the first step, if you think that DNS is not being correctly configured correctly, is to see if you do something with the IP address directly (thereby side-stepping the issue of whether DNS works, DNS not being needed in that particular case). So, if, for example:
ping w.x.y.z works, and the associated
ping www.somethingoranother.com doesn't, then it is usually the case that you can be sure that there is a DNS configuration error.

A worthwhile thing to remember is that Google have public nameservers at 8.8.8.8 and 8.8.4.4, at least one of those is a memorable address, and they do work (unlike some ISP nameservers, which can be, err, a bit intermittent, and not to be relied upon during debugging, because it adds an extra random factor, which can really mess you about, if they go wrong at a bad time).
 
1 members found this post helpful.
Old 01-12-2012, 10:09 AM   #7
EPS
LQ Newbie
 
Registered: Feb 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Again, thank you for your replies.
I have not been able to "Ping" anything at all.
netstat -rn gives me:
destination 127.0.0.0 ; Gateway 0.0.0.0 ; Genmask 255.0.0.0
Can you tell me how to edit the resolv.conf file, as I think this may be where the conflict lies.
at present it looks like this, it's all just commentary:
### /etc/resolv.conf file autogenerated by netconfig!

#
# Before you change this file manually, consider to define the

# static DNS configuration using the following variables in the

# /etc/sysconfig/network/config file:

# NETCONFIG_DNS_STATIC_SEARCHLIST

# NETCONFIG_DNS_STATIC_SERVERS

# NETCONFIG_DNS_FORWARDER

# or disable DNS configuration updates via netconfig by setting:

# NETCONFIG_DNS_POLICY=''

#

# See also the netconfig(8) manual page and other documentation.

#

# Note: Manual change of this file disables netconfig too, but

# may get lost when this file contains comments or empty lines

# only, the netconfig settings are same with settings in this

# file and in case of a "netconfig update -f" call.

#

### at least remove this warning if you change anything.

Here also is my wvdial dialog

Running as Root:

# wvdial bob
-->wvDial: Internet dialer version 1.60
-->Cannot get information for serial port
-->Initialising modem
-->Sending ATZ
ATZ
OK
-->Sending AT+CGDCONT=4,"IP","bob.at"
AT+CGDCONT=4,"IP","bob.at"
OK
-->Modem initialised
-->Sending: ATDT *99***1#
ATDT *99***1#
CONNECT 3600000
-->Carrier detected. Starting ppp immediately.
-->Starting pppd:2933
-->Using Interface ppp0
-->pppd:[06][08][06][08]
-->pppd:[06][08][06][08]
-->pppd:[06][08][06][08]
-->pppd:[06][08][06][08]
-->pppd:[06][08][06][08]
-->local IP address 10.61.86.251
-->pppd:[06][08][06][08]
-->remote IP address 10.64.64.64
-->pppd:[06][08][06][08]
-->primary DNS address 194.48.124.202
-->pppd:[06][08][06][08]
-->secondary DNS address 194.48.124.200
-->pppd:[06][08][06][08]
-->Script /etc/ppp/ip-up run successful
-->Default route Ok
-->warning, no nameserver found '/etc/resolv.conf/'
-->Nameserver DNS failure, the connection may not work.
-->Connected ... Press Crtl-C to disconnect

I then press ctrl-C to terminate. That is where I stand at present.
 
Old 01-12-2012, 11:47 AM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
At the end of
Code:
/etc/resolv.conf
add
Code:
nameserver 194.48.124.202
nameserver 194.48.124.200
Make the connection, and see if you can ping
Code:
ping www.google.com
If you can't ping, try
Code:
ping 212.100.160.51
Kind regards
 
Old 01-12-2012, 04:31 PM   #9
EPS
LQ Newbie
 
Registered: Feb 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Hello Repo, Thanks for the tip.
Sorry, but no help. I added the code as you suggested, but I still cannot make a connection.
So I still cannot ping anything either.

As indicated at the top of my /etc/resolv.conf file
"#/etc/resolv.conf file is autogenerated by netconfig! ", I am sure that this needs to be part of the problem, because anything I add to resolv.conf is just being overwritten.
However, I have went over the netconfig file several times and I cannot see where to insert a nameserver DNS.

It also say that manually changing this file ( ie the resolv.conf ), will automatically disable Netconfig. But I don't know if that is so ?

My latin is at an end now, and I cannot see any way forward, so I will gladly try any other thoughts.
 
Old 01-13-2012, 01:02 AM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
First make a backup of the files
/etc/ppp/peers/wvdial
/etc/wvdial.conf
Then edit
Code:
/etc/ppp/peers/wvdial
and comment out or remove
Code:
usepeerdns
edit
Code:
/etc/wvdial.conf
add
Code:
check DNS = no
auto DNS = no
Kind regards
 
Old 01-14-2012, 08:11 AM   #11
EPS
LQ Newbie
 
Registered: Feb 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Hello All,

I just wanted to report my success.
I got a tip from Josh at http://www.draisberghof.de/usb_modeswitch/bb/

He suggested adding my DNS IP addresses and then making my /etc/reslv.conf file read only

Code:
chmod a-w /etc/resolv.conf

It worked ! So I am now replying to you all to say THANK YOU ALL ! for your efforts and also for your patience.

So I can confirm : ZTE MF180 wireless stick works on Suse 11.4 using USB-modeswitch.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nameserver (DNS) failure, the connection May not work. saia Linux - Networking 7 07-06-2010 11:11 AM
dns nameserver tkbonito Linux - Networking 3 07-23-2009 05:45 PM
I screwed something on nameserver/dns centosfan Linux - Server 2 01-29-2008 09:27 AM
Gentoo DNS(nameserver)! Xerop Linux - Networking 3 05-20-2004 06:47 AM
fetchmail nameserver failure shellcode Linux - Software 1 02-10-2004 09:56 PM


All times are GMT -5. The time now is 03:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration