LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-22-2009, 12:19 PM   #1
Mo-regard
LQ Newbie
 
Registered: May 2009
Posts: 5

Rep: Reputation: 0
No link detected using ethtool after interfaces file configured and system rebooted


I have an interesting issue.
here is my setup up using ubuntu 8.04lts, 32bit server

Dell 2650 Server with 3 nics, all gig ports

ethtool -i eth0 (GB1 on Dell Server on-board)
driver: tg3
version: 3.86
firmware-version: 5703-v2.25a
bus-info: 0000:05:06.0


ethtool -i eth1 (In a PCI slot)
driver: e1000
version: 7.3.20-k2-NAPI
firmware-version: N/A
bus-info: 0000:01:08.0

ethtool -i eth2 (GB2 on Dell Server on board)
driver: tg3
version: 3.86
firmware-version: 5703-v2.25a
bus-info: 0000:05:08.0


NOW eth0 is connected into the main network and working fine ethtool provides the following information:

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes



ETH1 is not connected to anything and not being used(PCI slot)

ETH2 is uses a cross connect cable to connect to Netgear NV 4000 NAS which has a Gigabut port.

If I configure the /etc/network/interfaces file without eth2 configuration, and I run ethtool eth2 I get:
Settings for eth2:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: Unknown! (0)
Duplex: Half

Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes


If I configure /etc/network/interfaces with ETH2 and assign an IP address I cannot connect to the NAS, and when I do ethtool eth2 I get:

Settings for eth2:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: Unknown! (65535)
Duplex: Unknown! (255)

Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: no

PROBLEM:
It seems that when I activate the ETH2 interface in the /etc/network/interfaces file, ethtool no longer detects the link and I cannot ping my NAS.
I can ping myself 192.168.21.5 but not the NAS(see ip configuration below)

I have configured the interfaces file and rebooted the system, but still no resolve.


Here is the interfaces file as of my last reboot


#The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface GB1 on board
auto eth0
iface eth0 inet static
address 10.130.0.227
netmask 255.255.255.0
network 10.130.0.0
broadcast 10.130.0.255
gateway 10.130.0.1

#The NAS interface GB2 onboard
auto eth2
iface eth2 inet static
address 192.168.21.5
netmask 255.255.255.0
network 192.168.21.0
broadcast 192.168.21.255

Any assistance would be great.

Also here is the dmesg log related to interfaces.

root@DM:/etc/network# dmesg | grep -i eth0
[ 136.594499] eth0: Tigon3 [partno(BCM95703A30) rev 1002 PHY(5703)] (PCIX:133MHz:64-bit) 10/100/1000Base-T Ethernet 00:0f:1f:6b:93:01
[ 136.594519] eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] WireSpeed[1] TSOcap[1]
[ 136.594525] eth0: dma_rwctrl[769c4000] dma_mask[64-bit]
[ 177.812362] tg3: eth0: Link is up at 1000 Mbps, full duplex.
[ 177.812367] tg3: eth0: Flow control is off for TX and off for RX.
[ 191.579873] eth0: no IPv6 routers present
root@DM:/etc/network# dmesg | grep -i eth1
[ 136.670396] eth1: Tigon3 [partno(BCM95703A30) rev 1002 PHY(5703)] (PCIX:133MHz:64-bit) 10/100/1000Base-T Ethernet 00:0f:1f:6b:93:02
[ 136.670408] eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] WireSpeed[1] TSOcap[1]
[ 136.670411] eth1: dma_rwctrl[769c4000] dma_mask[64-bit]
[ 174.288170] udev: renamed network interface eth1 to eth2
[ 174.578233] udev: renamed network interface eth2_rename to eth1
root@DM:/etc/network# dmesg | grep -i eth2
[ 137.212719] e1000: eth2: e1000_probe: Intel(R) PRO/1000 Network Connection
[ 174.288170] udev: renamed network interface eth1 to eth2
[ 174.578233] udev: renamed network interface eth2_rename to eth1

Last edited by Mo-regard; 09-22-2009 at 12:28 PM. Reason: update
 
Old 09-24-2009, 06:23 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,420

Rep: Reputation: 561Reputation: 561Reputation: 561Reputation: 561Reputation: 561Reputation: 561
[ 174.288170] udev: renamed network interface eth1 to eth2
[ 174.578233] udev: renamed network interface eth2_rename to eth1

It strikes me that the onboard nics are being found first, and rather than have eth0 and eth2, udev renames them. Then the wrong options are applied to each. Can you fiddle things to eliminate this as an possibility?
 
  


Reply

Tags
configurations, detection, interfaces, link


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat: dhcpd.conf - error: Not configured to listen on any interfaces! alinuxLQ Linux - Networking 7 03-14-2014 12:50 AM
Network card detected but not configured Rogabo Linux - Newbie 4 12-16-2006 08:56 PM
I have to set up the wlan0 up every time the system is rebooted Fuzia Linux - Wireless Networking 11 04-14-2006 04:15 PM
dhcpd - Not configured to listen on any interfaces. ritter Linux - Networking 1 07-05-2004 03:48 PM
"ifnet structure (regarding configured interfaces)header file in linux9?" deepender Programming 0 12-07-2003 12:11 AM


All times are GMT -5. The time now is 05:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration