LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   No internet access while other computers in the network are turned on. Slackware 11.0 (http://www.linuxquestions.org/questions/linux-networking-3/no-internet-access-while-other-computers-in-the-network-are-turned-on-slackware-11-0-a-542931/)

RicardoB 04-03-2007 06:57 AM

No internet access while other computers in the network are turned on. Slackware 11.0
 
My problem is the following: I cannot access the internet when other computers on my LAN are turned on aswell. When this computer is the only one turned on, I'm smooth sailing, but obviously I would like to be able to have all computers in my network to be able to access the internet at the same time. I'm using Slackware 11.0 with kernel 2.6.18 (switched over from 2.4.33.3 for the following reasons: computer would not completely shutdown on halt, mouse did not work)

So, my question is: How do I enable internet access for everybody in my network in Slackware 11.0.

Also, I have found that the problem must be somewhere in Slackware, since the hardware is functioning perfectly and I got it to work on Windows XP. (Just made the switch [again], hoping for it to be permanent this time, but it won't be if I don't solve this problem)

I will be happy to provide any additional info where needed.

Thanks in advance,

Ricardo

acid_kewpie 04-03-2007 07:08 AM

well offhand it sounds like a suplicate ip address or something. there is never any good reason for somethign like that to happen, not going to be by design ever. what's your net topology look like? how are these clients getting ip addresses? static? dhcp? can you try to ping google.com when it's not working? show us the output of "/sbin/route -n"

RicardoB 04-03-2007 07:18 AM

There are 3 computers in my network, they are getting their IP addresses assigned by DHCP, and I'll turn on a computer now and ping google and then show you the output of '/sbin/route -n'. Thanks for your help so far!

Brian1 04-03-2007 07:28 AM

I agree sounds like a dupilcate IP issue. I would goto all machines and see what each one is using for an IP. Another thought is if one of the other machines has a DHCP server active then it may be getting an IP from that machine instead of the router itself.

Brian

RicardoB 04-03-2007 07:33 AM

Pinging Google or any other website resulted in a hostname not found error.

Output from '/sbin/route -n':

Quote:

Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
Also, the two other machines are both running Windows XP, and when I turn one of them on after I've turned my machine on, I can still access the internet (sounds like duplicate IP). But when I turn the other one on, (The one with the router on top of it) then, my internet connection dies instantly, so how do I check where the DCHP IP adress assignations come from? Or, how do I check whether there's a DHCP server ative on one of those XP machines.

Emerson 04-03-2007 09:09 AM

Assuming you have a router in your network with DHCP server. Just turn off "Internet sharing" in all desktops. Do not remember how exactly to do it in Windows.

RicardoB 04-03-2007 09:50 AM

Thank you, it now works. I was planning on running SAMBA, how is that going to work when I have file / printer sharing disabled? Not?

acid_kewpie 04-03-2007 10:03 AM

samba is unrelated to ISC. it's "Internet sharing" you've disabled, not "file and print sharing" is isn't it?

Quote:

Originally Posted by Emerson
Assuming you have a router in your network with DHCP server. Just turn off "Internet sharing" in all desktops. Do not remember how exactly to do it in Windows.

what made you say that? that's all disabled by default still isn't it?

Emerson 04-03-2007 10:56 AM

@Chris

Just assuming and guessing. It's disabled by default, but one can always fiddle with settings without knowing what (s)he is doing.

RicardoB 04-03-2007 11:35 AM

Well, I did disable file and printer sharing since I had never heard of Internet Sharing, and it sounded pretty much alike, and better yet, disabling it solved the problem! I think I'm just going to use some FTP server to transfer files between my PC's, the problem is solved now. Thank you all very much.

acid_kewpie 04-03-2007 11:48 AM

it was close enough?? blimey...


All times are GMT -5. The time now is 11:32 PM.