LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-16-2008, 02:18 PM   #1
SiliconBadger
Member
 
Registered: May 2002
Location: Houston
Distribution: Gentoo
Posts: 32

Rep: Reputation: 15
No eth0 on Slackware 12.0, using Netgear FA311 (RTL 8139) NIC


I am really starting to question what skills I thought I had at getting things to work on Linux. I've never had a problem like this before.

In the past, it's been pretty easy to get NICs working with Linux. I got a Netgear FA311(v2) recently, because I know there is Linux support for the RTL8139 chipset.

The problem is, as I see it, that when I do ifconfig eth0 up, it says
Quote:
eth0: ERROR while getting interface flags: No such device
I am running kernel version 2.6.21.5. Now, there are two possible kernel drivers that would be appropriate for this card, the "8139too", and the "8139cp" modules. The 8139cp is labeled "EXPERIMENTAL" in the kernel config, so I don't know if I want to use it. Here's what I've got:

dmesg|grep 8139:
Quote:
8139too Fast Ethernet driver 0.9.28
eth0: RealTek RTL8139 at 0xd000, 00:1e:2a:3e:cd:64, IRQ 11
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
lsmod|grep 8139:
Quote:
8139too 28736 0
mii 4400 1 8139too
This all looks good to me, except that I get the aforementioned error when trying to bring up eth0 using ifconfig.

Also, I've used the 8139cp module, and it also uses the "mii" module, but it doesn't get eth0 going either, and also dmesg has some info (after loading 8139cp) indicating that it isn't the right driver for this card, and that I should try the "8139too" driver.

Just for grins, here is the relevant output of lspci:
Quote:
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Please help, as I have been tearing my hair out for a whole day with this problem, and that's after I spent 2 days (solid, 8 hour days) finding out that trying to configure wifi in linux is apparently a process the magnitude of which I could write a dissertation on. I'm really really furious now just remembering all this wasted time. Please help!!!
 
Old 03-16-2008, 07:19 PM   #2
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
Hmm... The only thing I can think of would be to try disabling Plug and Play support in the BIOS.

Also according to the Gentoo wiki, you should be using the "National Semiconductor DP8381X" driver instead of the RTL:
http://gentoo-wiki.com/HOWTO_Netgear_FA_311
 
Old 03-17-2008, 05:09 PM   #3
SiliconBadger
Member
 
Registered: May 2002
Location: Houston
Distribution: Gentoo
Posts: 32

Original Poster
Rep: Reputation: 15
Thanks for the response. I will give that a try. I'm not near the computer that's having the problems at the moment, but I did download kernel 2.6.24.3 and used "make menuconfig" to check for the option to use the National Semiconductor DP8381X, and there wasn't one. But, I downloaded kernel 2.4.36.2, and it is in that one. Maybe I shouldn't be using kernel 2.6. I'm not sure why I would want it, except that it's newer.

Anyway, I'm leaning toward the notion that there may be something wrong with my motherboard, or some other component in the system. I'm no guru or anything, but I was pretty sure that once you have the proper module loaded (or built into) the kernel, it should create the /dev/eth0 (or whatever it should be) and the device will at least be visible, if not working properly. I want to do anything I can to learn of some other procedure(s) that could be used to further troubleshoot this issue.
 
Old 03-17-2008, 08:49 PM   #4
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
That's odd, I have the 2.6.23 kernel source and there's an option for the National Semiconductor DP8381x under Device Drivers -> Network device support -> Ethernet (10 or 100Mbit) -> EISA, VLB, PCI and on board controllers.
Maybe a realtek card is using the same hardware ID, or your card is misreporting it for some reason. What does it say for 00:09 when you run the following as root?:
Code:
pcitweak -l
It ought to say "chip 100b,0020 card 1385,f311" and then some other stuff, if it is a Netgear FA311 with the NatSemi chipset.

Well according to netgear they have two FA311 cards, and only one of them is supported in Linux:
http://kbserver.netgear.com/products/FA311.asp

Maybe the unsupported one is using the Realtek chipset that's not handled by the 8139too driver.
 
Old 03-19-2008, 07:00 PM   #5
cousinnewt
LQ Newbie
 
Registered: Apr 2006
Posts: 1

Rep: Reputation: 0
No eth0

Silicon Badger:

Check also that /etc/ifplugd/ifplugd.conf has an "INTERFACE=" line like this (with the quotes around eth0):

INTERFACE="eth0"

and then check that a file in /etc/modprobe.d/ has a file with an alias line for the interface to your driver. The modprobe.d directory may have a link to /etc/modprobe.conf and for good measure also put the alias in /etc/modules.conf like so:

alias eth0 8139too

Use the appropriate driver, of course.

Good luck. N.

Last edited by cousinnewt; 03-19-2008 at 07:11 PM.
 
Old 04-02-2008, 04:49 PM   #6
manuelmrtz
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Installing a New Ethernet Card on Linux (NETGEAR FA311 v2)

I installed an additional Ethernet card on my UBUNTU 6.06 LTS box. It just takes less then 10 minute to have it working. No additional Drivers Needed.

Follow these steps.
After installing the card:
1. Log in as root.
2. Modify /etc/network/interfaces.

2a. I first modified the "auto" line and added "eth1".
2b. Then I added "iface eth1 inet dhcp" in the bottom.

2c. The file likes like this :
************************************************
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo eth0 eth1

iface lo inet loopback

# The primary network interface
# auto eth0
# iface eth0 inet dhcp

iface eth0 inet static
address 192.168.2.2
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
gateway 192.168.2.1

iface eth1 inet dhcp
**********************************************

2d. Save changes to the file and exit.

3. restart by executing "/etc/init.d/networking restart".

4. Sit, relax, and have a beer....

Manny Martinez
 
Old 06-13-2012, 09:36 PM   #7
SiliconBadger
Member
 
Registered: May 2002
Location: Houston
Distribution: Gentoo
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
I installed an additional Ethernet card on my UBUNTU 6.06 LTS box. It just takes less then 10 minute to have it working. No additional Drivers Needed.
That's great Manny, but we don't have Dance Dance Revolution so... you're dumb.

P.S. Gloating about how it works for you on a system that's irrelevant to the discussion is just plain rude.

P.P.S. I am now using Gentoo and do not have any issues.

Last edited by SiliconBadger; 06-13-2012 at 09:38 PM.
 
  


Reply

Tags
netgear, nic, rtl8139


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
net working in win2k but not in RHLinux 9 using RTL 8139/810x nic ask4gaurav Linux - Newbie 7 05-22-2005 06:36 AM
Woody 2.2.20 kernel and zen1200 (rtl-8139) nic .. missing files or just confusion. Martiniv Linux - Laptop and Netbook 2 04-21-2004 02:01 PM
netgear fa311 nic card zexter Linux - Hardware 1 11-01-2003 03:05 PM
Nic :: Netgear FA311 :: Trouble with the driver Lok3 Linux - Hardware 7 10-22-2002 03:46 PM
Netgear FA311 NIC oryan_dunn Linux - Networking 6 09-23-2002 01:42 AM


All times are GMT -5. The time now is 05:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration