LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   no access to shared directories with samba (http://www.linuxquestions.org/questions/linux-networking-3/no-access-to-shared-directories-with-samba-300358/)

Meriadoc 03-11-2005 07:53 AM

no access to shared directories with samba
 
Hi all,
I've been suffering from networking problems ever since I installed Mandrake 10.1 Official. Basically internet access works fine but file and printer sharing with the Windows machines on the same router doens't work. I can access shares on other machines with my Linux machine. Other machines can see my shares but any attempt to actually reach the share give errors stating that the directories do not exist or that the network is down. After a lot of fiddling (deinstalling/reinstalling samba (3) and in the end deleteing /etc/samba I actually made the printer on my linux machine available to the other machines on the network. The only thing that is still unreachable is the [Linux Deelmap], the directory exists, there are users in the passwords file for samba, the network has been reset after the latest changes, and I am completely stumped. Can anyone point me in the right direction?
Thanks in advance,
Merijn

Contents of my /etc/samba/smb.conf

[global]
workgroup = NEXUS
server string = Samba Server %v
printcap name = cups
load printers = yes
printing = cups
printer admin = @adm
log file = /var/log/samba/log.%m
max log size = 50
map to guest = bad user
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

[Linux Deelmap]
comment = Gedeelde map
path = /home/merijn/Deelmap
read only = no
guest ok = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = yes
writable = no
printable = yes
create mode = 0700
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = yes

[print$]
path = /var/lib/samba/printers
browseable = yes
write list = @adm root
guest ok = yes
inherit permissions = yes

camorri 03-13-2005 07:42 AM

Let me first say, I'm not the biggest expert at Samab, but I have a similar configuration working. From what I can see in your smb.conf file, the section dealing with Deelmap would appear to me to be non standard. There is usually a Homes section, defining your home directory. Here is mine.

[homes]
browseable = no
comment = Home Directories
hide dot files = no
directory mask = 0775
write list = cliff
writeable = yes
create mask = 0664
valid users = cliff

As far as I know, this is how to make your home directory work. Then you have to share the "Linux Deelmap" directory. If you want to share with other users, you need to add the users. I just added them to a group cliff.


All times are GMT -5. The time now is 03:31 PM.