LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-02-2006, 10:23 AM   #1
garba
Member
 
Registered: May 2005
Location: Italy
Distribution: Crux
Posts: 62

Rep: Reputation: 15
NIS fails to export groups


Hello, I've just setup a NIS server and I'm having a nasty problem: although my users can log in, they belong to no group other than their own. Anybody got an idea about what's going on? Thanks in advance.
 
Old 03-02-2006, 10:51 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
are you sharing the file /etc/group via NIS?

check /etc/nsswitch.conf

maybe post it.

you probably have

group: files

at the moment....

see what i mean??


i presume you did "ypmake group"???


sorry if this is slightly non linux, as i've only done NIS's on HP-UX :-)

Last edited by satinet; 03-02-2006 at 11:02 AM.
 
Old 03-02-2006, 11:15 AM   #3
garba
Member
 
Registered: May 2005
Location: Italy
Distribution: Crux
Posts: 62

Original Poster
Rep: Reputation: 15
thx for your reply satinet but i finally managed to sort it out: the problem lied with a variable in the makefile in /var/yp only groups with an id > 1000 get exported by default ^^ now everything is ok, lowering that var to 0 did the trick. Regards
 
Old 03-02-2006, 11:25 AM   #4
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
ok cool. seems like you know what you're doing with it. just one of those little "gotchas" that catch us all out from time to time!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Map Windows NT Groups to UNIX Groups - why? kenji1903 Linux - Networking 4 10-16-2007 12:52 PM
SUSE 9 and 10 NIS clients with RedHat 8.0 NIS server not working fishsponge Linux - Networking 0 11-29-2005 08:43 AM
Export Users & Groups BuRnInICE Linux - Newbie 3 05-25-2004 01:03 PM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Linux - General 1 03-31-2004 07:10 AM
winbind: wbinfo -g only lists global groups from PDC and not local groups saradiya Linux - Networking 0 12-01-2003 03:58 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration