LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 06-12-2005, 11:41 PM   #1
gnmabc
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Rep: Reputation: 0
Angry nic not detected


I'm new to the Linux world and am having a NIC detection problem with Fedora Core 2. I have two NIC cards in the box, one on the motherboard (which is detected) and on PCI NIC (not detected). typing lspci -v seems to show the PCI NIC, but that is far as I can get with detecting, configuring, etc.

Any suggestions would be greatly appreciated.
 
Old 06-13-2005, 01:40 AM   #2
MikeZila
Member
 
Registered: Jul 2004
Location: /home/mikezila
Distribution: Slackware
Posts: 377

Rep: Reputation: 30
Open up your BIOS and disable the onboard NIC. Most mobos that have onboard gear give you the option to disable it so you can use your own cards. Check your BIOS settings.
 
Old 06-13-2005, 02:25 AM   #3
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
If you can figure out what driver your card should use the at the command line try....for example

Code:
modprobe 8139too
then use your lspci command
 
Old 06-13-2005, 03:24 AM   #4
rulex
LQ Newbie
 
Registered: Jun 2005
Distribution: Redhat
Posts: 2

Rep: Reputation: 0
Ok this was the same problem which i had faced long ago and one of my friend helped me out
This is probably because the chipset of your nic is same to the other on also.Because i heard that linux will not load the driver for the same device twice.But in the case of installation it will.But after postinstall probably not.I am assuming that you have realtek chipset in the nic.you can verify by
#cat /etc/modules.conf
it will be something like the following
alias eth0 8139too
alias eth1 8139cp
the device eth0 is taking 8139too.that means linux loaded the driver for eth0 first.then only to eth1,which is taking 8139cp.For this i did the following.

#cd /lib/modules/2.4.20-8/kernel/drivers/net
#cp 8139too.o 8139cp.o
#depmod
#reboot

if it has a via chip you can find that module at the above location that is
via-rhine.o

The problem could be beacuse of the mis-configuration of /etc/modules.conf. if you see a line something like pre-remove eth1/0 ..... Then remove it.

Good Luck
 
Old 06-13-2005, 07:58 AM   #5
gnmabc
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Original Poster
Rep: Reputation: 0
nic not detected

O.K. Thanks for the replies, but the solutions have not seemed to work.

First, turning off the onboard NIC did not help with the detection of the PCI NIC.

Second, looking at /etc/modprobe.conf revealed only the eth0 alias, which is detected.

Finally, as for the modprobe suggestion, I don't know what driver should be used. The lspci command reveals it to be a (gulp!) Microsoft MN-130 NIC. (This could be the problem.)

Any furhter help (including throw the NIC away and get a non-Microsoft one) would be greatly appreciated.
 
Old 06-13-2005, 08:09 AM   #6
zulfilee
Member
 
Registered: Apr 2004
Location: India
Distribution: Redhat,Fedora
Posts: 430

Rep: Reputation: 39
Ok first see if the network card was detected by linux at some stage or other

This can be done by checking
/etc/sysconfig/hwconf

See if the file has two NETWORK entries

and if it has check if any entry has
detached: 1
[if detached is 1 ] Try pulling out the card and connecting it back again.

or if it has a valid driver
something like

driver: 8139too

Also try running kudzu if you had kudzu disabled on startup

Cheers
Zulfi
 
Old 06-13-2005, 03:40 PM   #7
Robert G. Hays
Member
 
Registered: Jan 2003
Location: Atlanta, Ga., USA
Distribution: Gentoo, Mandrake, ~others
Posts: 157

Rep: Reputation: 30
BTW, FYI...:

rulex, I have 4 identical 3Com PCI SLOT (internal) NICs in one particular computer, works *fine*.

just in case someone needs this info......
 
Old 06-13-2005, 05:57 PM   #8
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
I'd try a live CD such as knoppix and see if it autodetects the card. If it does, I'd check to see which module (driver) it choose to use. Assuming the CD has a 2.6 kernel (recent knoppix, for example), try the following command:

ls /sys/class/net/eth*/driver -l

My system, for example, gives:

gd2shoe@linux:~> ls /sys/class/net/eth*/driver -lh
lrwxrwxrwx 1 root root 0 2005-06-11 22:18 /sys/class/net/eth0/driver -> ../../../bus/pci/drivers/8139too

Where my network card uses the 8139too module. If both cards are detected and properly loaded, there will be two entries (one for each card).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gigabit NIC not detected Wraezor Linux - Hardware 9 08-01-2005 10:14 AM
NIC not detected when upgrading kernel pineapples Linux - Hardware 3 03-20-2005 02:29 PM
How to specify the NIC detected by pcap wangjinyi Linux - Software 0 09-23-2004 03:42 AM
Real NIC isn't detected pPcG5 Linux - Networking 0 09-08-2003 10:23 AM
3c509B NIC detected, but can only ping to myself patrickdepingui Linux - Networking 5 04-05-2003 10:49 AM


All times are GMT -5. The time now is 01:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration