LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-16-2006, 07:57 AM   #1
Juho_L
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Rep: Reputation: 0
NIC & ADSL mystery in FC5


I have a mysterious problem with my ADSL setup.

I have 3Com 3C900 ethernet card which is connected to the A-link RR21 ADSL router.

I've configured an ethernet network with DHCP and the setup works fine, except sometimes the NIC doesn't connect the router at all. It can't connect on the OS startup at all, so I have to log in as Root and give it a kick to get it work. Sometimes it takes few tries to get the connection to work.

The router works fine as I tried it on my Windows computer and it worked without any problems. Could this be a case of a faulty NIC?
 
Old 10-16-2006, 09:24 AM   #2
tovaldez
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by Juho_L
I have a mysterious problem with my ADSL setup.

I have 3Com 3C900 ethernet card which is connected to the A-link RR21 ADSL router.

I've configured an ethernet network with DHCP and the setup works fine, except sometimes the NIC doesn't connect the router at all. It can't connect on the OS startup at all, so I have to log in as Root and give it a kick to get it work. Sometimes it takes few tries to get the connection to work.


The router works fine as I tried it on my Windows computer and it worked without any problems. Could this be a case of a faulty NIC?
What do you mean with "kick"? ifdown/ifup? did you have a look at some logs, to see if DHCP worked fine... Tell something about your configuration...
 
Old 10-16-2006, 09:48 AM   #3
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I would bet against a bad NIC, it is not impossible, but I would look elsewhere first.

New distros are enabling IPv6, whether you use it or not. In some cases it causes problems. Getting an address via a DHCP server is a timing thing. If your interface is timing out on IPv6 stuff, you may simply be taking too long to respond to the server.

Look to see if it is enabled, and if you don't need it, disable it, and see what happens.

Another approach is to set a fixed IP address, for testing purposes. If that works all the time, then you NIC is good.

Right now I can not remember how to disable IPv6, it is an edit of a system file. I'm sure you can find out how with a search...
 
Old 10-17-2006, 05:09 AM   #4
Juho_L
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tovaldez
What do you mean with "kick"? ifdown/ifup? did you have a look at some logs, to see if DHCP worked fine... Tell something about your configuration...
By kicking I mean that I have to start the connection manually from the network settings after the computer has booted. Sometimes the connection starts on a first try and sometimes it takes several tries to get the IP's.

I tried to find the logs, but in vain. I'm a n00b. Should the log be somewhere in var/log/ ?

Quote:
Originally Posted by camorri
New distros are enabling IPv6, whether you use it or not. In some cases it causes problems. Getting an address via a DHCP server is a timing thing. If your interface is timing out on IPv6 stuff, you may simply be taking too long to respond to the server.

Look to see if it is enabled, and if you don't need it, disable it, and see what happens.
The IPv6 is disabled. I've also tried with IPv6 without any results. I really start to doubt this is some sort of timing problem as the NIC seems to be working ok and so does the router. There's only difficulties in starting the communication. When the connection is achieved everything runs ok from there on.

Quote:
Another approach is to set a fixed IP address, for testing purposes. If that works all the time, then you NIC is good.
The weird part is that when I use static IP's, I can ping the router succesfully everytime, but can't access the frimware screen via my browser unless I restart the connection few times, just like on getting the DHCP to work.

Quote:
Right now I can not remember how to disable IPv6, it is an edit of a system file. I'm sure you can find out how with a search...
Hmmm... In Fedora Core isn't it enough to uncheck the IPv6 box in the network connection preferences?
 
Old 10-17-2006, 10:13 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
One of the difficulties of helping with different distros is, each distro has gui tools to 'make life easier' for the user. As far as disabling IPv6 in FCx, that check box may well do it. However, this method should work for any distro.

Edit /etc/sysconfig/network and add the following line:

Code:
NETWORKING_IPV6=NO
This one disables IPv6 system wide. It can be disabled for just one interface, if you have more than one NIC.

Hope this helps.
 
Old 10-18-2006, 05:56 AM   #6
Juho_L
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri
One of the difficulties of helping with different distros is, each distro has gui tools to 'make life easier' for the user. As far as disabling IPv6 in FCx, that check box may well do it. However, this method should work for any distro.

Edit /etc/sysconfig/network and add the following line:

Code:
NETWORKING_IPV6=NO
This one disables IPv6 system wide. It can be disabled for just one interface, if you have more than one NIC.

Hope this helps.
I tried that one. It didn't work. For some reason the network starts when I change a network profile (I made two identical network profiles for tests). I found the logs and they say following:

Quote:
Oct 18 12:51:08 localhost kernel: ACPI: PCI Interrupt 0000:00:0f.0[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
Oct 18 12:51:11 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
Oct 18 12:51:15 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
Oct 18 12:51:19 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
Oct 18 12:51:24 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
Oct 18 12:51:35 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
Oct 18 12:51:56 localhost system-config-network[2607]: -+ //etc/modprobe.conf eth0 alias 3c59x
Oct 18 12:51:56 localhost system-config-network[2607]: chmod 0644 //etc/sysconfig/networking/devices/ifcfg-eth0
Oct 18 12:51:56 localhost system-config-network[2607]: change hostname to
Oct 18 12:51:56 localhost system-config-network[2607]: mv //etc/hosts //etc/hosts.bak
Oct 18 12:51:56 localhost system-config-network[2607]: ln //etc/sysconfig/networking/profiles//default/hosts //etc/hosts
Oct 18 12:51:56 localhost system-config-network[2607]: mv //etc/resolv.conf //etc/resolv.conf.bak
Oct 18 12:51:56 localhost system-config-network[2607]: ln //etc/sysconfig/networking/profiles//default/resolv.conf //etc/resolv.conf
Oct 18 12:51:57 localhost kernel: ACPI: PCI Interrupt 0000:00:0f.0[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
Oct 18 12:52:00 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
Oct 18 12:52:00 localhost dhclient: DHCPOFFER from 80.186.48.1
Oct 18 12:52:00 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Oct 18 12:52:00 localhost dhclient: DHCPACK from 80.186.48.1
Oct 18 12:52:00 localhost NET[2898]: /sbin/dhclient-script : updated /etc/resolv.conf
Oct 18 12:52:00 localhost dhclient: bound to 62.248.148.93 -- renewal in 3016 seconds.
 
Old 10-18-2006, 10:15 AM   #7
tovaldez
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
These addresses are quite strange: you shouldn't have such addresses in a private network.
Is your router address 80.186.48.1 or something like 62.248.148.93?
Could you posto the output of /sbin/ifconfig -a
what kind of distribution do you have?

I think you have a misconfigured network.
 
Old 10-18-2006, 10:17 AM   #8
tovaldez
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
paste the content of /etc/sysconfig/networking/devices/ifcfg-eth0 too, please.
 
Old 10-18-2006, 10:30 AM   #9
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
My thoughts exactly, Tovaldez.

The big picture. Routers have two side ( at least ). The ISP side will have an IP address in the range of ISP's subnet you are connected to. You can usually view this address through your routers configuration.

Your side is typially a private IP sub-net. The majority of home lan routers come pre-configured for 192.168.x.y
The router preforms NAT to convert packets from the IP address of the ISP sub-net to your private sub-net.

Could you also post the sub-net address for your side of the network.

With ADSL usually either your router or your system has to do PPPoE or PPPoA. Which one depends on the ISP and country you are in. Which machine is doing what in your network?
 
Old 10-19-2006, 02:14 AM   #10
Juho_L
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tovaldez
These addresses are quite strange: you shouldn't have such addresses in a private network.
Is your router address 80.186.48.1 or something like 62.248.148.93?
I think the router address is 193.229.0.40 (193.229.0.42 as secondary DNS).

Quote:
Could you posto the output of /sbin/ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:10:4B:47:B6:BE
inet addr:62.248.148.93 Bcast:62.248.159.255 Mask:255.255.240.0
inet6 addr: fe80::210:4bff:fe47:b6be/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1110 errors:0 dropped:0 overruns:0 frame:0
TX packets:1131 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:788887 (770.3 KiB) TX bytes:242059 (236.3 KiB)
Interrupt:11 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1798 errors:0 dropped:0 overruns:0 frame:0
TX packets:1798 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4521501 (4.3 MiB) TX bytes:4521501 (4.3 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Quote:
what kind of distribution do you have?
Fedora Core 5. Can't remember the version number though.

Quote:
I think you have a misconfigured network.
I wouldn't be suprised if that would be the case as I haven't done any kind of deeper configuration due the fact that I really don't know what to do.

Quote:
paste the content of /etc/sysconfig/networking/devices/ifcfg-eth0 too, please.
IPV6INIT=no
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:10:4b:47:b6:be
BOOTPROTO=dhcp

Quote:
Originally Posted by camorri
Could you also post the sub-net address for your side of the network.
With "/sbin/ip addr show" I found out 62.248.159.255.

Quote:
With ADSL usually either your router or your system has to do PPPoE or PPPoA. Which one depends on the ISP and country you are in. Which machine is doing what in your network?
I have no idea on PPPoX things. I haven't done any PPPoX settings and the connection works ok, so I think the PPPoX magic is done by the router.
 
Old 10-19-2006, 11:00 AM   #11
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I'm surprised this has ever worked, but I'll take your word for that. Have a look at post #9 that I made.

Your IP address when you did the ifconfig is not a private IP address. Here is a link that tells you what addresses are private.

http://tldp.org/HOWTO/IP-Masquerade-...g-the-lan.html

Your side of the router needs to be configured for one of these ranges. If DHCP is working, then your machine will then be assigned a IP address in the range your set the router up for.

I had a look to find out some information on your ADSL router, however I can not find anything on it.

1. Have you got any documentation on the router, soft copy or hard copy?

2. Do you know how to connect to the router to display the configuration, or to change the configuration?

3. If you could post any information on it, like a URL for the maker it would help.

Most routers to configure them, you connect your system, open a web browser, and type the IP address of the router in the address bar. This will bring up a log on screen, most are require a User - Password to connect. Most have default users and passwords and that will be in the documentation.

As for the PPPoE, that stands for Point to Point Protocol over Ethernet. PPPoA is similar, but it is over ATM. Some countries, like the UK use ATM.

Your router can usually do it. If you are directly connected via a ADSL modem, ie no router, then linux has PPPoE you run on your system. If it is a windbloze box, the ISP usually supplies a piece of code to do the PPPoE.

Your ISP's support will tell you what you need to be doing; either PPPoE or PPPoA.

The DNS address you posted doesn't make sense either. It should be in the range of the ISP's IP sub-net you are connected to. If you get connected to the router, you should be able to display the IP address for the ISP side of the router.

If you look in your /etc/resolv.conf file, you should see the correct DNS addresses there, if your router passes them along to your system. Your ISP can also tell you what they should be.
 
Old 10-19-2006, 11:33 AM   #12
Juho_L
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri
I'm surprised this has ever worked, but I'll take your word for that. Have a look at post #9 that I made.

Your IP address when you did the ifconfig is not a private IP address. Here is a link that tells you what addresses are private.

http://tldp.org/HOWTO/IP-Masquerade-...g-the-lan.html

Your side of the router needs to be configured for one of these ranges. If DHCP is working, then your machine will then be assigned a IP address in the range your set the router up for.
The quick isntallation manual of the router gives these IP's for controlling the moden: IP 10.0.0.1, mask 255.255.255.0, gateway 10.0.0.2. Are these the private network IP's?

Quote:
I had a look to find out some information on your ADSL router, however I can not find anything on it.

1. Have you got any documentation on the router, soft copy or hard copy?
It only came with a crappy quick installation manual for Windows. By googling I found out the full manual: ftp://ftp.a-link.com/rr21/FullManual.pdf

Quote:
2. Do you know how to connect to the router to display the configuration, or to change the configuration?
See above. Through http://10.0.0.2. I just tried to access the modem and now it informs me the address is blocked.

Quote:
Most routers to configure them, you connect your system, open a web browser, and type the IP address of the router in the address bar. This will bring up a log on screen, most are require a User - Password to connect. Most have default users and passwords and that will be in the documentation.
I've browsed the setup few times when I was tracking down did the router had an connection to the ISP. Didn't do any changes to the parameters though.

Quote:
As for the PPPoE, that stands for Point to Point Protocol over Ethernet. PPPoA is similar, but it is over ATM. Some countries, like the UK use ATM.
The ISP contract says it's Point to Point over ATM.

Quote:
The DNS address you posted doesn't make sense either. It should be in the range of the ISP's IP sub-net you are connected to. If you get connected to the router, you should be able to display the IP address for the ISP side of the router.

If you look in your /etc/resolv.conf file, you should see the correct DNS addresses there, if your router passes them along to your system. Your ISP can also tell you what they should be.
The file says:

; generated by /sbin/dhclient-script
search elisa-laajakaista.fi
nameserver 193.229.0.40
nameserver 193.229.0.42

I called the ISP support some time ago and they told that the DNS is correct and the IP should be fetched via DHCP due dynamic IP.

Edit: I set the router IP's as static route, but still I can't get connection to the router settings. It worked (although not always) when I had no DHCP activated and made a route only to the router in order to access the setup. Completely odd.

Thank you for all the help you've given so far. Deeply appreciated, but I think I'm starting to need some sort of divine guideance out his swamp of n00bness of networking.

Edit 2: I pinged the router and the resluts were rather fascinating:

[juho@localhost ~]$ ping -c 10 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
From 193.229.6.53 icmp_seq=2 Packet filtered

--- 10.0.0.2 ping statistics ---
10 packets transmitted, 0 received, +1 errors, 100% packet loss, time 8999ms
, pipe 2
[juho@localhost ~]$

Ten packets in nine seconds with 100% loss. Cool!

Last edited by Juho_L; 10-19-2006 at 12:05 PM.
 
Old 10-19-2006, 02:15 PM   #13
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I have downloaded the manual. It looks quite detailed. I'm going to have a look through it, and I'll post back. BTW, the instructions on how to connect to the router are in the manual, chapter 4. It shows the default user and password. ( and how to get the default configuration back, if you can not connect ).

Things to condsider. You are running PPPoA, and since it works when you get an IP address on your system, I would bet it is configured correctly. If it were not, I don't think it would ever work. If you have any problems with the ISP side, I would strongly suggest you contact your ISP for advice. They should know how to set up a router to talk to their network.

If you have a look at the manual, the WAN side is the ISP side of things. The LAN side is where your system ( and others ) plug in.
 
Old 10-20-2006, 09:48 AM   #14
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I have had a look through the setup manual, and I'm going to make some suggestions. Considering your original problem, your system sometimes doesn't get an IP address from your router. The IP address you did get when it works, seems odd, to say the least. ( 62.248.148.93 ).

First off, leave the WAN ( the ISP ) side alone. ( at least at this point in time. It is working with DHCP and that is fine.

I think you should turn NAT on, if it is not on, and since the router has a firewall, I would turn that on also. You do not need any other firewalls in linux, so if you have enabled one there, you could disable it. The router is the best place to protect your network.

Now for the LAN ( your side ). Turning on NAT allows for the router to translate your ISP side IP address into lan addresses you may want to use. Your side becomes a private lan. You can use the default addresses that come on the router, they will work just fine. I would first turn off DHCP on the lan side. Paragraph 4.2.2.1.4 shows how to set up static IP addresses. Set the routers LAN side IP to 10.0.0.2 ( default ) and set your machine to 10.0.0.1, just like it says for windbloze. The only thing I can not tell you, since I don't run FC5, is how to set a static IP address in FC5. Distros have different gui's to do that kind of thing.

Once you you have done that, restart the router, and your system.

Ping yourself 'ping 10.0.0.1'

Ping the router 'ping 10.0.0.2'

Both should work. Try going online. It should work every time.

I see no advantage to using DHCP on the lan side, especially when you have one machine.

Often ISP's when they make statements like "Use DHCP" are reffering to their side of the router, and don't clarify your side ( LAN side ) is your choice.

If you feel you want to run DHCP on your side, paragraph 4.2.2.1.2 shows how to enable DHCP. Set a beginning and ending IP addresses, say begin at 10.0.0.10 and end at 10.0.0.20. That would give you 10 addresses on the range of your lan. That should also work every time, unless there is some other issue in your system preventing getting an IP address.

Your default gateway address will be 10.0.0.2 ( your router ).

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless NIC (PC CARD) For FC5 foustware Linux - Hardware 1 08-11-2006 04:25 AM
Ethernet NIC ADSL Modem Disaster :( SML Slackware 3 05-30-2006 06:41 PM
ADSL problem on FC5 borinds Linux - Networking 1 05-26-2006 03:01 PM
Conexant USB ADSL modem in FC5 siddharth1986 Linux - Networking 3 05-24-2006 02:14 AM
Help with "ITeX ADSL PCI NIC" & RedHat Linux 8.0 rnoyman Linux - Hardware 4 10-26-2004 06:46 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration