LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-22-2004, 12:41 PM   #1
rm6990
Member
 
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
NFS with Ubuntu not working?


I cannot, no matter what i do, get nfs with ubuntu working. Whenever I try to mount I get

ryan@ubuntu:~ $ cd /mnt
ryan@ubuntu:/mnt $ ls
backup nfs pool
ryan@ubuntu:/mnt $ sudo mount backup
mount: RPC: Remote system error - Connection refused
ryan@ubuntu:/mnt $ sudo mount nfs
mount: RPC: Remote system error - Connection refused
ryan@ubuntu:/mnt $ sudo mount pool
mount: RPC: Remote system error - Connection refused
ryan@ubuntu:/mnt $

I will come back and edit my post in a second when I log onto the other machine and can paste in my other files. Be right back.

On the server end, here is my /etc/exports file

# /etc/exports: the access control list for filesystems which may be exported
# to NFS clients. See exports(5).

/nfs/nfs 192.168.2.166(rw,no_root_squash) 192.168.2.134(ro)
/nfs/pool 192.168.2.166(rw,no_root_squash) 192.168.2.134(rw,no_root_squash)
/nfs/backup/ryan 192.168.2.166(rw,no_root_squash)
/nfs/backup/georgina 192.168.2.134(rw,no_root_squash)


and here is my /etc/hosts.allow file

# /etc/hosts.allow: list of hosts that are allowed to access the system.
# See the manual pages hosts_access(5), hosts_options(5)
# and /usr/doc/netbase/portmapper.txt.gz
#
# Example: ALL: LOCAL @some_netgroup
# ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8), rpc.mountd(8) and
# /usr/share/doc/portmap/portmapper.txt.gz for further information.
#

portmap: 192.168.2.166 , 192.168.2.134
lockd: 192.168.2.166 , 192.168.2.134
rquotad: 192.168.2.166 , 192.168.2.134
mountd: 192.168.2.166 , 192.168.2.134
statd: 192.168.2.166 , 192.168.2.134


and here is my /etc/hosts.deny file

# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
# See the manual pages hosts_access(5), hosts_options(5)
# and /usr/doc/netbase/portmapper.txt.gz
#
# Example: ALL: some.host.name, .some.domain
# ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper. See portmap(8)
# and /usr/doc/portmap/portmapper.txt.gz for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.

# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID

portmap:ALL
lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL


Can anyone notice anything wrong with these files that would be causing this?? Ttyl. Thanks

Last edited by rm6990; 10-22-2004 at 12:47 PM.
 
Old 11-18-2004, 03:35 PM   #2
martinwood
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
check nfs firewall settings

This might sound too easy..! But make sure you allow nfs through your firewall on the target system.

Cheers,

Martin
 
Old 01-24-2005, 12:24 PM   #3
katletz
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
solution for me (I had the same problem): http://www.ubuntulinux.org/support/d...faq/nfs-server
just comment the line in /etc/default/portmap and restart portmap.

hth
stefan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu NFS file sharing not working snobird Ubuntu 1 06-26-2005 06:31 PM
NFS share not available after server Ubuntu upgrade ming0 Linux - Networking 3 10-25-2004 11:30 PM
Can't get NFS working properly Scruff Linux - Networking 8 02-08-2004 10:55 PM
nfs not working with slackware jakiel Linux - Networking 8 04-16-2003 05:31 PM
Cant get NFS working on RedHat8 OrganicX Linux - Networking 3 03-31-2003 10:24 AM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration