LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   NFS tcp not available, falling back to UDP; RPC failure (http://www.linuxquestions.org/questions/linux-networking-3/nfs-tcp-not-available-falling-back-to-udp%3B-rpc-failure-691002/)

ron7000 12-16-2008 12:43 PM

NFS tcp not available, falling back to UDP; RPC failure
 
I have installed Suse Linux Enterprise Server 10 sp1 on our machines, and on the latest few I keep noticing as the machine boots up I get the following errors:
- nfs related, says tcp unavailable falling back to udp, and it gives a warning that errors may result,
- also right after the nfs tcp error, it mentions RPc failure, or RPC port mapper failure.

what does this mean, and how do i fix it.

KinnowGrower 12-16-2008 03:15 PM

please try

Code:

/usr/sbin/rpcinfo -p localhost | grep nfs
if no output then NFS is not registered with Portmapper

then try

#service nfs start

hopefully it may help

ron7000 12-17-2008 03:17 PM

managed to get a copy of the exact error on bootup:

Importing Net File System (NFS)mount server reported tcp not available, falling back to udp
mount:RPC:Remote system error - No route to host
--------------------

I did rpcinfo -p and get the following:

program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 32772 status
100021 1 udp 32772 nlockmgr
100021 3 udp 32772 nlockmgr
100021 4 udp 32772 nlockmgr
100024 1 tcp 38120 status
100021 1 tcp 38120 nlockmgr
100021 3 tcp 38120 nlockmgr
100021 4 tcp 38120 nlockmgr
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100005 1 udp 863 mountd
100005 1 tcp 864 mountd
100005 2 udp 863 mountd
100005 2 tcp 864 mountd
100005 3 udp 863 mountd
100005 3 tcp 864 mountd

hasanatizaz 12-17-2008 03:23 PM

network service should start first and then nfs also see if portmap and rpc services are running.

KinnowGrower 12-18-2008 11:20 AM

Hi


The another thing what I know is NFS is protected by SElinux, if possible, Can you please try to disable it for time being.


All times are GMT -5. The time now is 01:37 AM.