LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-22-2004, 06:58 PM   #1
smaida
Member
 
Registered: Apr 2004
Location: Richmond, VA - USA
Distribution: Debian
Posts: 62

Rep: Reputation: 15
NFS - Shares (File Caching Problem)


Hello,

I am currently working with egenera blade servers that use NFS-Shares and iplanet web servers. Currently we are having a problem where updates to nfs shares do not get written to the iplanets consistently.

In most cases when we update a file on NFS-Shares it will get written to one or two of the three iplanets. This forces us to manually update the iplanet servers with the new files.

Is there a way to either force the cached files to be flushed from the iplanet server or is there a way disable the file caching altogether. My boss has requested that file caching be disabled, but either solution will do.

Thank you,
Shawn:

 
Old 04-22-2004, 09:19 PM   #2
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
Might try using "sync" on the servers, either the option in fstab (to disable caching altogether) or the CLI utility with same name (to force delayed writes to disk.) I'm not familiar with egenera blade servers though.
 
Old 04-23-2004, 07:20 PM   #3
smaida
Member
 
Registered: Apr 2004
Location: Richmond, VA - USA
Distribution: Debian
Posts: 62

Original Poster
Rep: Reputation: 15
Crito,

Thanks for the info. I do not believe that using "sync" is what we want to do. Do you know which options need to be set in fstab to disale caching?

Thanks,
Shawn
 
Old 04-23-2004, 10:20 PM   #4
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
Here's a sample line from mine:
/dev/sda1 /mnt/removable auto user,sync,noatime,noauto,umask=0 0 0

The synchronous I/O option prevents delayed writes and read-ahead. I'm using it because the drive is removable and I don't want locks held. I sort of doubt your problem is caching though, to be honest. More likely a problem with whatever process is replicating the data across your servers.
 
Old 04-24-2004, 01:39 AM   #5
smaida
Member
 
Registered: Apr 2004
Location: Richmond, VA - USA
Distribution: Debian
Posts: 62

Original Poster
Rep: Reputation: 15
Thanks Citro,

I will take a look at it Monday when I get back to work.

-Shawn
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting NFS Shares ... UID Problem Riddick Linux - Software 1 01-06-2005 10:48 AM
nfs a file shares ok via file mngr but not command line. Suse 9.1 acummings Linux - Networking 2 10-09-2004 03:23 PM
Bad file naming during copy over NFS shares Tarrasque Linux - Networking 0 03-22-2004 07:26 AM
seeing nfs shares problem (firewall) rosscopeeko Linux - General 3 03-17-2004 04:46 PM
NFS-shares: Problem with locales/charset. Clemente Linux - Networking 1 01-19-2004 03:24 PM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration