LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   NFS share is only mounted read-only? (http://www.linuxquestions.org/questions/linux-networking-3/nfs-share-is-only-mounted-read-only-557685/)

Poetics 05-30-2007 03:23 AM

NFS share is only mounted read-only?
 
I'm running a CentOS 4 server with a reiserFS partition mounted as /home/public (I've recompiled the kernel to include RFS support and can read/write as normal to that device).

My /etc/exports shows my client computer's subnet (192.168.1.0/255.255.255.0) and the fact that it should be exported '(rw)'. There is nothing in /etc/hosts.deny, and in /etc/hosts.allow portmap is set to accept from the same subnet. I have restarted the nfs and portmap daemons after adjusting all config files. I have included an iptables rule to accept anything coming from the server (based on source IP).

From the client, if I mount the device (192.168.1.103:/home/public), I get a 'cannot read superblock' error after some minutes. If I include the "-o nolock" option, it mounts up just fine. However, the device is mounted as read-only; definitely not the behavior I want nor expect.

Is there some fundamental aspect of NFS I'm missing? I've had wonderful success with these same settings on Slackware in the past, but for some reason I'm hitting a wall I can't see over.

Thanks in advance.

IsaacKuo 05-30-2007 06:44 AM

What OS are you using for the client computer? If it's a different distribution, then the problem could be that the user id numbers don't match.

Since you've used nfs somewhat, I probably don't need to tell you that root priviledges are "squashed" by default, so root wouldn't have write permissions to files owned by a different uid.

Poetics 05-30-2007 12:58 PM

I'm using Slackware 11 for the client computer -- I'm sure the UIDs don't match but the directory I was attempting to write to as a test has 1777 permission. I was just trying to create a 'Transfer' directory in which to put things to be sorted once I had more time.


All times are GMT -5. The time now is 06:29 AM.