LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 07-01-2009, 02:54 PM   #1
rbell54
LQ Newbie
 
Registered: Apr 2009
Location: Florida
Posts: 18

Rep: Reputation: 0
nfs remount


On serverA I have in /etc/exports I the following:
/system_backup 209.82.230.0/24(rw,sync,anonuid=0,anongid=0)

I export the filesystem with the following command: "exportfs -va" and started the nfs: "service nfs restart"

Then on serverB in /etc/fstab I have the following set up for the nfs partition:
serverA:/system_backup /system_backup nfs defaults,rsize=32768,wsize=327
68,hard 1 2

I mount the nfs file system with no problem.

But if serverA reboot then the file system will not remount. So when my server reboot how can I get the server to automatic remounted each time.
 
Old 07-01-2009, 03:00 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,607
Blog Entries: 1

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
I might be talking nonsense now, but have you specified ports for rpcbind services on the server so that they are always mapped to the same ports?
 
Old 07-02-2009, 09:03 AM   #3
rbell54
LQ Newbie
 
Registered: Apr 2009
Location: Florida
Posts: 18

Original Poster
Rep: Reputation: 0
I have portmapper running so I would assume it would automatic map back to any port that is knows about.
 
Old 07-02-2009, 09:25 AM   #4
rbell54
LQ Newbie
 
Registered: Apr 2009
Location: Florida
Posts: 18

Original Poster
Rep: Reputation: 0
I think I found out the problem. I had iptables running so i turn it off and after I reboot the server then nfs partition remounted.
 
Old 07-03-2009, 10:37 AM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,607
Blog Entries: 1

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
Quote:
Originally Posted by rbell54 View Post
I think I found out the problem. I had iptables running so i turn it off and after I reboot the server then nfs partition remounted.
Have you completely turned off iptables? I don't think it's a wise solution to turn off the firewall when you're connected to the internet.

I might be wrong but unless you explicitly specify the ports, portmapper might map the ports for some services differently each time you reboot. When I set up my nfs server (on centos) I specified the ports in /etc/sysconfig/nfs.
 
  


Reply

Tags
nfs, remount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS share won't remount after reboot userlander Linux - Networking 7 03-19-2009 08:52 AM
Debian Fails to Remount NFS Share on Server Reboot userlander Debian 3 02-13-2009 01:56 PM
NFS: "remount" showing up as NFS option kenneho Linux - Newbie 0 11-18-2008 06:25 AM
"errors=remount-ro" auto fsck, then remount-rw possible? Sepero Linux - Hardware 0 03-28-2007 04:23 AM
remount to hd ewt3y Linux - Newbie 1 08-16-2005 05:28 AM


All times are GMT -5. The time now is 08:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration