LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 12-04-2012, 01:37 AM   #1
echipbk
LQ Newbie
 
Registered: Feb 2012
Posts: 13

Rep: Reputation: Disabled
NFS permission???


- On NFS Server:
+ Create a user: nfs_server (uid-1015, gid-1015)
+ A folder named "/opt" on NFS server with permissions like this
dr-xr-xr-- nfs_server root ...
+ File /etc/exports:
/opt 192.168.3.0/24(rw,root_squash)

- On NFS Client:
+ Create a user: nfs_client (uid-1015, gid-1015)
+ Mount /opt on server to /mnt/test on local machine

- Access to server from the user nfs_client on client machine (a line was already added to fstab so that this non-root-user can mount). Mount was successful.

I have 2 questions:

1. Although "rw" permissions were specified in /etc/exports, nfs_client still couldn't write onto /mnt/test because this user didn't have "w" permission on folder "/opt" on server. Is this correct???
( I have already tested it, I just want to confirm the information)

2. From question 1, we can see that the permissions on a folder at the server must match the permissions specified in /etc/exports. Is this correct?????

Thanks for any help.
 
Old 12-04-2012, 03:22 PM   #2
fatmac
Member
 
Registered: Sep 2011
Location: Surrey/Hants Border, UK
Distribution: AntiX, TinyCore, (& SliTaz)
Posts: 413

Rep: Reputation: Disabled
I would think that //server/opt needs to be accessable by GID, as a root folder I think it belongs to the root user, & therefore can't be written to by another user unless in the group root. Putting users into group root isn't the best solution, so, I think, change the GID of /opt to 1015, (& maybe add the root user to that group, although I don't think it will be neccessary).
 
Old 12-04-2012, 03:54 PM   #3
echipbk
LQ Newbie
 
Registered: Feb 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
The user owner of /opt folder is nfs_user, not root. I changed the user owner, but keeping the group owner as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nfs permission eng_amrmohsen@yahoo.com Linux - Newbie 1 09-13-2012 07:59 AM
Permission in NFS malickhat Linux - Newbie 2 03-03-2010 07:54 AM
NFS Write Permission louisb Linux - Enterprise 2 02-20-2006 08:16 AM
NFS Permission Error alunduil Linux - Software 3 01-14-2006 12:12 PM
PLEASE help, NFS (permission denied) Nappa Slackware 15 01-13-2004 08:17 PM


All times are GMT -5. The time now is 03:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration