LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 04-15-2003, 08:30 AM   #1
jakiel
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Rep: Reputation: 0
nfs not working with slackware


I have just updated an old slackware system to version 8.1. Everything seems to be operating but nfs. I'm not familiar with slackware thus, I'm not sure to do. All nfs files seem to be in place, /usr/sbin/nfsd, /usr/sbin/mountd, etc. However when I go to start nfsd I get the following error:

nfssvc-function not implemented

Do I need to compile a new kernal??? Like I said earlier I'm new to Slackware, but not to UNIX.
 
Old 04-15-2003, 09:19 AM   #2
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Are you trying to mount an NFS export from another server or are you trying to act as an NFS server?

In either case you'll need to have a kernel that support NFS so this may be part of your problem. Typically you'll just need to get the necessary kernel built, then edit /etc/exports, then run /etc/rc.d/rc.nfsd and thats that. Exactly what do you run to get the nfssvc-function not implemented error message?

cheers

Jamie...
 
Old 04-15-2003, 11:01 AM   #3
jakiel
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I'm operating a NFS server. All files are installed on the server, and the exports file has been edited. I get the error when I issue the command /usr/sbin/nfsd from the command line, it is also in the /etc/rc.d/inetd file.

The problem is that someone else updated the server to 8.1 of slackware, and I don't know what they did or not do. Thus, what worked prior to the update does not work now.

If I have to update the kernel, what I need to know is the step by step procedure to actually do this. What SW do I need to get from slackware (if any), and what commands do I enter to get the new "nfs" into the updated kernel.

Thanks
 
Old 04-15-2003, 11:06 AM   #4
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
You should call /etc/rc.d/rc.nfsd start to start the NFS services. What happens when you run this? You need more than just nfsd running for NFS to work!

cheers

Jamie...
 
Old 04-15-2003, 11:26 AM   #5
jakiel
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Ran the command:

/etc/rc.d/rc.nfsd start

and all the nfs daemons started up, and the filesystems in the export file are now being exported. Question is where do I put this in the system startup scripts, so that upon reboot nfs will automatically start.

Thanks
 
Old 04-15-2003, 02:42 PM   #6
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
You shouldn't need to do anything to get NFS to run at boot time. That rc.nfsd script is called everytime you boot. It checks for entries in /etc/exports. If there are any entries then it runs, otherwise it just terminates. Try just restarting the machines and see if it works as it should.

cheers

Jamie....
 
Old 04-16-2003, 09:27 AM   #7
azornoz
Member
 
Registered: Apr 2003
Posts: 52

Rep: Reputation: 15
hi all
I got a little problem with nfs:
I have 2 boxes: box1 with mandrake 9.1 box2 with mdk 9.0
I can mount files in mdk 9.0 from mdk 9.1
when I try the reverse everything seems fine (entry in fstab too) but when I do cd to the mount point I get : permission denied
I am root on both boxes (same id, gid and passwd).
When I do ls -l I get drwx------ on the mount point, weird?
Could it be any default option that I missed?
Any ideas will be welcome.
thanks in advance.
 
Old 04-16-2003, 09:46 AM   #8
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
You really should have started a new thread for this...

NFS doesn't honour a remote root user, unless you export the entry with "no_root_squash". This would make you export entry look something like.
Code:
/exportDir serverNameThatCanMountIt(rw,no_root_squash)
Chmod the mount point on the remote machines to 755 before you mount it.

You'll need to run
Code:
exportfs -ra
on the server too.

cheers

Jamie...
 
Old 04-16-2003, 06:31 PM   #9
azornoz
Member
 
Registered: Apr 2003
Posts: 52

Rep: Reputation: 15
thanks a lot dude, it worked fine.
I just miserably forgot that option and because of changing some options in both machines.
Viva Linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SimpleTechs SimpleShare: nfs not working? mcr70 Linux - Hardware 9 11-24-2009 03:36 AM
NFS with Ubuntu not working? rm6990 Linux - Networking 2 01-24-2005 01:24 PM
Can't get NFS working properly Scruff Linux - Networking 8 02-08-2004 11:55 PM
Slackware 9.1 NFS install not working austindad Slackware 8 10-12-2003 06:31 PM
Cant get NFS working on RedHat8 OrganicX Linux - Networking 3 03-31-2003 11:24 AM


All times are GMT -5. The time now is 09:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration