LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-16-2008, 09:13 AM   #1
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 519

Rep: Reputation: 31
NFS mounting using FSTAB


Hi all,

i am using rhel 4.2 and 5. both systems are working and i am able to mount using mount manually.

#mount server1:/opt/tmp /opt/tmp

and it works,
but if i try it via /etc/fstab

server1:/opt/tmp /opt/tmp nfs _netdev,defaults 0 0

it doesn't. any tip , in this ?
 
Old 05-16-2008, 10:07 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
What error does it throw if you try to mount it via fstab? Using
Code:
mount -a
or such..it should say what's wrong if it doesn't succeed.
 
Old 05-17-2008, 08:15 AM   #3
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 519

Original Poster
Rep: Reputation: 31
there isn't any error if i use

#mount -a

and able to successfully mount nfs share . whereas it should also work
when system reboots.
Google is also populated with this problem, and i still didn't found work solution of this.


thanks.
 
Old 05-20-2008, 12:48 AM   #4
tox2ik
LQ Newbie
 
Registered: Nov 2004
Location: norway
Distribution: gentoo
Posts: 23

Rep: Reputation: 15
defaults

what the hell is _netdev?
try removing that option unless you know better.

also for names to work in fstab like this one:
Code:
tryggve:/mnt/140g /mnt/net/140g nfs defaults 0 0
you need a line in the /etc/hosts file for each one like so:
Code:
10.3.0.1 tryggve try router
192.168.0.1 otherhost
alternatively there is a dns server in your network which knows where "server1" is.

your distro probably has an init script called something like nfsmount in /etc/init.d or /etc/rc.*
make sure it is included in the startup configuration

Last edited by tox2ik; 05-20-2008 at 12:50 AM. Reason: moo
 
Old 05-20-2008, 05:38 AM   #5
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 519

Original Poster
Rep: Reputation: 31
i have also done using ip address but no success, the
"_netdev" defines to wait until network devices up. even though i removed all options and used just "defaults" but fails to mount on boot.

whereas "mount -a " works fine, that is strange, i am using RHEL 4 and RHEL 5.


thanks for interest.
 
Old 05-20-2008, 07:44 AM   #6
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 36
have you tried
Code:
mount -a -t nfs
Most distributions will parse fstab multiple times during the boot process. Whats more they (should) use parameters like nonfs to prevent mounting remote file systems until the network has been brought up. Thus _netdev is probably not necessary and of note in man is it only prevents mounting this line. ie A second mount like the one above needs to be issued during the init process.

so if the above mount did not work reformat fstab entry until it does else

well not being a RHEL user think the best thing I should advise is to reinstall your nfsd package hoping it will fix your mount problem.
 
Old 05-20-2008, 08:38 AM   #7
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 519

Original Poster
Rep: Reputation: 31
i did changes in fstab. but i think reinstalling will solve this. i will check this
thanks.
 
Old 12-18-2008, 07:23 AM   #8
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
whats the update ? is this problem solved ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS mount in /etc/fstab ? cozye Linux - General 3 09-12-2014 04:48 PM
NFS entries in /etc/fstab not mounting on boot jwolter0 Linux - Server 11 02-27-2012 02:28 PM
Fstab does not work in nfs windsurfer Linux - Software 1 04-23-2007 03:33 AM
nfs client on knoppix 3.9 - problem mounting nfs drive Rod Butcher Linux - Networking 1 09-21-2005 05:18 AM
Mounting NFS filesystem fstab vs autofs rrich100 Linux - Networking 0 11-13-2003 02:38 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration