LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   nfs mount can't read superblock (http://www.linuxquestions.org/questions/linux-networking-3/nfs-mount-cant-read-superblock-519292/)

nafan 01-14-2007 05:48 PM

[FIXED] nfs mount can't read superblock
 
I'm having trouble mounting an nfs share. Trying to mount the share returns
Code:

mount: 192.168.1.3:/opt/Music: can't read superblock
/etc/exports on the server (192.168.1.3) contains
Code:

/opt/Music 192.168.1.6(sync,no_wdelay,insecure,no_root_squash,rw)
/etc/fstab on the client machine (192.168.1.6) has the line
Code:

192.168.1.3:/opt/Music /opt/Music nfs noauto,user,rw  0 0
I'm at a loss to explain what's happening (or not happening). Anyone have any ideas?

Edit:
I have been digging around a bit further and somehow missed the complaints from the kernel in /var/log/syslog that portmap wasn't started locally.
Code:

Jan 15 12:12:11 maxdata kernel: RPC: failed to contact portmap (errno -5).
Jan 15 12:12:11 maxdata kernel: lockd_up: makesock failed, error=-5
Jan 15 12:12:46 maxdata kernel: portmap: server localhost not responding, timed out

**feels like a right fool..**

xjlittle 01-15-2007 11:33 AM

Do you the nfs server and portmap service started on the server? See the howto at http://tldp.org/HOWTO/NFS-HOWTO/server.html to check and make sure everything is running ok.

obourdon 04-17-2007 03:05 AM

try using the -o nolock option from the nfs mount command

mether 04-17-2007 04:08 AM

First check :

#shoumount -e serverip

If you see the shares check the settings suggested by xjlittle

Jim_B 05-15-2007 01:22 AM

same issue, -o nolock works perfectly...
 
Thanks. ;)

Firerat 10-02-2008 06:39 PM

Just had the same problem, opened up the firewall on the server and it is working now

guanx 04-22-2009 05:33 PM

Quote:

Originally Posted by obourdon (Post 2714156)
try using the -o nolock option from the nfs mount command

It works. Thank you!

jazz13 04-12-2010 06:39 AM

Quote:

Originally Posted by obourdon (Post 2714156)
try using the -o nolock option from the nfs mount command

Worked out! Thank you.

bhussein 06-12-2014 04:40 AM

Quote:

Originally Posted by obourdon (Post 2714156)
try using the -o nolock option from the nfs mount command

I'm having the same problem as the rest here, but the command above works for me too "Thanks Obourdon", but if i want to add the mount to fstab how can i do that?

if i edit the /etc/fstab and add this entry

nfsrvr:/main /content/html nfs noauto,user,rw 0 0

it doesnt mount it on the next reboot, so i need to add the -o nolock but not sure how to do that in fstab.

Thanks,

bhussein 06-12-2014 05:48 AM

Quote:

Originally Posted by bhussein (Post 5186893)
I'm having the same problem as the rest here, but the command above works for me too "Thanks Obourdon", but if i want to add the mount to fstab how can i do that?

if i edit the /etc/fstab and add this entry

nfsrvr:/main /content/html nfs noauto,user,rw 0 0

it doesnt mount it on the next reboot, so i need to add the -o nolock but not sure how to do that in fstab.

Thanks,

Please ignore i've managed to resolve by doing the following


nfsrvr:/main /content/html nfs nolock,nfsvers=3 0 0

jefro 06-12-2014 02:44 PM

OK, thanks for the update and solution.

You are also welcome to start new threads on topics if you wish.


All times are GMT -5. The time now is 11:17 PM.