LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-06-2004, 04:17 PM   #1
wahhh
LQ Newbie
 
Registered: Sep 2004
Location: Vancouver
Distribution: Debian
Posts: 2

Rep: Reputation: 0
NFS Input/Output error after filesystem mounted problem


Hi Everyone,

I am new to this forum and I am having this strange issue with NFS with my FreeBSD NFS server and a Linux (Debian) NFS client. I've been searching around and haven't had much success in finding any solutions.

Essentially I just want to share the filesystem as if it were a local filesystem where one ofmy user groups has full access to it. The problem I am having is after I mount an exported filesystem. Once the filesystem is mounted, I can access it and copy files over as a non-root user without any problems. However after maybe 20 - 30 min. after being connected, when I try access the mounted file system, I get a:
bash: cd: /s01: Input/output error

The root user on the NFS client can still access the file system without problems. The only work around I have discovered is by remounting the file system. Has anyone come across a problem like this, and if so are there any solutions?




I mount the filesystem in /etc/fstab with the following:

ws123:/s01 /s01 nfs rsize=4096,wsize=4096,hard,intr 0 0



Thanks

Zach
 
Old 09-06-2004, 07:48 PM   #2
wahhh
LQ Newbie
 
Registered: Sep 2004
Location: Vancouver
Distribution: Debian
Posts: 2

Original Poster
Rep: Reputation: 0
oh, i don't know if its relevant, but I am using a ReiserFS on my linux box.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS hangs nfssvc: input/output error kawinter Linux - Networking 3 10-23-2007 11:13 AM
mounted filesystem error.... Basslord1124 Linux - General 4 03-17-2005 01:29 PM
Cannot read table of mounted filesystems: Input/output error k0ljat Linux - Software 1 09-18-2004 01:51 PM
Random 'Input/output error' with nfs ggeorgiev Linux - Networking 0 05-26-2004 06:43 PM
Input/Output errors when mv or cp from local machine->NAS device via NFS? Matt@Ants Linux - Networking 2 06-24-2003 01:17 PM


All times are GMT -5. The time now is 04:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration