LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-24-2003, 07:15 AM   #1
pablovschby
Member
 
Registered: Oct 2003
Posts: 153

Rep: Reputation: 30
NFS: how can I get write-access??


Hello

A RedHat9-Shrike-Dist as an NFS-server... all nfs-services are starting successfull...here's my /etc/exports:
  • ......cat /etc/exports
    /home/test %ip of client% (rw)
well...everything works...(but write-access)....I'm mounting this share on a Neolinux (NW Capio 508)-TClient with the ip %ip of client%... like this:
  • mount %ip of rh9-server%:/home/test /writable/mount_server -o rw
....and also that works without an error message....but if I change to the directory /writable/mount_server on the client and want to create a new file with "vi".... per command "wq!"....this error occurs
Code:
can't open file for writing...
mmmh.... I can't understand what my redhat is doing...

cause I share this folder for the client as "rw" ... and I mount the share on the client with the options "rw".....
what the hell did I wrong?
thanks for all advices
pablo
 
Old 12-24-2003, 07:33 AM   #2
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
What user as your trying to write the files as? If it is the root user on the client machine then this is the correct behaviour, the root user on an NFS client is 'squashed' be default. Any UID 0 (root) access from the client gets mapped to the nobody user on the server. You can change this by using the no_root_squash option on the server. Typically set in /etc/exports something like
Code:
/home      192.168.1.0/24(rw,no_root_squash,sync)
cheers

Jamie...
 
Old 12-24-2003, 08:15 AM   #3
Parksy
Member
 
Registered: Apr 2003
Distribution: Gentoo/Mandrake 10.0
Posts: 110

Rep: Reputation: 15
Re: NFS: how can I get write-access??

Make sure you don't have a space after the ip address:
Code:
/home          192.168.0.1 (rw) - bad
/home          192.168.0.1(rw) - good
 
Old 12-24-2003, 08:39 AM   #4
pablovschby
Member
 
Registered: Oct 2003
Posts: 153

Original Poster
Rep: Reputation: 30
thanks a lot!!!!!

it works now with:
Code:
/home/test %client-ip%(rw,no_root_squash,sync)
problem is solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grip : no write access to write encoded file bidouilleur Linux - Software 5 10-09-2010 09:23 PM
NFS write access denied on one of two filesystems TomF Linux - Security 2 02-23-2005 08:48 PM
NFS problem - no write access? aaronfg Linux - Newbie 3 12-22-2004 05:52 AM
Write to NFS reiserfs? Euronymous Linux - Networking 1 10-24-2004 03:26 PM
NFS non root read write access matthewkeen Linux - Networking 8 09-09-2004 10:52 PM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration