LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-27-2004, 10:49 PM   #1
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Rep: Reputation: 15
newbie setting up lan - can't see local webserver.


Hi,

Ive been using linux (slackware 9.1) for a bit now, and a I recently got a Mac Powerbook G3. I am trying to set up a simple lan so I can do internet sharing, file sharing etc. but I cant get the mac to see the linux box.

My linux box is connected to the net via a usb dsl modem. It is also running apache, and has a site on http://xxx.xxx.xxx.xxx:3000/

I have connected both machines to a hub, and ran this command:
ifconfig eth0 192.168.0.1 broadcast 192.168.0.255 netmask 255.255.255.0

and set up a static ip on the laptop:
ip: 192.168.0.101
subnet mask: 255.255.255.0
router address: 192.168.0.1

If, from the linux box I ping the laptop "ping 192.168.0.101" it pings fine. I dont know how you ping on a mac, but if I point a browser to 192.168.0.1:3000 (which I CAN see from the linux machine [and the outside world]), the hub shows that the mac sends, the linux box recieves packets, but I dont get the page.

Does anyone know what I might try to get this working?

Thank you,

nmoog
 
Old 03-28-2004, 12:17 AM   #2
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Original Poster
Rep: Reputation: 15
Figured it out - it was an iptables issue. I copied some rules from the IP-Masquerade-HOWTO and it worked fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup local machine to allow lan machines to retrieve its local user mail. Brian1 Linux - Networking 3 03-30-2006 06:04 AM
Can access local LAN Webserver, but not Internet spaceuser Debian 11 08-23-2005 01:54 AM
Local webserver -- How to deny all client install their local web server--Please help b:z Linux - Networking 13 04-16-2005 08:11 PM
Setting up a webserver inside a lan, which should be accessible from outside seidren Linux - Networking 2 05-18-2004 09:26 AM
newbie question: setting up webserver geo_h Linux - Networking 1 09-09-2003 02:20 PM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration