LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-24-2006, 06:44 PM   #1
spy_X
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Rep: Reputation: 0
New slackware 11 install, cannot access port 80


Hey,

I just installed slackware 11, i cannot access port 80 from outside my network. The port was working fine, passing thru my dlink router to a Ubuntu box. I have open up some of the other ports from the inetd.conf, and apache.conf is using port 80. I did a scan from outsite my network and getting this:

Tue, 24 Oct 2006 15:30:34 -0700

The host xx.xx.xxx.xxx has a service running on port 21 (ftp).
The host xx.xx.xxx.xxx has a service running on port 23 (telnet).
The host xx.xx.xxx.xxx has a service running on port 110 (pop3).

The host xx.xx.xxx.xxx does not have a service running on port 53 (domain).
The host xx.xx.xxx.xxx does not have a service running on port 80 (http).
The host xx.xx.xxx.xxx does not have a service running on port 139 (netbios-ssn).

im not sure if i am missing something with in a slackware conf file. http is not listed in
the inetd.conf file. is it something i need to add to it?

Thanks in advance for anyone that can help.
--dave
 
Old 10-24-2006, 06:49 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Are you saying you actually want to run a webserver on the Slackware machine?

Is Apache installed? Apache is not started from inetd.conf, by the way, but from /etc/rc.d/rc.httpd.
 
Old 10-24-2006, 06:56 PM   #3
spy_X
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Yes it is running, I can see the "Hey it worked" test page. I can access it via a browser typing the 192.xxx.x.xxx IP or the 72.xxx.xx.xxx IP that is in my router from my ISP from pc's on the network here. Its just if i get on another pc, or dial up via wireless pc-card outside the network, i cannot access port 80, and I can access port 21 and port 23 from outside just fine.
 
Old 10-24-2006, 07:02 PM   #4
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I assume you have checked if the IP has changed since you forwarded the port on the router?

You are saying that you can only see the page on the local machine, not from a computer on the LAN either? Are you sure that no firewall is running on the Slackware machine?

Does this command show anything:

iptables -L
 
Old 10-24-2006, 07:08 PM   #5
spy_X
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I have 2 windows pc, and 1 linux and now the slackbox. all 4 can view the test page just fine with in the internal side of the router. Yes i have verifyed and am using the correct IP. I have no experince with iptables, if this is the problem, that i will need to read up on it.

Here is the output:

root@capone:~# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
 
Old 10-24-2006, 07:16 PM   #6
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
That output is fine, it shows that no firewalling is going on.

Are ports 21 and 23 forwarded to this Slackware machine as well, or do they go to a different machine?
 
Old 10-24-2006, 07:22 PM   #7
spy_X
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Same machine. It just wierd, Having not use slackware in years, I am just not sure if something is blocking it. I will pull out the forwarding in the router and re-boot and add it back. I do appreciate the help!!
 
Old 10-24-2006, 07:27 PM   #8
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Perhaps it is something in the Apache configuration then, which is not allowing remote requests. I have only installed Apache twice myself though, so I am not up on it's configuration options.
 
Old 10-24-2006, 07:38 PM   #9
spy_X
LQ Newbie
 
Registered: Oct 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Ok kewl... i'll do some checking again in the apache config file. Thanks for the help!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firewall : port access consty Linux - Networking 1 06-29-2006 04:48 AM
Port Access Fool Mandriva 4 02-21-2006 06:53 AM
Cannot access Port 80 arizona Linux - General 21 08-26-2003 01:32 AM
can't access some port from outside azure_ss Linux - Networking 5 10-02-2002 11:12 AM
Controlling port access? ugenn Linux - Security 3 05-13-2002 02:39 AM


All times are GMT -5. The time now is 09:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration