LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-02-2004, 08:21 PM   #1
happyoutkast
LQ Newbie
 
Registered: May 2004
Distribution: mandrake
Posts: 7

Rep: Reputation: 0
Unhappy networking mandrake to windows via ethernet crossover cable


hello, i'm rather new to linux and am currently running 2 dual boot machines on my small "network"
i have these 2 computers connected directly using a crossover cable connecting each machine's ethenet (nic) cards. then on the gateway (my faster of the 2 comps) i have a second ethernet card (this machine)
now to start, this comp has windows xp for the main boot and mandrake linux 10
the other machine's running windows 98 and mandrake 9.2. i was able to get the network running with a shared internet connection working quite successfully using the xp's network configuration wizard on both machine's windows install. however with linux it's a different problem. i've run mandrake's internet connection sharing wizard so many time's it's sick, and have configured them many times over. the internet works on this machine, but on the client the internet won't work in either windows or linux. i'm about ready to give up, honestly i've done everything i can possibly think of and it still doesn't work. . .any help would be greatly appreaciated. if more information is needed, please ask.

michael c.
 
Old 05-02-2004, 09:28 PM   #2
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
We are going to need a lot more information.

First off, when your boot your gateway into linux dose your client machine get a DHCP address?

If it does not get an address, is your gateway machine set up to be a DHCP server?

If you do get an IP address do you get a default gateway and DNS information correctly?

Can you ping the ip address of your gateway machine? Can you ping an IP address of something on the internet (216.239.57.99 = Google IP address)?

If you can ping an IP, can you ping a URL? If not, do you get the name resolved to an IP?

I'm sure I have other question, just can't think of them now...

Cheers,

MrKnisely
 
Old 05-03-2004, 12:13 AM   #3
happyoutkast
LQ Newbie
 
Registered: May 2004
Distribution: mandrake
Posts: 7

Original Poster
Rep: Reputation: 0
well, here's my configuration:

basically, on my eth1 (internet connection) it works fine, as a matter of fact i did the original post in linux. however reguarding setting my machine as a dhcp server, no i didn't do that, didn't know i had to. i did notice that the mandrake connection sharing wizard did install a few packages, including samba and squid. i think i might have them configured correctly.

now reguarding the ip address, it does have one, at least on this end, says the ip address for my ethernet card (eth0), configured statically. i tried using dhcp for that card but it didn't work. i figured that's because that's not an internet connection, so therefore no dhcp server to resolve from. setting one up, now that you raise the point, might fix the problem. again i'm still quite new to linux and although i've gotten decent at making it work, networking to it has been horrible. anyways, i'm not sure how to ping in linux, maybe by typing ping, i don't know for certain. anyways, as far as an ip address to ping to, i'm not sure, i only have the ip of the ethernet card (eth0) connected to it on this end, than the other end configured to use this comp as a gateway. i have looked at the network monitoring utility in kde and it definitely has activity on that connection. however the comps actually "talking" to eachother isn't happening. i can't access the network shares on that comp nor can it access the internet like it can in winblows.

Last edited by happyoutkast; 05-03-2004 at 12:16 AM.
 
Old 05-03-2004, 12:23 AM   #4
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
You need to configure the second NIC on the gateway (in this case, eth0 apparently) with the IP 192.168.0.1, give it a subnet mask of 255.255.255.0. On the second computer, give eth0 an IP of 192.168.0.2, and subnet mask 255.255.255.0, and (the important part) gateway of 192.168.0.1.

This is a static configuration, but it's very simple and a "no-brainer".

This is, of course, assuming that eth1 on the main box is getting an IP other than 192.168.0.something. If eth1 is already getting an IP on that subnet, then you need to use a different subnet for eth0. Try 10.0.0.1, same netmask, the second computer will use 10.0.0.2, same netmask, and gateway of 10.0.0.1.

Come to think of it, before you do anything else boot both machines into Linux. On each one, do
$ ifconfig -a

then cut and paste the output here. That way we can see if they're already configured correctly or not. The last part you'll have to do is enable IP forwarding on the "gateway" machine. With IP forwarding on, you should definitely setup a firewall too.

Last edited by chort; 05-03-2004 at 12:25 AM.
 
Old 05-03-2004, 10:18 PM   #5
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
Squid...kind of rubbery but good!

Another thing to note is that you installed squid. Squid is a caching proxy server... what that means don't worry about.

Know this though, you should be able to go into your proxy settings on your workstation to which you are trying to share you internet connection and put in the IP of your gateway machine as well as the port on which squid is running (3128 by default) and you should be able to get an internet connection.

Acting as a router and acting as a proxy server are two completely different things. We may be trying to make a router out of a proxy here.

MrKnisely
 
Old 05-03-2004, 11:16 PM   #6
happyoutkast
LQ Newbie
 
Registered: May 2004
Distribution: mandrake
Posts: 7

Original Poster
Rep: Reputation: 0
Actually, i should clarify, i didn't install squid, the mandrake "internet connection sharing wizard" did. why it did i don't know. . .so far that static configuration sounds good and easy. . .not sure if winblows will allow me to specify ports for a gateway, and i need this to work for both winblows and linux, since they're both dual boot machines. (trying to wean people from winblows is hard, especially when certain windows games WILL NOT work in linux. . .)
 
Old 05-03-2004, 11:33 PM   #7
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Squid only proxies HTTP traffic, and by default it's not a transparent proxy (at least that I have seen--you would need iptables setup to do that). You can edit the proxy settings in your browser configuration, but it shouldn't matter. Squid can't block your Internet access.
 
Old 05-06-2004, 08:29 PM   #8
happyoutkast
LQ Newbie
 
Registered: May 2004
Distribution: mandrake
Posts: 7

Original Poster
Rep: Reputation: 0
ah well, that problem has been replaced my a more serious problem. i updated to mandrake 10, booted into it and it worked fine. . .and i didn't change any settings other than trying to get the network to work. . .but either ways my old 9.2 desktop settings, etc were still there
then i went to go back into it and i get an error when i try to start x:
connection reset by peer, no screens found for device (or something similar, i really don't know too much in linux command line, so i've been forced to work in windows lately. . .)
annoying, for sure, have no clue how to fix it, i think mandrake 10 had a pre-release of x. . .all i can think is to reinstall x, i've already run xf86config many times and it still doesn't work, i have noticed that instead of the old XF86Config file it's not XF86Config-4. . . .why this happens to me i don't know, didn't adjust any x settings, hardware's still the same. . .it just decided that it didn't want to work. . .heh

WOW I FIXED IT!!! i'm in linux with x running, how did i know the install chose a driver that didn't exist. changed my driver back to nv instead of nvidia like it had it and it works now!!! cool, i fixed someting. . .now if the interenet connection sharing would work that would rock!!!

to prevent spam i edited this current message: i typed ifconfig -a and of course in case the previous message was mistyped i keyed in ipconfig -a as well. . .i got this: "bash: ifconfig: command not found" i also configured the winblows machine statically with ip address 196.152.0.156 (to mimmick winblows settings) and gateway 192.156.0.1 (this machine) and . . . .the internet still doesn't work on the client machine. . .i just about give up, i really thought this was supposed to work easier. but unfortunately i have to admit, when it comes to setting up a network, winblows makes it much easier. . .

Last edited by happyoutkast; 05-07-2004 at 12:33 AM.
 
Old 05-07-2004, 01:58 AM   #9
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
/sbin might not be in your path, try /sbin/ifconfig -a

You didn't indicate that you've checked IP forwarding yet, so it's quite possible that everything else was configured correctly but you just didn't enable forwarding.
 
Old 05-07-2004, 01:58 PM   #10
happyoutkast
LQ Newbie
 
Registered: May 2004
Distribution: mandrake
Posts: 7

Original Poster
Rep: Reputation: 0
honestly, i never saw the option for ip forwarding, so it's possible it hasn't been set. where do you set it at? actually i don't know command line in linux too much at all, so i've been doing this all under x running kde.
strangely enough, i went back into linux today and just typed ifconfig -a in my terminal window and got this. honestly i don't know why it suddently decided to work, kind of like x suddenly deciding not to work. anyways, for your information here it is, the output:

eth0 Link encap:Ethernet HWaddr 00:04:5A:8D:61:E3
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.248.0
inet6 addr: fe80::204:5aff:fe8d:61e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:170 errors:0 dropped:0 overruns:0 frame:0
TX packets:141 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14664 (14.3 Kb) TX bytes:20894 (20.4 Kb)
Interrupt:17 Base address:0xd000

eth1 Link encap:Ethernet HWaddr 00:09:5B:0A:E4:09
inet addr:24.116.153.55 Bcast:255.255.255.255 Mask:255.255.248.0
inet6 addr: fe80::209:5bff:fe0a:e409/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17353 errors:0 dropped:0 overruns:0 frame:0
TX packets:2606 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2461532 (2.3 Mb) TX bytes:254746 (248.7 Kb)
Interrupt:19 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:194 errors:0 dropped:0 overruns:0 frame:0
TX packets:194 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:18902 (18.4 Kb) TX bytes:18902 (18.4 Kb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
eth0 Link encap:Ethernet HWaddr 00:04:5A:8D:61:E3
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.248.0
inet6 addr: fe80::204:5aff:fe8d:61e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:170 errors:0 dropped:0 overruns:0 frame:0
TX packets:141 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14664 (14.3 Kb) TX bytes:20894 (20.4 Kb)
Interrupt:17 Base address:0xd000

eth1 Link encap:Ethernet HWaddr 00:09:5B:0A:E4:09
inet addr:24.116.153.55 Bcast:255.255.255.255 Mask:255.255.248.0
inet6 addr: fe80::209:5bff:fe0a:e409/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17353 errors:0 dropped:0 overruns:0 frame:0
TX packets:2606 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2461532 (2.3 Mb) TX bytes:254746 (248.7 Kb)
Interrupt:19 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:194 errors:0 dropped:0 overruns:0 frame:0
TX packets:194 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:18902 (18.4 Kb) TX bytes:18902 (18.4 Kb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crossover ethernet cable business ygfperson Linux - Networking 5 07-23-2004 05:07 PM
Trouble networking two Linux computers (via crossover cable) lrt2003 Linux - Networking 3 06-29-2004 09:06 AM
Transferring Files from Windows XP to Suse 9.1 through crossover cable sirtrack Linux - Networking 3 06-20-2004 08:26 PM
Crossover cable eggoz Linux - Networking 4 03-14-2004 12:49 PM
Slackware 9, Windows XP, crossover cable and an internet connection dxdad Linux - Networking 37 11-11-2003 08:45 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration