LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-27-2008, 03:36 PM   #1
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Rep: Reputation: 15
Unhappy network not working at all!


Hi all! I have a problem connecting to internet - I can't connect to internet at all!. I have a DSL (with dhcp) connection and 2 pcs are connected to it via ethernet switch. I have tried Ubuntu (6.06 up to 8.04), Knoppix 5.3.1 and had openSUSE 10.3 installed for a while. I've tested LiveCDs on both pcs, have tried connectding pcs directly to DSL modem, but the network still isn't working! So, currently i'm running xp :-/ (of course, internet on xp works only after install of proper drivers). I have 2 network cards for this PC: Intel Pro/100 & Realtek RTL 8139. Oh, and when the linux is running all the `link` lights (on both network switch & network card) are on. Also, I connected my work laptop (opensuse 10.3) to my home DSL modem, and there also was no connection!

What could be the problem here? Cause I really want to switch to linux @ home. I ran ifconfig on ubuntu 8.04 livecd (on both network cards) and here are the results:

Code:
eth0      Link encap:Ethernet  HWaddr 00:11:25:6F:1D:5C
          inet6 addr: fe80::211:25ff:fe6f:1d5c/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1102 (1.0 Kb)  TX bytes:5284 (5.1 Kb)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:254 errors:0 dropped:0 overruns:0 frame:0
          TX packets:254 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:18988 (18.5 Kb)  TX bytes:18988 (18.5 Kb)



eth0      Link encap:Ethernet  HWaddr 00:11:25:6F:1D:5C
          inet6 addr: fe80::211:25ff:fe6f:1d5c/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1728 (1.6 Kb)  TX bytes:7054 (6.8 Kb)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:286 errors:0 dropped:0 overruns:0 frame:0
          TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21532 (21.0 Kb)  TX bytes:21532 (21.0 Kb)
Or maybe proper networking will be avaliable after full install?

Thanks in advance,

-skazhy
 
Old 11-27-2008, 03:42 PM   #2
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
eth0 has no ip. try setting up ip manually. if you are using ipv6 then i don't know.

Last edited by hasanatizaz; 11-27-2008 at 03:43 PM.
 
Old 11-27-2008, 05:58 PM   #3
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Hi skazhy

In your network settings, disable IPv6, make sure DHCP is enabled, then restart your pc and check again. It should get an IP address now.
 
Old 11-28-2008, 12:52 PM   #4
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Original Poster
Rep: Reputation: 15
hey, is there something like YaST for Ubuntu? Or where can I see more detailed network settings?
 
Old 11-28-2008, 05:01 PM   #5
framp
Member
 
Registered: Apr 2003
Location: Stuttgart, BW Germany
Distribution: SuSE 10.3-11.0, Knoppix, Ubuntu 8.10, Fedora 10
Posts: 119
Blog Entries: 5

Rep: Reputation: 15
Quote:
Originally Posted by skazhy View Post
hey, is there something like YaST for Ubuntu? Or where can I see more detailed network settings?
What info are you looking for?
 
Old 11-29-2008, 08:31 AM   #6
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Original Poster
Rep: Reputation: 15
OK, I installed Ubuntu 8.10, disabled IPv6 and enabled dhcp. But still nothing is working. In the upper right corner it shows that `network connections are disconnected` Also, I tried to connect my PC directly to modem, but it's still the same.
 
Old 11-29-2008, 08:35 AM   #7
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Hi skazhy

Can you please do the following:

(as root, on a konsole)

Code:
ethtool eth0
And paste the output in this thread.

Thanks
 
Old 11-29-2008, 09:20 AM   #8
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Original Poster
Rep: Reputation: 15
here it is:

Code:
Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: g
	Wake-on: d
	Current message level: 0x00000007 (7)
	Link detected: yes
 
Old 11-29-2008, 10:52 AM   #9
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Based on previous messages, and in combination with the above output from ethtool, I have come a possible conclusion

>Your router is not issuing an IP address because the MAC address of your NIC is different than the one it is set to when using windows.<

To verify this, boot up in Windows, open a command line (Start -> run -> cmd), then type in

Code:
ipconfig /all
And compare the `Physical Address' that it reports to the one reported above (00:11:25:6F:1D:5C). If they differ, come back here, and we'll give you help on how to change it in Linux.

What baffles me though, is that you say that you have an Intel Pro/100, and a Realtek RTL 8139 NIC, but the MAC address shown above belongs to IBM Network cards: http://www.coffer.com/mac_find/?stri...3A6F%3A1D%3A5C
 
Old 11-29-2008, 11:03 AM   #10
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by x_terminat_or_3 View Post
What baffles me though, is that you say that you have an Intel Pro/100, and a Realtek RTL 8139 NIC, but the MAC address shown above belongs to IBM Network cards: http://www.coffer.com/mac_find/?stri...3A6F%3A1D%3A5C

The Intel Pro/100 is an integrated card, an I have IBM/Lenovo PC. Maybe thats why..
 
Old 11-29-2008, 11:05 AM   #11
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Fair enough, are you able to assess that the MAC address your network card is bound to, is the same in Windows as on Linux?
 
Old 11-29-2008, 01:32 PM   #12
skazhy
LQ Newbie
 
Registered: Nov 2008
Location: Latvia
Distribution: arch
Posts: 23

Original Poster
Rep: Reputation: 15
i re-installed ubuntu 8.10 & spared some GBs for XP. But there was strange thing. Wen ubuntu was connecting to eth0, it showed, that 126 updates are avaliable (in a list). But when I tried to install them, there were some error messages (disconnected etc). I guess it downloaded the list from the internet right?

and address for Intel Pro/100 card is the same in ubuntu & winXP - 00:11:25:6f:1d:5c
and address for Realtek card is also the same in both systems - 00:08:54:3d:e2:57
 
Old 12-01-2008, 02:11 AM   #13
soroccoheaven
Member
 
Registered: Jul 2007
Distribution: mandrake Mandriva Redhat CentOS Slackware
Posts: 221

Rep: Reputation: 30
check your dsl modem configuration and make sure it is configured for pppoe and dhcp is enabled.(if it is configured for bridge mode this setup will not work you have to put bridge with the box which is dialing the connection.)
now enable dhcp in your linux box, and browse the internet.
 
  


Reply

Tags
dhcp, dsl, networking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Network] Getting network working during installation (netinstall) dubbeld00 Debian 2 05-30-2006 01:58 PM
Internet not working, network working Vossy Linux - Networking 3 12-20-2005 06:20 PM
Network card not working? Cannot activate network device eth0 lifeonitsown Linux - Networking 1 11-17-2005 07:30 AM
Internet working, network not working... phoenix07 Fedora 1 04-11-2004 03:30 AM
Ethernet Adapter not working or Network not working... phoenix07 Linux - Hardware 2 04-09-2004 07:58 PM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration