LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-16-2004, 08:17 PM   #1
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Rep: Reputation: 15
Network is unreachable


I am running FC2 on a desktop and Knoppix 3.4 (Live CD, not harddrive) on a laptop and am trying to network the two with a crossover cable. I want to image my harddrive on my laptop before I use QTParted to make room for Linux. I have the /etc/exports set up. I currently reads
Code:
/home/confidential/image
I start up the nfs service on the desktop using /etc/rc.d/init.d/nfs start. In the Network applet, I have the IP of the NIC in my desktop set up as 192.168.0.1 and the name as main.home. I have my user account on both computers in the users group with a GroupID of 100. When I type
Code:
mount -t nfs 192.168.0.1:/home/confidential/image /home/Knoppix/image
I get the error
Code:
mount: RPC: Remote system error - Network is unreachable
How can I get my two computers to communicate? I figured that this would be easier than getting two XP Home computers to communicate since Linux was made for a network.
 
Old 06-16-2004, 08:50 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Quote:
How can I get my two computers to communicate? I figured that this would be easier than getting two XP Home computers to communicate since Linux was made for a network.
So was the Windows NT kernel, but Windows misconceptions aside...

Are you sure it is a crossover cable, and not a patch cable? If it is a crossover cable, did you set both machines up with IP addresses in the same subnet and range?

Can you ping one machine from the other?

Last edited by MS3FGX; 06-16-2004 at 08:52 PM.
 
Old 06-17-2004, 02:49 PM   #3
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Original Poster
Rep: Reputation: 15
I am sure that it is a crossover cable because I split it open and redid the wiring myself.

I've never setup my own network before, so I am not sure what you mean when you talk about the IP addresses being in the same subnet and range.

I have been successful in pinging the machines using Windows, but I don't know how to ping machines in Linux.

Last edited by confidential007; 06-17-2004 at 03:43 PM.
 
Old 06-17-2004, 03:41 PM   #4
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Original Poster
Rep: Reputation: 15
After playing with some settings, the mount command now produces the error
Code:
mount: RPC: Remote system error - No route to host
This appears to be a step in the right direction since the network must now be reachable.

Here is a rundown of all of my settings:

In Knoppix 3.4, I ran the Network Card Configuration utility (netcardconfig). I answered no to use DHCP broadcast since I dont have a DHCP server on my "network".
IP Address: 192.168.0.2
Network Mask: 255.255.255.0
Broadcast Address: 192.168.0.255
Default Gateway: 192.168.0.254
Nameserver(s): 192.168.0.254

netcardconfig produces the following output:
Code:
ifconfig eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255 up
route add default gw 192.168.0.254
SIOCADDRT: File exists
auto 1o eth0
Setting Nameserver in /etc/resolv.conf to 192.168.0.254
Done.

In FC2:
----In the Network Configuration applet:
--------DNS tab:
------------Hostname: main.home
------------Primary DNS: 209.151.160.51 (my ISP's DNS server)
------------Secondary DNS:
------------Tertiary DNS:
------------DNS Search Path:
--------Hosts tab:
------------IP: 192.168.0.1
------------Name: MAIN
------------Aliases:
--------General tab for eth0:
------------IPv6 enabled
------------Manual IP Address Settings:
----------------Address: 192.168.0.1
----------------Subnet mask: 255.255.255.0
----------------Default gateway address: 192.168.0.254
Sorry for the formatting, but spaces don't work, I can't use TABs, and I don't want to format it as code
 
Old 06-17-2004, 05:11 PM   #5
mermxx
Member
 
Registered: Apr 2004
Location: Wales
Distribution: rh9, winxp
Posts: 411

Rep: Reputation: 30
u can use the ping command in a terminal window and use ctrl - c to close.
a good list of ping commands can be found at http://www.computerhope.com/unix/uping.htm
but it would seem that the network ip addresses and isp addresses need a bit more attention.....if nobody get backs to u with more today will offer more help tomorrow as just browsing through quickly :-)
 
Old 06-18-2004, 12:33 PM   #6
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Original Poster
Rep: Reputation: 15
I tryed the ping command. last night. I was able to have each computer ping its own IP address, meaning that the ethernet interfaces had been brought up properly. However, when I tryed to ping the other computer, all of the packets were lost. I guess that there must be something wrong with some of my network parameters. Can someone help me sort them out and fix the problem?
 
Old 06-18-2004, 12:44 PM   #7
Oxyacetylene
Member
 
Registered: Apr 2004
Location: Greensboro, NC, USA
Distribution: Debian
Posts: 134

Rep: Reputation: 15
What is the IP address, subnet mask, and default gateway of the 2 machines? use the ifconfig and route -F commands to get the info...
 
Old 06-18-2004, 07:45 PM   #8
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Original Poster
Rep: Reputation: 15
Here is the information from my FC2 desktop:
Code:
[root@main sbin]# ./ifconfig
eth0      Link encap:Ethernet  HWaddr 00:07:95:EB:48:4C
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::207:95ff:feeb:484c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:360 (360.0 b)  TX bytes:546 (546.0 b)
          Interrupt:11 Base address:0xd800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1592 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1592 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1986584 (1.8 Mb)  TX bytes:1986584 (1.8 Mb)

[root@main sbin]# ./route -F
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         192.168.0.254   0.0.0.0         UG    0      0        0 eth0
and here is the information from my Knoppix 3.4 laptop after running netcardconfig with no DHCP and the defaults:
Code:
root@ttyp0[knoppix]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:03:25:10:89:1D
          inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:9 Base address:0x1c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:300 (300.0 b)  TX bytes:300 (300.0 b)

root@ttyp0[knoppix]# route -F
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.0.254   0.0.0.0         UG    0      0        0 eth0
 
Old 06-18-2004, 08:08 PM   #9
Oxyacetylene
Member
 
Registered: Apr 2004
Location: Greensboro, NC, USA
Distribution: Debian
Posts: 134

Rep: Reputation: 15
Do you have any sort of firewall rules that could be blocking the traffic? You have both machines in the same subnet so that part is fine.
 
Old 06-18-2004, 09:05 PM   #10
confidential007
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: Red Hat Linux, Fedora Core, Knoppix, tomsrtbt
Posts: 37

Original Poster
Rep: Reputation: 15
I have disabled the firewall on my FC2 machine. I do not know if a firewall is operating on the Knoppix machine. If it is, I don't know how to turn it off.
 
Old 06-19-2004, 03:06 PM   #11
Oxyacetylene
Member
 
Registered: Apr 2004
Location: Greensboro, NC, USA
Distribution: Debian
Posts: 134

Rep: Reputation: 15
you could try adding a route to each machine to the specific IP address of the other and using its own NIC as the gateway for that IP. If that doesn't work then I would try using two regular patch cables plugged into a hub or switch. I'm not doubting your cable, but it would be worth trying a different one, or hooking them up to a hub or switch instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Unreachable? biledaemon Slackware 4 10-24-2005 02:05 PM
Network Is Unreachable!!!!!!!!!!!!!!!!!!!!! koodoo Linux - Newbie 4 02-19-2005 09:51 AM
Network is unreachable kakarizz Linux - Networking 1 12-16-2003 09:16 AM
Network is unreachable radix Linux - Networking 4 05-09-2002 01:06 AM
network unreachable topsoil Linux - Networking 6 08-05-2001 12:28 PM


All times are GMT -5. The time now is 06:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration