LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Network interface missing (http://www.linuxquestions.org/questions/linux-networking-3/network-interface-missing-943986/)

kwill 05-08-2012 11:10 PM

Network interface missing
 
I have installed kernel 3.2.16 (PCLinuxOS) replacing 2.8.38 which had problems with swap and have "lost" the wlan0 interface. Rebooted a couple of times but it has made no difference. Was working before. Wicd just doesn't find my network. Eth0 is still working O.K.

The Wifi device is listed in lsusb, the module is in the kernel but all I get is "device not found/does not exist"

I cannot find anything in the logs to say it has not been initialised or failed to start.

***********

ifconfig -s wlan0
Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
wlan0: error fetching interface information: Device not found

***********

iwconfig wlan0
wlan0 No such device

***********

service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]
Bringing up interface wlan0: Device wlan0 does not seem to be present, delaying initialization.
[FAILED]

***********

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Could not read interface wlan0 flags: No such device
Failed to initialize driver interface
***********

What has happened and how do I fix it please?

mdlinuxwolf 05-09-2012 06:00 AM

If you have your CD or DVD, try booting into that in rescue mode and see if there is a repair option that will let you preserve all of your data. If there is, go for it after making a good backup.

Also, try getting the very latest live DVD or CD for your distribution. If the wireless doesn't work with the latest live version, then they dropped your driver for your card. This leaves you with 2 choices. First, downgrade and never update again. Second, begin testing other distributions to see what plays nicer with your hardware.

My suggestions would be to test the following.

Mint KDE or main edition. (The main edition uses Unity desktop, caveat emptor. KDE is a normal desktop. LXDE and Xfce are lightweight desktops)
Mepis (needs multimedia codecs)
Kubuntu
Fedora (needs multimedia codecs)
PC-BSD (but be sure your backup file system can be read by both UNIX and Linux -- Use FAT32 or NTFS Reiser)
Ubuntu
Open SuSE (needs multimedia codecs) but also has some nice server options built in.

... or whatever other user friendly distribution interests you.

qlue 05-09-2012 12:39 PM

Have you tried booting into the older kernel and seeing if that restores your wlan0 ?

kwill 05-09-2012 05:40 PM

For some reason the system has not setup a new grub menu.lst so it only goes to new kernel. There is an un-openable .#menu.lst file that presumably should have carried that out BUT again there seems to be nothing in logs as to why it fell over.

The kernel has the right driver (broadcom) installed in it as the logs show when I try to set up a connection in Drake.

It seems that somewhere down in the depths something is preventing the wlan interface from starting.

To try a new install from Cd means that I have to reinstall all the applications and would take ages. Maybe I should have updated from Cd. By the way the new kernel wasn't installed while running as I seen before but when I rebooted. Something to do with 3.*.* kernel? I don't want to go back to previous kernel as it has real problems with kswapd0 & khugepaged, every so often it churns away for at least 5 minutes, doing what? It locks up the computer and even stops the clock from running. I could probably uninstall new kernel from synaptic.

I use PCLinuxOS as it has a good working version of Avidemux which other distro's don't. My preferred Kubuntu8.04LTS doesn't as the sound won't work much of the time with Avidemux. Later versions of Kubuntu don't even seem to run on this HP/Compaq DC7600 series computer. Mepis kept doing horrible things, like changing font size up every time it was booted and up again the next time, and up .... I have never had much luck with straight Debian so I am more or less stuck with PCLinuxOS.

mdlinuxwolf 05-09-2012 10:43 PM

Have you tried


"ifconfig wlan0 up"


when you're root in a terminal? You might also want to man ifconfig and iwconfig as well.

There are no quotes when issuing this in a terminal. Start with i and end with p.


Still, try Mint live media. Mint is based on Ubuntu not debian, but there is a version that is a debian edition. Just try the KDE one.

kwill 05-10-2012 09:59 PM

It just says does not exist.

*******
ifconfig wlan0 up
wlan0: unknown interface: No such device

********

I also tried this which I found on net:

********
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Could not read interface wlan0 flags: No such device
Failed to initialize driver interface

**********

Double checking the boot log I find this after it has been updating modules:

**********

Starting wicd services: [145G[[1;32m OK [0;39m]

Bringing up loopback interface: [145G[[1;32m OK [0;39m]

Bringing up interface eth0: [145G[[1;32m OK [0;39m]

Bringing up interface wlan0: Device wlan0 does not seem to be present, delaying initialization.
[145G[[1;31mFAILED[0;39m]

Waiting for network to be up[145G[[1;32m OK [0;39m]

***********

This is what happens when you try to setup wlan0 using drakconnect. When I try to specifically set it to use the Broadcom driver it still refuses as the driver is already in kernel.

*****************

May 9 13:25:49 HP3000 net_applet[5330]: running: /usr/bin/draknetcenter
May 9 13:25:49 HP3000 draknetcenter[7126]: ### Program is starting ###
May 9 13:25:55 HP3000 draknetcenter[7126]: running: /bin/rpm -q --qf %{name} wireless-tools
May 9 13:25:56 HP3000 draknetcenter[7126]: running: /sbin/modprobe ndiswrapper
May 9 13:25:56 HP3000 draknetcenter[7126]: running: /sbin/modprobe -n ndiswrapper
May 9 13:25:56 HP3000 draknetcenter[7126]: running: dmidecode
May 9 13:25:56 HP3000 draknetcenter[7126]: Found settings for driver "ndiswrapper" in category "network::connection::wireless"
May 9 13:25:56 HP3000 draknetcenter[7126]: No kernel_module package for module "ndiswrapper" is required, skipping
May 9 13:25:56 HP3000 draknetcenter[7126]: Required tools package for module "ndiswrapper" is already installed, skipping
May 9 13:26:18 HP3000 draknetcenter[7126]: ### Program is exiting ###
May 9 13:29:13 HP3000 net_applet[5330]: running: /usr/bin/draknetcenter
May 9 13:29:13 HP3000 draknetcenter[7550]: ### Program is starting ###
May 9 13:29:19 HP3000 net_applet[5330]: ### Program is exiting ###
May 9 13:29:24 HP3000 draknetcenter[7550]: ### Program is exiting ###
May 9 13:52:36 HP3000 drakconf.real[11358]: ### Program is starting ###
May 9 13:52:49 HP3000 drakconf.real[11368]: ### Program is starting ###
May 9 13:53:05 HP3000 drakconnect[11395]: ### Program is starting ###
May 9 13:53:12 HP3000 drakconnect[11395]: running: /bin/rpm -q --qf %{name} wireless-tools
May 9 13:53:18 HP3000 drakconnect[11395]: running: dmidecode
May 9 13:53:18 HP3000 drakconnect[11395]: Found settings for driver "ndiswrapper" in category "network::connection::wireless"
May 9 13:53:19 HP3000 drakconnect[11395]: No kernel_module package for module "ndiswrapper" is required, skipping
May 9 13:53:19 HP3000 drakconnect[11395]: Required tools package for module "ndiswrapper" is already installed, skipping
May 9 13:54:08 HP3000 drakconnect[11395]: running: ndiswrapper -e bcmwlhigh5
May 9 13:54:09 HP3000 drakconnect[11395]: running: ndiswrapper -i /working/Computer/broadcom/bcmwlhigh5.inf
May 9 13:54:14 HP3000 drakconnect[11395]: Settings for driver "ndiswrapper" applied
May 9 13:54:14 HP3000 drakconnect[11395]: running: /sbin/modprobe ndiswrapper
May 9 13:54:14 HP3000 drakconnect[11395]: running: /sbin/modprobe -n ndiswrapper
May 9 13:54:21 HP3000 drakconnect[11395]: Found settings for driver "ndiswrapper" in category "network::connection::wireless"
May 9 13:54:21 HP3000 drakconnect[11395]: No kernel_module package for module "ndiswrapper" is required, skipping
May 9 13:54:21 HP3000 drakconnect[11395]: Required tools package for module "ndiswrapper" is already installed, skipping
May 9 13:54:27 HP3000 drakconnect[11395]: Found settings for driver "ndiswrapper" in category "network::connection::wireless"
May 9 13:54:27 HP3000 drakconnect[11395]: No kernel_module package for module "ndiswrapper" is required, skipping
May 9 13:54:27 HP3000 drakconnect[11395]: Required tools package for module "ndiswrapper" is already installed, skipping
May 9 13:54:32 HP3000 drakconnect[11395]: ### Program is exiting ###


*******************************

kwill 05-10-2012 10:11 PM

Apologies,

The new kernel was put into menu.lst but at the bottom after other Linux distro's not under previous PCLinuxOS kernel as is usual.

It is definitely running the new kernel.

jschiwal 05-10-2012 10:28 PM

Are you using the b43 module or ndiswrapper? If it is b43, run "modinfo b43". It should list the firmware it expects. If you are using ndiswrapper, you may need to rewrap the driver. Years ago, when my laptop had a broadcom wireless device and bcm43xx wasn't available for my x86_64 kernel, I think I remember running rpmbuild (openSuSE), as the ndiswrapper source had a SPECS file for building RPMs. I seem to remember you could build Debian packages as well.

If you use the b43 driver, re-run the b43_fwcutter to cut out the firmware.

Ubuntu uses the STA driver.

Check in /etc/modprobe.d/. Check if the driver you think you are using is blacklisted.

Run "sudo /sbin/depmod -a" to rebuild the modprobe dependancy files (depmod files in /lib/modules/). This should have been done when you upgraded your kernel, but failed for some reason.

mdlinuxwolf 05-11-2012 04:10 AM

Another "TFE" thing to do is physically remove the wireless card. Boot up. Log in as root in a terminal. Run ifconfig. Then shut down. Reinstall the wireless card. Boot up and run ifconfig or the wireless utility again. Sometimes this works.


If you have yumex or synaptic, reinstall the new kernel. Also try to get physical access to an Ethernet connection. A cable or DSL modem will work. Plug into the wired connection and run the update program.


Of course we also need to rule out a hardware issue. Test the wireless with any live distribution or in a known good computer, even M$. If nothing works, then your hardware failed at the same time you updated.


See if you can get PClinuxOS's HCL. Wireless cards can usually be had for under $50.

Again, this isn't the most sophisticated way to fix it, but a known compatible card takes less then 10 minutes to install. I would avoid USB wireless. Linux doesn't play nice with these. Get an internal PCI wireless card. Amazon will mail it to your house.

Switching distros or extensive trouble shooting takes up way too much time.

You can also get a wireless Ethernet bridge, but you'll need to add wpa_supplicant to your Ethernet configuration or run an open unsecure network.

I'm not quite sure how to add wpa_supplicant to th Ethernet because I haven't done it before.

kwill 05-11-2012 06:01 AM

It is a USB dongle. When you remove or replug it is correctly detected. The Dongle was working with the Broadcom module built into previous kernel. Again if you attempt to setup the interface with Drakeconnect it says module already installed.

There was an update to Broadcom driver a couple of weeks back. On previous kernel Wicd would automatically connect which it wouldn't do before. Also other OS on machine (Kubuntu 8.04) also had the update and it worked perfectly, previously it hadn't worked at all. So the Broadcom kernel module seems now to be pretty good.

Tried "sudo /sbin/depmod -a" after a couple of minutes command completed but nothing in any log. After completion tried "service network restart " same as before "Bringing up interface wlan0: Device wlan0 does not seem to be present, delaying initialization. FAILED"

I just don't see why "interface wlan0" or "device wlan0" isn't there. Might have to try reinstalling kernel tomorrow, also will check that the dongle still works under Kubuntu

mdlinuxwolf 05-11-2012 06:20 AM

Quote:

Originally Posted by kwill (Post 4675842)
It is a USB dongle. When you remove or replug it is correctly detected. The Dongle was working with the Broadcom module built into previous kernel. Again if you attempt to setup the interface with Drakeconnect it says module already installed.

There was an update to Broadcom driver a couple of weeks back. On previous kernel Wicd would automatically connect which it wouldn't do before. Also other OS on machine (Kubuntu 8.04) also had the update and it worked perfectly, previously it hadn't worked at all. So the Broadcom kernel module seems now to be pretty good.

Tried "sudo /sbin/depmod -a" after a couple of minutes command completed but nothing in any log. After completion tried "service network restart " same as before "Bringing up interface wlan0: Device wlan0 does not seem to be present, delaying initialization. FAILED"

I just don't see why "interface wlan0" or "device wlan0" isn't there. Might have to try reinstalling kernel tomorrow, also will check that the dongle still works under Kubuntu


I have never had any luck getting any USB wireless device to work in Linux, ever -- failure rate 100%. PCM-CIA cards and PCI cards, not a problem. There are just certain things that linux flat out doesn't like to do. I'm surprised that the dongle ever worked at all. Basically those are for M$ only.

I'm sure that if you get the right equipment, you'll be fine. Just buy something that has been out for at least 6 months, preferably a year or more. Use the linux drivers not ndiswrapper. For less then $50, problem solved.

sheebu 06-04-2012 04:53 PM

I am using usb wireless device (zte ac2737) with centos 6.2 success fully
 
I am using usb wireless device (zte ac2737) with centos 6.2 success fully

I faced same wireless device problem in centos 6.2. zte ac2737 some time fail to shown up in nm-applet for connection. I get around this problem using usb_modswitch.
After couple of time using usb_modswitch now its loading automatically without any problem.

my wireless device is zte ac2737

so I used the command
usb_modeswitch --default-vendor=0x19d2 --default-product=0xfff1




please refer http://www.draisberghof.de/usb_modeswitch

mdlinuxwolf 06-05-2012 08:09 AM

The next logical step is to check out your hardware compability list and then newegg or tiger direct. I'm not saying the script above won't work, just that giving Linux something it likes is the "TFE" way to go. Fighting with it gives you mixed results... usually a bad mix.


All times are GMT -5. The time now is 12:45 PM.