LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Network fstab entries not being mounted at boot (http://www.linuxquestions.org/questions/linux-networking-3/network-fstab-entries-not-being-mounted-at-boot-396348/)

tisource 12-24-2005 09:35 PM

Network fstab entries not being mounted at boot
 
I've got OpenSUSE (10.0) and am having an issue with network related entries in my fstab. They're not happening! I have a cifs mount at the bottom of my fstab, and after the system boots, it isn't there!

After I login to KDE, can do "mount -a" as root, and all is well. Why not at boot???

Do I need to add something to my fstab so it loads at boot???

My local fstab entries (various partitions, subfs, etc) all work fine.

runlevel0 12-25-2005 04:08 PM

Quote:

Originally Posted by tisource
I've got OpenSUSE (10.0) and am having an issue with network related entries in my fstab. They're not happening! I have a cifs mount at the bottom of my fstab, and after the system boots, it isn't there!

After I login to KDE, can do "mount -a" as root, and all is well. Why not at boot???

Do I need to add something to my fstab so it loads at boot???

My local fstab entries (various partitions, subfs, etc) all work fine.


I'm sure they work, but we cannot guess how they look like, posting them would be a good idea.

So, thinking on the most frequent errors:

The partitions can be configured with the noauto option, this means that they are not going to be mounted at boot time, but they can be mounted either by hand or automatically (like CDROM dirves or DVD's). Removing this option should mount the partitions at startup.

It can also be, that the partitions are configured with the _netdev option, in which case the partition refuses to mount if there is no network connection.

It can also be, that you lack permissions, that the probes for a Samba network are negative...

There are plenty of options, but to be 100% sure, just copy and past your fstab here ;)

tisource 12-25-2005 05:33 PM

Here's my fstab entry:

//10.0.0.12/data /media/net/fs2/data cifs credentials=/etc/samba/fs2.auth 0 0

I should also tell you I had a NFS mount here (to the same network folder), and it did the same thing (required manual mount). We implemented a firewall on the server I'm connecting to, and found NFS to be too much of a hassle (from a firewall standpoint), so I switched to CIFS.

When I do mount the share, I do 'mount -a' as root and it mounts fine.

runlevel0 12-25-2005 06:04 PM

Quote:

Originally Posted by tisource
Here's my fstab entry:

//10.0.0.12/data /media/net/fs2/data cifs credentials=/etc/samba/fs2.auth 0 0
I should also tell you I had a NFS mount here (to the same network folder), and it did the same thing (required manual mount). We implemented a firewall on the server I'm connecting to, and found NFS to be too much of a hassle (from a firewall standpoint), so I switched to CIFS.

When I do mount the share, I do 'mount -a' as root and it mounts fine.

This is very strange. Chances are you are missing to set the correct user, not the user for authentification purposes, but the user as seen form the 'unix' part.

Code:

uid=YourUser
Other things to try would be the modules: It could be that the modules are not loaded at the correct time and thus causes the mounting to fail. I don't know how the modules or the daemon are called, but if you find out place it in your /etc/modules script, so that it's loaded during the boot process.

Finally, place the option _netdev as an option on every line belonging to network devices; this will not solve your problem, but it will skip trying to mount these devices when they are not reachable and thus avoiding wasting time during the boot process.

Hope this helps...

tisource 12-26-2005 10:47 AM

Okay...

First, I don't have an /etc/modules file.

Second, the samba client will enumerate user and group permissions over the mount. In other words, as long as I have the same groups and same usernames on both sides (client and server), with matching uids and gids, all is well (from a permission standpoint)... like a NFS mount. I don't think UID is the issue here.

I checked /etc/init.d/rc5.d on the workstation, and found my network script is at S05, just after dbus and resmgr.

I should also mention I'm bridging with a static ip, which is created just after the networks script (S06). Why? I have a laptop I often plug into the network, and unfortunately, there is only one connection port at my station. My workstation has a gigabit network connection, but also has an on-board (mobo) 100 Mbps connection that wasn't being used. So, I have a crossover cable coming out of the 100 Mbps that I use for the laptop... share the LAN connection thru the workstation. I bridge, but I have an IP assigned to the bridge, so my workstation can also communicate with the network.

Once mounted, the network connection works flawlessly. The problem is, I reboot often (dual-boot XP/Linux setup). Every time I boot back into Linux, I have to remount my connections.


All times are GMT -5. The time now is 02:44 PM.