LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 12-06-2009, 12:30 AM   #1
FunctionSys
LQ Newbie
 
Registered: Dec 2009
Location: Hacker Pool
Posts: 2

Rep: Reputation: 0
Network & internet in BT4 - With VMware Workstation 7


Greetings to you

Dear Expert in Linux,,
MY OS IS (Widnows XP )
I'm Using VMware Workstation 7 to run My BT4-Beta (backtrack 4)

in my OS Windows XP I have Internet I'm in big network our administrator using Cyberoam Client for Corporate to allow people using Internet ..
so if any people connect this network they should has id in Cyberoam if they don't has id will can't connect to the internet .. they will redirect automatically to the log in page in Cyberoam


so ! in VMware Workstation 7 i configure network adapter to Bridged
and i see internet icon with green color but dose not browse internet
and also i can't ping my computer this is mean network dose not appear to backtrack my computer is in the network when i try to do ping this is what happened
root@bt:~# ping 172.16.2.102
connect: Network is unreachable
root@bt:~#


and this output to try run network !

PHP Code:
Stopping NetworkManager...                                            [ OK ]
 * 
Starting NetworkManager...                                            [ OK ]
root@bt:~# ifconfig eth0 up
root@bt:~# lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX 82443BX/ZX/DX Host b
ridge 
[8086:7190] (rev 01)
00:01.0 PCI bridge [0604]: Intel Corporation 440BX/ZX/DX 82443BX/ZX/DX AGP bri
dge 
[8086:7191] (rev 01)
00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110]
 (
rev 08)
00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:71
11
] (rev 01)
00:07.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (r
ev 08
)
00:07.7 System peripheral [0880]: VMware Inc Virtual Machine Communication Inter
face 
[15ad:0740] (rev 10)
00:0f.0 VGA compatible controller [0300]: VMware Inc Abstract SVGA II Adapter [1
5ad
:0405]
00:10.0 SCSI storage controller [0100]: LSI Logic Symbios Logic 53c1030 PCI-X
Fusion
-MPT Dual Ultra320 SCSI [1000:0030] (rev 01)
00:11.0 PCI bridge [0604]: VMware Inc PCI bridge [15ad:0790] (rev 02)
00:15.0 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.1 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.2 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.3 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.4 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.5 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.6 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:15.7 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.0 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.1 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.2 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.3 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.4 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.5 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.6 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:16.7 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.0 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.1 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.2 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.3 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.4 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.5 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.6 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:17.7 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.0 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.1 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.2 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.3 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.4 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.5 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.6 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
00:18.7 PCI bridge [0604]: VMware Inc Device [15ad:07a0] (rev 01)
02:00.0 USB Controller [0c03]: Intel Corporation 82371AB/EB/MB PIIX4 USB [8086:7                                           112]
02:01.0 Ethernet controller [0200]: Advanced Micro Devices [AMD79c970 [PCnet32                                            LANCE] [1022:2000] (rev 10)
02:02.0 Multimedia audio controller [0401]: Ensoniq ES1371 [AudioPCI-97] [1274:1                                           371] (rev 02)
02:03.0 USB Controller [0c03]: VMware Inc Abstract USB2 EHCI Controller [15ad:07                                           70]
root@bt:~
and this is my ifconfig

root@bt:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0c:29:bc:31:03
inet6 addr: fe80::20c:29ff:febc:3103/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:258 (258.0 B) TX bytes:468 (468.0 B)
Interrupt:19 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 B) TX bytes:200 (200.0 B)

root@bt:~#


please give me Structure how to do Step by Step to connect the network using VMware WorkStation !


please it's very urgent you can't do anything without internet !
i hope you understand me
 
Old 12-07-2009, 12:46 AM   #2
FunctionSys
LQ Newbie
 
Registered: Dec 2009
Location: Hacker Pool
Posts: 2

Original Poster
Rep: Reputation: 0
Greetings to you

i know the solution do this
1- make sure you configure VM -> Settings ->Network Adapter -> Bridged
2- when you run BT4 (root - toor )
3- run this command /etc/init.d/networking start
4- Startx

then you will able to connect the internet ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do VMware server 2 faster than VMware workstation 6.5? wanas Linux - Software 5 12-17-2008 08:29 AM
illusive IP command & troubleshooting network/USB connection on a CoreOS workstation oceanarches Linux - Newbie 8 08-27-2008 05:12 PM
RHEL 5 & VMWare Workstation Beta 6 SimoneDice Red Hat 9 04-18-2007 12:03 PM
VMware Server & Workstation Do Nothing jeelliso Linux - Software 4 11-14-2006 12:57 AM
Using VMWare 3.0 Workstation asb12973 Linux - General 2 06-08-2002 01:05 AM


All times are GMT -5. The time now is 03:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration