LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-11-2005, 05:11 AM   #1
English_Man
Member
 
Registered: Feb 2004
Location: Stockholm SWEDEN
Distribution: Kubuntu 9.04
Posts: 54

Rep: Reputation: 15
Netstat issues 'warning, got duplicate tcp line'


Hi there. I run a BitTorrent tracker, it runs on FC3 and has an average of 150,000+ peers. This is not a problem the server is running fine.

The tracker runs on many ports, but these ports are not being used by any other applications.

When doing a netstat all I get is hundreds of 'warning, got duplicate tcp line' lines.

I have googled this and it appears to be a RH/FC issue only. Is there a fix for this or anything?

Any help appreciated,

E_Man
 
Old 09-11-2005, 08:59 AM   #2
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Strange... is it possible there is a bug in this particuliar version of netstat? Have you tried to update net-tools, maybe?
 
Old 09-11-2005, 10:28 AM   #3
English_Man
Member
 
Registered: Feb 2004
Location: Stockholm SWEDEN
Distribution: Kubuntu 9.04
Posts: 54

Original Poster
Rep: Reputation: 15
[english_man@NOA001 ~]$ netstat --version
net-tools 1.60
netstat 1.42 (2001-04-15)

Everything is up-to-date acording to yum.

E_Man
 
Old 09-11-2005, 10:48 PM   #4
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
The same version as I have, but I doN't have much trafic (at leat not 10 000+ connections) I can't judge
 
Old 08-06-2008, 05:47 AM   #5
insanewhiz
LQ Newbie
 
Registered: Apr 2008
Posts: 3

Rep: Reputation: 0
Fix.

Edit the following file to fix this problem
Add or modify text as follows:

# vi /etc/sysctl.conf

net.ipv4.tcp_tw_reuse = 0
net.ipv4.tcp_tw_recycle = 0

# sysctl -p

The above command will help the new settings to take effect.
 
Old 04-13-2009, 03:07 AM   #6
michelle02012007
LQ Newbie
 
Registered: Jul 2008
Posts: 21

Rep: Reputation: 16
Quote:
Originally Posted by insanewhiz View Post
Edit the following file to fix this problem
Add or modify text as follows:

# vi /etc/sysctl.conf

net.ipv4.tcp_tw_reuse = 0
net.ipv4.tcp_tw_recycle = 0

# sysctl -p

The above command will help the new settings to take effect.
I don't know if the one who ask solved this issue? i tried this but nothing happen. Do i need to reboot the machine or is there a way that i don't have to reboot.

TY
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have a warning that i want to eliminate in the folowing line: ... grupoapunte Programming 2 05-08-2005 08:33 PM
TCP/IP configuration issues falconkid Linux - Networking 17 12-22-2004 04:10 PM
WARNING: linux/tcp present but cannot be compiled qwijibow Linux - General 1 07-16-2004 10:21 PM
WARNING: Bad format on line 10 of /etc/fstab thetwin Linux - Newbie 22 03-05-2003 12:55 AM
netstat doesn't show tcp sockets in Redhat 7.2 pfpalmer Linux - General 3 10-31-2002 03:04 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration