LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-24-2005, 02:24 PM   #1
Steve1445
LQ Newbie
 
Registered: Jan 2004
Location: Charleston, SC
Distribution: Redhat 9.0
Posts: 15

Rep: Reputation: 0
net join ads command


Trying to join a RH 9.0 box with Samba 3.0 and KBR5 on it to a Win2K domain. Seem to be making headway however when I use the net command from the /usr/local/samba/sbin folder or anywhere else it always comes back with a net: command not found. I know that I must be typing this wrong, or something , anyone care to set me straight?
 
Old 02-24-2005, 05:11 PM   #2
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
It really depends on how you installed Samba. I'm using RH9 and installed Samba from an RPM I downloaded via the Samba.org site. I have net in /usr/bin.
You can always try:

find / -name net

and see if you can find the net command. If it doesn't find it anywhere, something must have gone wrong with your install. I'd try a re-install of Samba.
 
Old 02-24-2005, 06:30 PM   #3
Steve1445
LQ Newbie
 
Registered: Jan 2004
Location: Charleston, SC
Distribution: Redhat 9.0
Posts: 15

Original Poster
Rep: Reputation: 0
thanks for the reply

I have the net command and am launching the command directly out of the bin folder under Samba. Did the install just like you did, but the net command does nada. Just returns an error.
 
Old 02-25-2005, 05:53 AM   #4
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
If it's always returning a command not found error even when your current directory is the directory where net is located, perhaps you have a problem with your PATH. Linux, unlike windows, will not automatically look in the current directory for a command you execute unless it is in your PATH.

From the current directory where net is located, execute:

./net [options]

and see if that works.

You can also try to use the complete path to net such as:

/usr/bin/net [options]
 
Old 02-25-2005, 07:44 AM   #5
Steve1445
LQ Newbie
 
Registered: Jan 2004
Location: Charleston, SC
Distribution: Redhat 9.0
Posts: 15

Original Poster
Rep: Reputation: 0
worked

That did the trick, using ./ before the net command. Something simple yet vital. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help using 'net join' to join a windows domain Wapo Linux - Networking 1 04-28-2006 02:30 AM
IBM ads vs. the Intel ads on TV vharishankar General 1 03-16-2005 05:47 AM
Samba 3.0.0 installed on RH WS3, but "net join" command not found chloevu Linux - Networking 0 07-13-2004 03:20 PM
"net ads join" command not found with samba 3.0.2a tisource Linux - Networking 2 04-15-2004 03:38 PM
Join the LinuxQuestions distributed.net team jeremy Linux - Security 1 10-17-2000 11:58 AM


All times are GMT -5. The time now is 08:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration