LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   need to connect blu-ray player to wireless internet (http://www.linuxquestions.org/questions/linux-networking-3/need-to-connect-blu-ray-player-to-wireless-internet-774246/)

schneidz 12-08-2009 09:56 AM

need to connect blu-ray player to wireless internet
 
hi, i just got an lg blu-ray player (by and by, the manual says that it is running a busybox installation).

i tried plugging in a usb wifi adapter to it but that seems not to work.

my plan now is to connect it using cat-5 cable to my laptop running fedora-11 live-usb (my laptop can connect to my wireless router upstairs).

how do i configure fedora to share the internet connection to the blu-ray player so that it can use the netflix streaming capability ?

thx,

jkzfixme 12-08-2009 01:14 PM

First things first the ethernet cable has to be a crossover cable , and this should bring you the rest of the way there.

Regards,
JKZfixme

schneidz 12-18-2009 05:26 PM

^ tahnks for the link; i cant find gsheild and firestarter seems a little buggy.

is there anything someone can prescribe that works via the command line ?

rite now i have my fedora-live-11-usb laptop connected via crossover cable to the blueray player. but it still says the dynamic network connection is not working. (i also tried it setting a static ip).

schneidz 12-18-2009 07:04 PM

i now get network is connected on the blurays settings menu.

but when i try to use youtube, pandora, cinimanow or netflix i get cant connect to internet...

nimnull22 12-18-2009 07:22 PM

Connect it to wireless router instead, if it has empty ethernet slots.

schneidz 12-19-2009 10:48 AM

^ that would be ideal except that i would need to move my tv upstairs to my office or my pc downstairs to the living room.

nimnull22 12-19-2009 11:00 AM

Move router downstairs.
Or you can think about to buy 5-cat ethernet cable and put it in your house.
But before check if it will work like this. Connect it to router and check.

schneidz 12-19-2009 11:11 AM

Quote:

Originally Posted by schneidz (Post 3797364)
i now get network is connected on the blurays settings menu.

but when i try to use youtube, pandora, cinimanow or netflix i get cant connect to internet...

it seems to get an ip-address ok from the laptop.

maybe i have some wrong iptables rule and it is not forwarding my internet connection well.

michaelk 12-19-2009 11:28 AM

There are many links that explain how to configure internet connection sharing using linux.
Here are some links to get you started. In your case to share your wireless you would use the following rule instead.
iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

http://www.cyberciti.biz/faq/rhel-fe...sharing-howto/
http://lindesk.com/2007/04/internet-...sing-iptables/

Are you using a different subnet for the player then the router's

schneidz 12-19-2009 12:03 PM

^ i was using this as a guide but i guess there are a few typpos:
http://newbiedoc.sourceforge.net/net...megateway.html
i get this error in 9.2.2:
Code:

/sbin/iptables -A INPUT -m state --state NEW -i ! eth0 -j ACCEPT
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).

and this doesnt seem rite:
Code:

/sbin/iptables -A FORWARD -i eth0 -o eth0 -j REJECT
is that forwarding eth0 packets to eth0 (in my case eth2 to eth2) ? wouldnt i want to send eth1 packets to eth2 -or- eth2 to eth1 ?
i dont think neither worked.

Code:

[liveuser@localhost ~]$ ifconfig && iwconfig
eth1      Link encap:Ethernet  HWaddr 00:26:55:57:xx:xx 
          inet addr:192.168.15.1  Bcast:192.168.15.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Memory:98400000-98420000

eth2      Link encap:Ethernet  HWaddr 00:26:82:04:xx:xx 
          inet addr:10.0.0.116  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::226:82ff:fe04:615b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13211 errors:1 dropped:0 overruns:0 frame:11615
          TX packets:13721 errors:8 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10738762 (10.2 MiB)  TX bytes:2252115 (2.1 MiB)
          Interrupt:17

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)

lo        no wireless extensions.

eth1      no wireless extensions.

pan0      no wireless extensions.

eth2      IEEE 802.11  Nickname:""
          Access Point: Not-Associated 
          Link Quality:4  Signal level:194  Noise level:164
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

[liveuser@localhost ~]$ ping www.something.com
PING Friday.westnet.com (216.187.52.6) 56(84) bytes of data.
64 bytes from Friday.westnet.com (216.187.52.6): icmp_seq=1 ttl=243 time=168 ms
64 bytes from Friday.westnet.com (216.187.52.6): icmp_seq=2 ttl=243 time=155 ms
^C
--- Friday.westnet.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1723ms
rtt min/avg/max/mdev = 155.323/162.053/168.784/6.742 ms


lazlow 12-19-2009 12:15 PM

Quote:

First things first the ethernet cable has to be a crossover cable ,
If either end is GigE then the above statement is not true. GigE will automatically handle doing this without using a crossover cable.

schneidz 12-19-2009 03:27 PM

i finally got it to work but i was just randomly typing commands i found on sites like http://www.yolinux.com/TUTORIALS/Lin...rkGateway.html .

now i am afraid that if i restart my laptop i wont be able to retrace my steps.

schneidz 12-25-2009 10:55 PM

here's the final score:
eth0 is my ethernet card connected to my blu-ray player via crossover cable (i also tried with a regular cat-5 cable and it worked just the same).
eth1 is my wifi adapter connected to my netgear router upstairs.

i ran:
Code:

[liveuser@localhost ~]$ cat masq.ksh
/sbin/ifconfig eth0 192.168.10.101 netmask 255.255.255.0 broadcast 192.168.10.255
  iptables --flush           
  iptables --table nat --flush
  iptables --delete-chain   
  iptables --table nat --delete-chain
  iptables --table nat --append POSTROUTING --out-interface eth1 -j MASQUERADE
  iptables --append FORWARD --in-interface eth0 -j ACCEPT
  echo 1 > /proc/sys/net/ipv4/ip_forward
route add  -net 192.168.10.0  netmask 255.255.255.0 gw 192.168.5.1 dev eth0

on the fedora laptop.
and then put in the settings for my blu-ray player:
ip: 192.168.10.105
netmask: 255.255.255.0
gateway: 192.168.10.101
dns: 192.168.5.1 (my netgear router)

done,


All times are GMT -5. The time now is 02:29 AM.