LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-29-2001, 11:12 AM   #1
hairball
LQ Newbie
 
Registered: May 2001
Posts: 2

Rep: Reputation: 0
Unhappy


I just installed the new 2.4.5 kernel on my slackware 7.1 machine after upgrading all the utilities to the required versions as per the Documentaion/Changes file. Everything in my 2.2.16 kernel still boots perfectly, but when I boot the 2.4.5 kernel, my network card driver (As a module) won't load. I have a ne2000 compatible card and i used the ne.o driver under 2.2.16. I made sure to compile that driver in the new kernel as a module, but it just won't load. when i type:
insmod ne io=0x240 (the io of the card. this works under 2.2.16)
all i get is an error message something to the effect of:
/lib/modules/2.4.5/kernel/drivers/net/ne.c: Device not configured
it also says this could be due to bad IRQ or IO but this is the same command i use to get the card to work under 2.2.16. any idea what I could be missing that might cause the driver to not load? thanks in advance
 
Old 05-30-2001, 08:32 AM   #2
siddiqu
Member
 
Registered: Mar 2001
Location: India
Posts: 332

Rep: Reputation: 30
Hi..


First try to load manually by loadin 8390.o first and then load ne.o . If it is loading then include the 8390.o in conf.modules/module.conf

siddiqu.T
 
Old 05-30-2001, 12:39 PM   #3
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Try modprobe instead of insmod, it will load the dependencies for you. The only other thing I can think is happening is 2.4.5's PnP support is changing your base address. If you are able to; use the DOS config util for your card, and take it off of PnP mode and set the resources yourself.

HTH

Jamie...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome 2.10 pannels don't load anymore cyborg_jt Linux - Software 2 09-17-2005 08:37 PM
2.6.3 doesn't even LOAD anymore kev^ Slackware 4 03-09-2004 01:42 PM
How to install NE2000 (ISA CARD) network driver on red hat 9 ? roykauf Linux - Networking 0 03-08-2004 12:08 PM
3c59x doesn't load anymore Anibal Slackware 1 09-19-2003 08:42 PM
mandrake9.1 won't load anymore after upgrade... crafty_guy Linux - Newbie 8 08-15-2003 08:22 PM


All times are GMT -5. The time now is 04:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration